Quantcast
Download
(155 Kb)
Download
Updated: 11/12/17 05:03 AM
Pictures
File Info
Compatibility:
Clockwork City (3.2)
Updated:11/12/17 05:03 AM
Created:10/03/17 12:50 PM
Monthly downloads:5,002
Total downloads:7,154
Favorites:32
MD5:
3.2
AlphaGear 2  Popular! (More than 5000 hits)
Version: 6.1.2
by: mesota [More]
AlphaGear 2

I've adopted this great Addon from AlphaLemming and changed the name to "AlphaGear 2" for the version that I maintain.

Important
Global settings (UI, Recharge etc.) are reinitialized with 6.1.2. Your configured sets remain valid.

Look at the Images for usage instructions!

Changes see Change Log.

What Is AlphaGear 2?

AlphaGear lets you create up to 16 combined gear/weapon/skill sets that may be activated with a single button press. Each set consists of
  • 7 pieces of armor
  • 3 pieces of jewlery
  • 2 weapon bars
  • 2 skill bars

Use cases
  • switch between different roles
  • switch between PvE and PvP environment
  • assign different skill bars to the same gear/weapon set (e.g. when a skill is not necessary in your group)


Usage Tips:
  • Bind your number pad to gear sets if you aren't using it already because they are not considered the same as your number row keys by ESO
  • Create 2 (or more) sets with the same equipment, but different skill bars to create situational skill setups (solo, group, etc...)
  • Create a radial menu using Big Picture mode with your Steam or Dual Shock 4 controller (Steam beta) to make swapping gear sets a breeze! Combine this with my first tip and set your radial menu buttons to num1, num2, etc...
  • Use /alphagear to show/hide the main window

Found a Bug? Missing Feature?

Just post a comment. I'm going to try to keep this thing working going forward for as long as I play ESO.

-mesota
Wishlist
  • More (unlimitted) set slots
  • More (unlimitted) action-bar slots
  • Grab items from the bank when pressing a hotkey tied to a gear set with bank open
  • Make AlphaGear icon visible only in the inventory screen
  • Auto-repair gear using repair-kits

Version 6.1.3 (planned)
  • Show item level for items below CP160
  • Bugfix: Mouse-Cursor Problem
  • Bugfix: Set-Display corrupted if no set is selected

Version 6.1.2
  • Bugfix: Auto-Repair Option not saved
  • Bugfix: Show UI-Button Option not saved

Version 6.1.1
  • ESO 3.2 (Clockwork City)
  • Name changed to AlphaGear 2
  • Settings rework using LibAddonMenu-2.0
  • Internationalization (Russian, Chinese, Japanese)
  • Enhancements
    • Make Gear/Weapon Icon movable
    • Auto-repair gear in stores

Version 6.1.0
  • ESO 3.2 (Clockwork City)
  • New slash-command: /alphagear to toggle the main dialog
  • Minor performance optimizations

Version 6.0.1
  • ESO 3.1 (Horns of the Reach)
  • Adopted by mesota
  • Fixed a bug, where automatic recharging of weapons sometimes didn't work
  • Fixed a rounding error where a weapon was shown with "0%"

Version 6.0.0
  • ESO 3.1 (Horns of the Reach)
  • Adopted by mesota
  • No functional changes since 5.0

Version 5.0
  • ESO 2.6 (One Tamriel)
  • Adopted by Lohengramm82
  • Code commented
  • No functional changes since 4.08

Version 4.08
  • ESO 2.4
  • Poison error fixed
  • Some minor problems fixed

Older versions see the original AlphaGear by AlphaLemming
Archived Files (4)
File Name
Version
Size
Author
Date
6.1.1
155kB
mesota
11/11/17 10:52 AM
6.1.0
104kB
mesota
10/24/17 03:26 PM
6.0.1
104kB
mesota
10/15/17 04:28 PM
6.0.0
103kB
mesota
10/03/17 12:50 PM


Post A Reply Comment Options
Unread 11/13/17, 05:30 PM  
Migoda
AddOn Author - Click to view AddOns

Forum posts: 14
File comments: 77
Uploads: 1
The cursor problem is fixed with beta-2. Thanks again!
Report comment to moderator  
Reply With Quote
Unread 11/13/17, 03:16 PM  
mesota
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 26
Uploads: 3
Originally Posted by Kalidor187
Ok I've narrowed down the root of the cursor problem. Clicking on the old settings button inside the alphagear window, which sends you to addon settings menu, generates the problem. Reloading the ui will fix it. Thanks, JimBobMcKrakken, for the lightbulb about moving the windows.
Thanks for digging into! I could reproduce (and fix) the problem with your help.
Please give beta-2 a try. Should work now.

Thanks again
-mesota
Report comment to moderator  
Reply With Quote
Unread 11/13/17, 01:46 PM  
Shaitan

Forum posts: 0
File comments: 9
Uploads: 0
Can you, please, add to the wishlist option to make AlphaGear icon visible only in the inventory screen, if such thing is possible?
Report comment to moderator  
Reply With Quote
Unread 11/13/17, 01:43 PM  
Shaitan

Forum posts: 0
File comments: 9
Uploads: 0
Yesterday the problem with mouse cursor has not repeated. But I don't remember if I changed any settings of the addon.
But I did uninstall "AlphaGear Lives" and reinstalled "AlphaGear2" via Minion.
Report comment to moderator  
Reply With Quote
Unread 11/13/17, 10:23 AM  
Migoda
AddOn Author - Click to view AddOns

Forum posts: 14
File comments: 77
Uploads: 1
Thanks for the update, it fixed the button and repair bug for me.

For the cursor problem, i can reproduce it the same way as Kalidor187. It starts when you use the cogwheel button inside the AlphaGear window to switch to the settings menu and stays until you reload the UI or relog. I also tried the beta version 6.1.3 but sadly it did not fix it.
Last edited by Migoda : 11/13/17 at 11:07 AM.
Report comment to moderator  
Reply With Quote
Unread 11/13/17, 09:33 AM  
Snakefish

Forum posts: 0
File comments: 71
Uploads: 0
Question Grafik-Bug?

Das sieht ein wenig seltsam aus:
<-Klick mich
Keine Ahnung, woran das liegt, pasiert auch nicht bei allen Chars
Last edited by Snakefish : 11/13/17 at 09:34 AM.
Report comment to moderator  
Reply With Quote
Unread 11/12/17, 07:58 PM  
Kalidor187

Forum posts: 0
File comments: 3
Uploads: 0
Ok I've narrowed down the root of the cursor problem. Clicking on the old settings button inside the alphagear window, which sends you to addon settings menu, generates the problem. Reloading the ui will fix it. Thanks, JimBobMcKrakken, for the lightbulb about moving the windows.
Last edited by Kalidor187 : 11/12/17 at 08:01 PM.
Report comment to moderator  
Reply With Quote
Unread 11/12/17, 06:54 PM  
JimBobMcKrakken

Forum posts: 0
File comments: 8
Uploads: 0
Mouse Cursor

Upon update, I had the mouse cursor issue that others mentioned. It works like this: each time you loot a container, resource, or vanquished enemy, upon accepting the items the loot window will close but the mouse will remain in cursor mode so that you have no control over your camera.

It did not matter if you moved the mouse during looting or kept it still. I reloaded the UI and the problem has disappeared. I tried to replicate it by doing the last thing I had done before having the problem, moving the weapon swap indicator, but the problem did not resume. At this point, I can only guess that it was temporary, and due to the update itself--not an actual bug.
Report comment to moderator  
Reply With Quote
Unread 11/12/17, 05:59 PM  
JimBobMcKrakken

Forum posts: 0
File comments: 8
Uploads: 0
Update

Thank you for the most excellent update. The integrated menu is nice, and I love that you can move the bar indicator (I have been hoping for that for a long time).
Report comment to moderator  
Reply With Quote
Unread 11/12/17, 05:21 PM  
Kalidor187

Forum posts: 0
File comments: 3
Uploads: 0
Re: Mouse Cursor Problem - Help wanted!

Originally Posted by mesota
Some of you report a problem, that the mouse remains in cursor mode after looting or whatever.
I can't reproduce this problem- thus I don't have a clue how to solve it.

Please:

Could someone describe exactly how to get to the problematic state?

I need:
  • Steps
  • Settings
  • Screenshots could be useful

Anyone?

-mesota
I would "suspect" it's something related to the closing window on movement option. Alphagear will close but you're left in mouse cursor mode instead of reverting to mouse look and you need to manually switch. I've also seen this behavior in mouse look mode and looting a container. You should revert to mouse look on looting and closing the container but retains the mouse cursor mode. Also seen in leaving some menu screens.

Reverting to a previous version along fixes this, not thinking it's a conflict with another addon.

Not a huge deal but it makes things seem clunky because it's unexpected behavior. Thank you for keeping the addon alive, we truly appreciate it!
Report comment to moderator  
Reply With Quote
Unread 11/12/17, 04:19 PM  
mesota
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 26
Uploads: 3
Re: Set-Buttons

Originally Posted by Snakefish
Kann man bitte die Set-Buttons, wie in der alten Version, limitierbar bzw abschaltbar machen.
Ich möchte die nicht auf dem Schirm haben.
Danke
Kann man wie gehabt unter Einstellungen/Erweiterungen/AlphaGear/Sets einstellen.

-mesota
Report comment to moderator  
Reply With Quote
Unread 11/12/17, 03:15 PM  
Snakefish

Forum posts: 0
File comments: 71
Uploads: 0
Exclamation Set-Buttons

Kann man bitte die Set-Buttons, wie in der alten Version, limitierbar bzw abschaltbar machen.
Ich möchte die nicht auf dem Schirm haben.
Danke
Report comment to moderator  
Reply With Quote
Unread 11/12/17, 12:16 PM  
mesota
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 26
Uploads: 3
Mouse Cursor Problem - Help wanted!

Some of you report a problem, that the mouse remains in cursor mode after looting or whatever.
I can't reproduce this problem- thus I don't have a clue how to solve it.

Please:

Could someone describe exactly how to get to the problematic state?

I need:
  • Steps
  • Settings
  • Screenshots could be useful

Anyone?

-mesota
Report comment to moderator  
Reply With Quote
Unread 11/12/17, 11:15 AM  
cag_dk

Forum posts: 5
File comments: 9
Uploads: 0
still problems...

Still got the mouse cursor problem ver. 6.1.2
Report comment to moderator  
Reply With Quote
Unread 11/12/17, 11:08 AM  
Mulcibur

Forum posts: 0
File comments: 39
Uploads: 0
Originally Posted by Shaitan
Originally Posted by Kalidor187
Automatic changing of mouse cursor to mouse look on movement has been disabled.

Looting containers and leaving menus leaves you in mouse cursor mode.
Have the same problem, but not sure if it is because of this addon...
Have the same problem. It's Alphagear since the update.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: