Quantcast
Download
(57 Kb)
Download
Updated: 11/26/17 09:39 PM
Pictures
File Info
Compatibility:
Clockwork City (3.2)
Horns of the Reach (3.1)
Morrowind (3.0)
Updated:11/26/17 09:39 PM
Created:07/04/17 05:45 PM
Monthly downloads:543
Total downloads:2,056
Favorites:4
MD5:
3.2
Where's My Guild Hall
Version: 1.1.4
by: Shadowfen [More]
Shows the available "guild halls" for your guild on the guild home screen.

It allows you to set for each of your guilds individually if you want to assume that the guild master owns a guild hall, and/or if you want the addon to look for the "Guild Hall List" (GHL) addon marker characters "<GH" in the guild member notes.

If you turn on Guild Master Owner, then the guild master will always be listed first in the guild halls list on the Guild home page. The guild master will then be followed by any guild members that have the GHL marker in their guild member notes (if you have turned on Guild Hall List compatibility mode).

This addon conflicts with Guild Hall List - primarily because we try to use the exact same spot on the Guild page for our guild hall lists.

I wrote this addon because sirinsidiator's excellent Guild Hall List addon did not assume that the guild master owned the guild hall - instead, it required the guild hall owner to put the "<GH" marker in their member notes. Unfortunately, the guild hall owners for my guilds did not wish to add the "<GH" marker so that I could use the addon. Sirinsidiator did not wish to add guild masters as owners to his addon because in his guilds, some of the guild hall owners were not the guild masters. So, this addon was born...
1.1.4
  • Rewrote code where Where's My Guildhall would see an "attempt to index nil value" error when a guild note was changed in one of your guilds. If any of you see this error again, please let me know.
  • Changes to the WheresMyGuild settings for the current guild will now automatically update in the Guild page instead of requiring to to look at another guild and then come back to the guild that you just changed the settings for.
  • Changes that you make to your guild notes (to add or remove a guild hall marker) will now automatically be updated on the Guild Home page.
  • Upgraded LibAddonMenu to r25.

1.1.3
  • Theoretically fixed an error where Where's My Guildhall would see an "attempt to index nil value" error when a guild note was changed in one of your guilds. If any of you see this error again, please let me know.

1.1.2
  • Modified the settings saves so that it distinguishes which megaserver you are currently on. This change will require everyone to redo their settings so they can be saved properly for the megaserver(s) that they play on, but it allows people to play on multiple megaservers without getting the savedvariables corrupted.

1.1.1
  • Revised the settings text so the important part doesn't get cut off.

1.1.0
  • Added a new marker style for guild notes. Now you can choose to have it look for the words "Guild Hall" (with exactly that capitalization) in the guild notes. This is turned off by default.
  • Fixed the guild hall list so that people are only listed once on it even if they are the Guild Master and have "<GHL" and "Guild Hall" in their personal notes. Previously, they would have been listed multiple times.

1.0.4
  • Fixed problem with loading the saved variables.
  • Fixed problem with displaying guild halls for the very first guild before data was loaded.
  • Fixed lua error that was occurring when the guild MOTD was getting changed.

1.0.3
  • Bump up the API version.
  • Upgraded LibAddonMenu to 2.0_r24.

1.0.2
  • Reworked how the guild settings were rematched to the player's active guilds.
  • Reworked the processing to do only as much as absolutely necessary at a time in order to increase performance.
  • Created a library to put my commonly used functions in so they can be available to all of my addons.

1.0.1
  • Fixed some problems where the guild hall lists just went away.
  • Fixed problem where sometimes the guild halls listed were for a different guild than the one currently on the Guild Home page.

1.0
  • Works with Morrowind
  • Initial release by Shadowfen
Optional Files (0)


Archived Files (9)
File Name
Version
Size
Author
Date
1.1.3
58kB
Shadowfen
11/17/17 12:27 AM
1.1.2
58kB
Shadowfen
10/14/17 05:34 PM
1.1.2
58kB
Shadowfen
10/09/17 03:17 PM
1.1.0
58kB
Shadowfen
10/05/17 06:58 PM
1.0.4
57kB
Shadowfen
08/26/17 10:46 PM
1.0.3
57kB
Shadowfen
08/15/17 07:13 PM
1.0.2
55kB
Shadowfen
07/11/17 07:20 PM
1.0.1
53kB
Shadowfen
07/06/17 08:30 PM
1.0.1
53kB
Shadowfen
07/04/17 05:45 PM


Post A Reply Comment Options
Unread 12/02/17, 10:38 AM  
patrick_smyth
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 6
Uploads: 1
Originally Posted by PBnicos
Getting an error each time i log-in with any char:

user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: attempt to index a nil value
stack traceback:
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: in function 'loadActiveGuilds'
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:515: in function 'onPlayerActivated'
I have just started getting this since I changed one of my five guilds today.

The first time I got it was on the first /reloadui after I left one guild and added the other. I do not do this often and it is the first time since I installed this addon.
Report comment to moderator  
Reply With Quote
Unread 12/01/17, 03:37 PM  
Shadowfen
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 100
Uploads: 3
Originally Posted by PBnicos
Getting an error each time i log-in with any char:

user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: attempt to index a nil value
stack traceback:
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: in function 'loadActiveGuilds'
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:515: in function 'onPlayerActivated'
I will check into the cause for it, but a possible solution for you would be to logout, remove the saved variables file for WheresMyGuildHall, and then log back in to ESO. You have to be out of the game for this to work because otherwise when you do a /reloadui it writes out the currently broken settings to the saved variables file before restarting.

The saved variables file (also named WheresMyGuildHall.lua) is typically saved in Documents\Elder Scrolls Online\live\SavedVariables.
Report comment to moderator  
Reply With Quote
Unread 12/01/17, 03:29 PM  
PBnicos

Forum posts: 0
File comments: 15
Uploads: 0
Getting an error each time i log-in with any char:

user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: attempt to index a nil value
stack traceback:
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: in function 'loadActiveGuilds'
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:515: in function 'onPlayerActivated'
Report comment to moderator  
Reply With Quote
Unread 12/01/17, 08:01 AM  
Shadowfen
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 100
Uploads: 3
Re: Re: Re: Error Message

[quote=patrick_smyth

I have been using the new version for a few days and the problem has not recurred.

Many Thanks [/quote]

Thanks for letting me know. It's good to know that maybe this time I crushed the bug.
Report comment to moderator  
Reply With Quote
Unread 12/01/17, 04:03 AM  
patrick_smyth
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 6
Uploads: 1
Re: Re: Error Message

Originally Posted by Shadowfen
Originally Posted by patrick_smyth
I have been using this addon for a few weeks now.

Once or twice a day a box pops up and I get this:
Code:
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:201: attempt to index a nil value
stack traceback:
	user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:201: in function 'WMGH.UpdateGHLList'
	user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:426: in function 'onGuildMemberNoteChanged'
This happens when I am not actively doing guild things. I assume something is happening in the background. I click "ignore" and it goes away.
Thank you for the report. I have tried to eliminate the error in this evening's update. Please let me know if you see it again.

Thanks.

I have been using the new version for a few days and the problem has not recurred.

Many Thanks
Report comment to moderator  
Reply With Quote
Unread 11/26/17, 09:41 PM  
Shadowfen
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 100
Uploads: 3
Re: Error Message

Originally Posted by patrick_smyth
I have been using this addon for a few weeks now.

Once or twice a day a box pops up and I get this:
Code:
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:201: attempt to index a nil value
stack traceback:
	user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:201: in function 'WMGH.UpdateGHLList'
	user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:426: in function 'onGuildMemberNoteChanged'
This happens when I am not actively doing guild things. I assume something is happening in the background. I click "ignore" and it goes away.
Thank you for the report. I have tried to eliminate the error in this evening's update. Please let me know if you see it again.

Thanks.
Report comment to moderator  
Reply With Quote
Unread 11/26/17, 04:40 PM  
patrick_smyth
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 6
Uploads: 1
Error Message

I have been using this addon for a few weeks now.

Once or twice a day a box pops up and I get this:
Code:
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:201: attempt to index a nil value
stack traceback:
	user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:201: in function 'WMGH.UpdateGHLList'
	user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:426: in function 'onGuildMemberNoteChanged'
This happens when I am not actively doing guild things. I assume something is happening in the background. I click "ignore" and it goes away.
Report comment to moderator  
Reply With Quote
Unread 11/15/17, 10:50 AM  
Shadowfen
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 100
Uploads: 3
Originally Posted by SteveCampsOut
Started getting this today....left a guild on NA last night and joined a new one today.

EDIT: Deleted Saved Variables and it's gone. Nevermind.
I'll still look into it. It's not supposed to do that...
Report comment to moderator  
Reply With Quote
Unread 11/15/17, 03:04 AM  
SteveCampsOut
 
SteveCampsOut's Avatar

Forum posts: 12
File comments: 199
Uploads: 0
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: attempt to index a nil value
stack traceback:
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: in function 'loadActiveGuilds'
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:506: in function 'onPlayerActivated'
Started getting this today....left a guild on NA last night and joined a new one today.

EDIT: Deleted Saved Variables and it's gone. Nevermind.
Last edited by SteveCampsOut : 11/15/17 at 03:08 AM.
Report comment to moderator  
Reply With Quote
Unread 10/15/17, 04:44 AM  
SteveCampsOut
 
SteveCampsOut's Avatar

Forum posts: 12
File comments: 199
Uploads: 0
Originally Posted by Shadowfen
Originally Posted by SteveCampsOut
No they merged clients almost a year ago it's just the user\documents\live\savedvariables\ folder now. This is why patch times are now the same on both servers.
Thank you. I will fix that.

Edit: Fixed. Thanks again.
Fixed indeed! Thanks!
Report comment to moderator  
Reply With Quote
Unread 10/14/17, 07:56 AM  
Shadowfen
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 100
Uploads: 3
Originally Posted by SteveCampsOut
No they merged clients almost a year ago it's just the user\documents\live\savedvariables\ folder now. This is why patch times are now the same on both servers.
Thank you. I will fix that.

Edit: Fixed. Thanks again.
Last edited by Shadowfen : 10/14/17 at 08:34 AM.
Report comment to moderator  
Reply With Quote
Unread 10/14/17, 01:35 AM  
SteveCampsOut
 
SteveCampsOut's Avatar

Forum posts: 12
File comments: 199
Uploads: 0
Originally Posted by Shadowfen
Originally Posted by SteveCampsOut
Originally Posted by Shadowfen
Originally Posted by SteveCampsOut
I'll give that a try but today there's a new problem on EU it's not working for me at all. I get the following error. It works on NA for me but EU isn't working.

user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: attempt to index a nil value
stack traceback:
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: in function 'loadActiveGuilds'
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:506: in function 'onPlayerActivated'

On EU I'm still guild-master of my guild. That's the only difference. Same addons are used on both servers.
I haven't seen those errors in a while. Could you delete the liveeu/SavedVariables/WheresMyGuildHall.lua file and then try it again to see if you get the same errors please? Thanks.
Ok I've just deleted the saved variables and the error is gone on EU. Here's my supposition. You are not segregating the saved data by server. I am in the guild Pacrooti's Hirelings on both servers and I also have characters with duplicate names on both servers. I've run into issues with this before where the addon treats all the data as if it's from one server. I will confirm it when I log into NA and I get errors there later this evening.

PS - That's what it is because now it's erroring out on the NA server.
Interesting. I thought that the saved variables were in separate directories for each server... like live and liveeu?
No they merged clients almost a year ago it's just the user\documents\live\savedvariables\ folder now. This is why patch times are now the same on both servers.
Last edited by SteveCampsOut : 10/14/17 at 01:52 AM.
Report comment to moderator  
Reply With Quote
Unread 10/13/17, 10:59 PM  
Shadowfen
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 100
Uploads: 3
Originally Posted by SteveCampsOut
Originally Posted by Shadowfen
Originally Posted by SteveCampsOut
I'll give that a try but today there's a new problem on EU it's not working for me at all. I get the following error. It works on NA for me but EU isn't working.

user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: attempt to index a nil value
stack traceback:
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: in function 'loadActiveGuilds'
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:506: in function 'onPlayerActivated'

On EU I'm still guild-master of my guild. That's the only difference. Same addons are used on both servers.
I haven't seen those errors in a while. Could you delete the liveeu/SavedVariables/WheresMyGuildHall.lua file and then try it again to see if you get the same errors please? Thanks.
Ok I've just deleted the saved variables and the error is gone on EU. Here's my supposition. You are not segregating the saved data by server. I am in the guild Pacrooti's Hirelings on both servers and I also have characters with duplicate names on both servers. I've run into issues with this before where the addon treats all the data as if it's from one server. I will confirm it when I log into NA and I get errors there later this evening.

PS - That's what it is because now it's erroring out on the NA server.
Interesting. I thought that the saved variables were in separate directories for each server... like live and liveeu?
Report comment to moderator  
Reply With Quote
Unread 10/13/17, 06:00 PM  
SteveCampsOut
 
SteveCampsOut's Avatar

Forum posts: 12
File comments: 199
Uploads: 0
Originally Posted by Shadowfen
Originally Posted by SteveCampsOut
I'll give that a try but today there's a new problem on EU it's not working for me at all. I get the following error. It works on NA for me but EU isn't working.

user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: attempt to index a nil value
stack traceback:
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: in function 'loadActiveGuilds'
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:506: in function 'onPlayerActivated'

On EU I'm still guild-master of my guild. That's the only difference. Same addons are used on both servers.
I haven't seen those errors in a while. Could you delete the liveeu/SavedVariables/WheresMyGuildHall.lua file and then try it again to see if you get the same errors please? Thanks.
Ok I've just deleted the saved variables and the error is gone on EU. Here's my supposition. You are not segregating the saved data by server. I am in the guild Pacrooti's Hirelings on both servers and I also have characters with duplicate names on both servers. I've run into issues with this before where the addon treats all the data as if it's from one server. I will confirm it when I log into NA and I get errors there later this evening.

PS - That's what it is because now it's erroring out on the NA server.
Last edited by SteveCampsOut : 10/13/17 at 08:21 PM.
Report comment to moderator  
Reply With Quote
Unread 10/12/17, 07:59 PM  
Shadowfen
AddOn Author - Click to view AddOns

Forum posts: 9
File comments: 100
Uploads: 3
Originally Posted by SteveCampsOut
I'll give that a try but today there's a new problem on EU it's not working for me at all. I get the following error. It works on NA for me but EU isn't working.

user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: attempt to index a nil value
stack traceback:
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:168: in function 'loadActiveGuilds'
user:/AddOns/WheresMyGuildHall/WheresMyGuildHall.lua:506: in function 'onPlayerActivated'

On EU I'm still guild-master of my guild. That's the only difference. Same addons are used on both servers.
I haven't seen those errors in a while. Could you delete the liveeu/SavedVariables/WheresMyGuildHall.lua file and then try it again to see if you get the same errors please? Thanks.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: