Quantcast
Download
(2 Kb)
Download
Updated: 05/22/17 01:28 AM
Addon for:
Advanced Filters.
Pictures
File Info
Compatibility:
Morrowind (3.0)
Updated:05/22/17 01:28 AM
Created:10/09/14 06:15 AM
Monthly downloads:132
Total downloads:7,859
Favorites:29
MD5:
Advanced Filters - Item Saver Filters  Popular! (More than 5000 hits)
Version: 1.2.0.1
by: Randactyl [More]
Item Saver compatibility for Advanced Filters!

This is a plugin for Advanced Filter's extensible dropdown filter system. Download this plugin for an example on how to create new filters using the callback/string generator feature added in Advanced Filters 1.4.0.0!

Comments are included to generally explain each section.

You may submit your filters as plugins for Advanced Filters on ESOUI.
Do this by:
1. Go to http://www.esoui.com/downloads/info245-AdvancedFilters.html
2. Click on "Other Files" between "Change Log" and "Comments"
3. Click on "Upload Optional Addon"
4. Enter all relevant information and attach a .zip file containing the folder that contains your plugin
heirarchy should look something like:
AF_MyPluginFilters-1.0.0.zip
AF_MyPluginFilters
AF_MyPluginFilters.txt
AF_MyPluginFilters.lua
5. Submit
Remember to include all readme and disclaimer information required by ZOS.

Your addon manifest must look similar to the following (example from Item Saver Filters):
--[[

## Title: Advanced Filters - Item Saver Filters
## Author: Randactyl
## Version: 1.0
## APIVersion: 100009
## DependsOn: AdvancedFilters ItemSaver

AF_ItemSaverFilters.lua

]]
Your title should retain the leading "Advanced Filters - " in order to keep things organized in the game's addon menu.
If your addon depends on any other addon for functionality, you must include the addon name in the DependsOn line.
AdvancedFilters must always be included in DependsOn.

---

If you like my work and feel the urge to contribute, I'm always willing to accept in-game gold sent to @Randactyl

If you REALLY like my work and want to help me out with ESO Plus, I won't say no to Paypal donations
v1.2.0.1
- updated minimum API version to 100019 (ESO 3.x, Morrowind)

v1.2.0.0
- updated to Advanced Filters 1.4.0.0's new registration capabilities. This means compatibility for modern versions of Item Saver!
- updated minimum API version to 100018 (ESO 2.7.x, Homestead)

v1.1.0.4
- update API version

v1.1.0.3
- update API version

v1.1.0.2
- update API version

v1.1.0.1
- update API version

v1.1.0
- Switch to new registration method in Advanced Filters 0.7.1

v1.0.0
- Initial release
Archived Files (7)
File Name
Version
Size
Author
Date
1.2.0.0
2kB
Randactyl
02/06/17 05:52 AM
1.1.0.4
1kB
Randactyl
03/07/16 05:52 AM
1.1.0.3
2kB
Randactyl
08/31/15 01:39 AM
1.1.0.2
2kB
Randactyl
03/03/15 11:29 AM
1.1.0.1
2kB
Randactyl
11/03/14 10:12 AM
1.1.0
2kB
Randactyl
10/11/14 01:22 AM
1.0.0
2kB
Randactyl
10/09/14 06:15 AM


Post A Reply Comment Options
Unread 06/10/17, 11:53 AM  
Randactyl
 
Randactyl's Avatar
AddOn Author - Click to view AddOns

Forum posts: 253
File comments: 439
Uploads: 17
Re: Re: Re: Warning of dependency missing

Originally Posted by praxcelis
Originally Posted by Randactyl
Originally Posted by praxcelis
This addon is flagged as unable to run due to dependency, because Advanced Filters is not enabled. But I do have the latest release of Advanced Filters running, along with other Advanced Filters addons. Is this an issue due to needing to be updated to current API or just something funky on my machine?
This plugin actually has two dependencies. Item Saver is linked at the top of the description.
I... feel like an idiot now. I thought it was for use with Advanced Filters and FCO Item Saver. Will try it the proper way. Thanks!
No problem!
__________________
Randactyl | NA Megaserver | Blood for the Pact! | Sun's Death, Chrysamere Pact

My Addons
Beta Addons
Check out my GitHub repos to follow my latest changes and see some addons before they are released.
Report comment to moderator  
Reply With Quote
Unread 06/09/17, 08:48 PM  
praxcelis

Forum posts: 0
File comments: 14
Uploads: 0
Re: Re: Warning of dependency missing

Originally Posted by Randactyl
Originally Posted by praxcelis
This addon is flagged as unable to run due to dependency, because Advanced Filters is not enabled. But I do have the latest release of Advanced Filters running, along with other Advanced Filters addons. Is this an issue due to needing to be updated to current API or just something funky on my machine?
This plugin actually has two dependencies. Item Saver is linked at the top of the description.
I... feel like an idiot now. I thought it was for use with Advanced Filters and FCO Item Saver. Will try it the proper way. Thanks!
Report comment to moderator  
Reply With Quote
Unread 06/08/17, 10:52 PM  
Randactyl
 
Randactyl's Avatar
AddOn Author - Click to view AddOns

Forum posts: 253
File comments: 439
Uploads: 17
Re: Warning of dependency missing

Originally Posted by praxcelis
This addon is flagged as unable to run due to dependency, because Advanced Filters is not enabled. But I do have the latest release of Advanced Filters running, along with other Advanced Filters addons. Is this an issue due to needing to be updated to current API or just something funky on my machine?
This plugin actually has two dependencies. Item Saver is linked at the top of the description.
__________________
Randactyl | NA Megaserver | Blood for the Pact! | Sun's Death, Chrysamere Pact

My Addons
Beta Addons
Check out my GitHub repos to follow my latest changes and see some addons before they are released.
Report comment to moderator  
Reply With Quote
Unread 06/08/17, 09:37 PM  
praxcelis

Forum posts: 0
File comments: 14
Uploads: 0
Warning of dependency missing

This addon is flagged as unable to run due to dependency, because Advanced Filters is not enabled. But I do have the latest release of Advanced Filters running, along with other Advanced Filters addons. Is this an issue due to needing to be updated to current API or just something funky on my machine?
Report comment to moderator  
Reply With Quote
Unread 04/21/17, 05:51 PM  
Majeure
 
Majeure's Avatar

Forum posts: 6
File comments: 120
Uploads: 0
Originally Posted by Randactyl
Originally Posted by Majeure
It does what it says, however it would be more useful if instead of just "Saved Items" you had subcategories for each category you've created using "Item Saver", similar to how "Advanced Filters - FCOItemSaver filters PLUGIN" works for "FCOItemSaver"

I'd prefer to only use "Item Saver" and this plugin as I prefer the more dynamic item sets you can create with it, but as it stands right now I must run "FCOItemSaver" along with its plugin to quickly move specific sets of gear between my bank and different characters' inventories, it's quite a hassle to have to maintain these item sets in multiple addons.

Come to think of it, that's 3 addons I'm using to save the same items... Item Saver which I use for everything, FCOItemSaver to move stuff between my bank and inventory quickly, Wykkyd's Outfitter to actually equip said stuff via Wykkyd's Macros.

Hope this reaches you, and thanks for Item Saver!
I hear you. I've been meaning to do that for a long time, just need a chance to do it.
Hey, I noticed recently that it now supports filtering for all saved categories, find it extremely useful now. Thanks!

Now if we could also have hotkeys to select those Filters, like I have Item Saver setup to save to Default by pressing 1, if I could set press ALT-1 or other user set hotkey to then show me all items in the Default category, that'd be super handy.

In any case, love your work with both this and Item Saver, keep it up!
__________________
@Majeure | CP 900+ | Former Emperor | Master Angler | PC EU | Blood for the Pact!
Flawless Warden | Flawless Dragonknight | Flawless Templar | Flawless Nightblade | Flawless Sorcerer
YouTube | Website | Twitch | Late Night Dungeoneers
Last edited by Majeure : 04/21/17 at 06:00 PM.
Report comment to moderator  
Reply With Quote
Unread 08/28/16, 06:22 PM  
Randactyl
 
Randactyl's Avatar
AddOn Author - Click to view AddOns

Forum posts: 253
File comments: 439
Uploads: 17
Originally Posted by Majeure
It does what it says, however it would be more useful if instead of just "Saved Items" you had subcategories for each category you've created using "Item Saver", similar to how "Advanced Filters - FCOItemSaver filters PLUGIN" works for "FCOItemSaver"

I'd prefer to only use "Item Saver" and this plugin as I prefer the more dynamic item sets you can create with it, but as it stands right now I must run "FCOItemSaver" along with its plugin to quickly move specific sets of gear between my bank and different characters' inventories, it's quite a hassle to have to maintain these item sets in multiple addons.

Come to think of it, that's 3 addons I'm using to save the same items... Item Saver which I use for everything, FCOItemSaver to move stuff between my bank and inventory quickly, Wykkyd's Outfitter to actually equip said stuff via Wykkyd's Macros.

Hope this reaches you, and thanks for Item Saver!
I hear you. I've been meaning to do that for a long time, just need a chance to do it.
__________________
Randactyl | NA Megaserver | Blood for the Pact! | Sun's Death, Chrysamere Pact

My Addons
Beta Addons
Check out my GitHub repos to follow my latest changes and see some addons before they are released.
Report comment to moderator  
Reply With Quote
Unread 08/28/16, 12:40 PM  
Majeure
 
Majeure's Avatar

Forum posts: 6
File comments: 120
Uploads: 0
It does what it says, however it would be more useful if instead of just "Saved Items" you had subcategories for each category you've created using "Item Saver", similar to how "Advanced Filters - FCOItemSaver filters PLUGIN" works for "FCOItemSaver"

I'd prefer to only use "Item Saver" and this plugin as I prefer the more dynamic item sets you can create with it, but as it stands right now I must run "FCOItemSaver" along with its plugin to quickly move specific sets of gear between my bank and different characters' inventories, it's quite a hassle to have to maintain these item sets in multiple addons.

Come to think of it, that's 3 addons I'm using to save the same items... Item Saver which I use for everything, FCOItemSaver to move stuff between my bank and inventory quickly, Wykkyd's Outfitter to actually equip said stuff via Wykkyd's Macros.

Hope this reaches you, and thanks for Item Saver!


Edit: For anyone else in the same boat who's not interested in running two separate item saver addons as detailed above, apparently you can just hit one of Wykkyd's Macros that has a Gear set attached while the bank is open and it loots and equips all the pieces straight from your bank, in-case you're using Wykkyd's Outfitter and Wykkyd's Macros.
__________________
@Majeure | CP 900+ | Former Emperor | Master Angler | PC EU | Blood for the Pact!
Flawless Warden | Flawless Dragonknight | Flawless Templar | Flawless Nightblade | Flawless Sorcerer
YouTube | Website | Twitch | Late Night Dungeoneers
Last edited by Majeure : 08/29/16 at 07:27 AM.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.