Quantcast
Download
(5 Kb)
Download
Updated: 09/10/17 10:51 AM
Addon for:
Advanced Filters.
Pictures
File Info
Compatibility:
Horns of the Reach (3.1)
Morrowind (3.0)
Homestead (2.7)
One Tamriel (2.6)
Shadows of the Hist (2.5)
Dark Brotherhood (2.4)
Thieves Guild (2.3)
Orsinium (2.2.4)
Updated:09/10/17 10:51 AM
Created:10/09/14 12:25 PM
Monthly downloads:438
Total downloads:18,753
Favorites:77
MD5:
Advanced Filters - FCOItemSaver filters PLUGIN  Popular! (More than 5000 hits)
Version: 1.91
by: Baertram [More]
FCOItemSaver marked items filter plugin

Code:
Plugin is Fast API ready
This PLUGIN depends on the following ADDONs:
FCOItemSaver
Advanced Filters

This is a filter PLUGIN for the dynamic filters of the "Advanced Filters" addon.
It will be able to filter your items in your inventories by all the different filter types for marked items, supported from the addon "FCOItemSaver".

Please use filter dropdown box of AdvancedFilters, located at the top right edge inside your inventories, to select the different filters.
1.91
-Updated API version to HOTR
-Fixed: Disabled dynamic icons > 5 showed a lua nil error

1.9
Updated for new FCOItemSaver version 1.0
-> Only use with FCOIS version >= 1.0 !!!

1.71
Fixed: Gear set texts
Added: Dynamic icon texts
Updated: Translations

1.7
Updated API
Updated libraries

Added the 4 new dynamic icons

1.1.1
-Updated API to Shadows of the Hist

1.1.0
Updated: API to version 100015

1.0.9
Updated: API to version 100014
Updated: Moved the filters to a submenu to support lower screen resolutions

1.0.8
Updated: API to version 100013

1.0.7
Updated: API to version 100012

1.0.6b
-Added support for new filter icons "Sell at guild store" and "Intricate", introduced with FCOItemSaver version 0.6.1

1.0.6a
-Updated french translations. Big thx to DoomS59

1.0.6
-Updated the API version for patch 1.6 (100011)

Version 1.0.4 -> 1.0.5
!!!NEEDS FCOItemSaver version 0.5.6 or higher!!!
-Added the 5 different gear sets to the list
-The gear set names will be read from FCOItemSaver settings so the list will show YOUR individually chosen gear set names too
-Added the research, deconstruction and improvement icons to the list
-Fixed a global variable glitch

Version 1.0.3 -> 1.0.4
Added option to select only items that are not marked with FCO ItemSaver.
In addition to the new context menu button of FCO ItemSaver, where you can mark several items with 1 click now, this helps to manage all items quickly

Version 1.0.2 -> 1.0.3
Bugfix for filter 4 ("Sell items", coin icon) to show correctly, if selected

Version 1.0.1 -> 1.0.2
Api Version Update to 100010

Version 1.00 -> 1.0.1
Updated to current AdvancedFilter methods of filtering
Archived Files (17)
File Name
Version
Size
Author
Date
1.9
5kB
Baertram
06/11/17 07:39 AM
1.71
4kB
Baertram
10/03/16 07:49 AM
1.7
4kB
Baertram
10/02/16 07:37 PM
1.1.1
4kB
Baertram
07/17/16 01:24 PM
1.1.0
4kB
Baertram
06/05/16 08:50 AM
1.0.9
4kB
Baertram
02/27/16 05:04 PM
1.0.8
3kB
Baertram
11/05/15 03:04 AM
1.0.7
3kB
Baertram
08/31/15 05:19 PM
1.0.6b
3kB
Baertram
04/06/15 07:01 PM
1.0.6a
3kB
Baertram
03/16/15 12:52 PM
1.0.5
3kB
Baertram
02/26/15 06:21 PM
1.0.4
3kB
Baertram
12/19/14 09:58 AM
1.0.3
3kB
Baertram
11/22/14 02:45 PM
1.0.2
3kB
Baertram
11/07/14 11:01 AM
1.0.1
3kB
Baertram
10/13/14 01:51 PM
1.0.1
3kB
Baertram
10/13/14 01:04 PM
1.0.0
3kB
Baertram
10/09/14 12:25 PM


Post A Reply Comment Options
Unread 08/15/17, 02:42 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 1297
File comments: 1235
Uploads: 43
Hi there and thanks for the bug report. Due to a business trip I'm currently not able to invest or fix this.
I'll have a look as I come back and got access to my gaming pc.
Report comment to moderator  
Reply With Quote
Unread 08/15/17, 01:13 AM  
Snakefish

Forum posts: 0
File comments: 70
Uploads: 0
Update

Update for 3.1 please!
Report comment to moderator  
Reply With Quote
Unread 08/14/17, 09:16 AM  
FWSWBN
 
FWSWBN's Avatar

Forum posts: 8
File comments: 194
Uploads: 0
after new update lua error

user:/AddOns/AdvancedFilters/main.lua:77: C stack overflow: too many (128) nested C function calls.

stack traceback:
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
user:/AddOns/AdvancedFilters/main.lua:77: in function '__index'
Report comment to moderator  
Reply With Quote
Unread 06/11/17, 07:36 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 1297
File comments: 1235
Uploads: 43
Do not use this version of the plugin with a FCOItemSaver version < 1.0.0!
Please update FCOItemSaver (FCOIS) to the newest version 1.0.0 too.
Report comment to moderator  
Reply With Quote
Unread 07/23/16, 03:04 AM  
leeux
 
leeux's Avatar

Forum posts: 0
File comments: 20
Uploads: 0
Problem with dependency

Nevermind, sorry... I'm dumb! Never realised until now that there are two addons with almost the same name :/

Forget I wrote anything!
Last edited by leeux : 07/23/16 at 03:13 AM.
Report comment to moderator  
Reply With Quote
Unread 11/05/15, 02:57 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 1297
File comments: 1235
Uploads: 43
Sorry for confusing you

AdvancedFilters is a base ADDON which is able to run alone (without FCOItemSaver!).
FCOItemSaver is another base ADDON (which is able to run alone without AdvancedFilters).
AdvancedFilters FCOItemSaver filter plugin is a PLUGIN (no standalone addon!) which is only able to run with AdvancedFilters enabled AND FCOItemSaver enabled too.

If you want to run the PLUGIN you need to make sure that you use FCOItemSaver version 0.6.1, or a higher version.
If you use Minion to update FCOItemSaver properly everything should be ok and you would currently use the version 0.7.9a of FCOIS (which is higher then 0.6.1).

You just need to understand the difference between a standalone ADDON, connected ADDONs and PLUGINs for addons (which can require more than 1 addon to work properly).

Hope this explains it good enough to get even more confused now?


Originally Posted by Starkman
Okay, so if I have this right:
There's Advanced Filters.
There's FCO ItemSaver,
And there's also Advanced Filters FCO ItemSaver filters plugin (which, of course, would require FCO ItemSaver)...

I think I got it.

But don't that I'm still not confused, a lot. I always am!!

Starkman
Report comment to moderator  
Reply With Quote
Unread 09/18/15, 01:24 PM  
Jar-Ek
AddOn Author - Click to view AddOns

Forum posts: 1
File comments: 25
Uploads: 4
Nevermind, solved it
Last edited by Jar-Ek : 09/18/15 at 01:34 PM.
Report comment to moderator  
Reply With Quote
Unread 09/02/15, 09:17 AM  
Starkman

Forum posts: 2
File comments: 4
Uploads: 0
Okay, so if I have this right:
There's Advanced Filters.
There's FCO ItemSaver,
And there's also Advanced Filters FCO ItemSaver filters plugin (which, of course, would require FCO ItemSaver)...

I think I got it.

But don't that I'm still not confused, a lot. I always am!!

Starkman
Report comment to moderator  
Reply With Quote
Unread 09/02/15, 04:50 AM  
merlight
AddOn Author - Click to view AddOns

Forum posts: 645
File comments: 208
Uploads: 12
Yes, Advanced Filters - FCOItemSaver filters plugin requires FCO ItemSaver. This link is even in the description
Last edited by merlight : 09/02/15 at 04:51 AM.
Report comment to moderator  
Reply With Quote
Unread 09/01/15, 06:54 PM  
Starkman

Forum posts: 2
File comments: 4
Uploads: 0
I did a search in Esoui for FCO Item Saver and found the addon; however, the information about this addon is very confusing:


Advanced Filters - FCOItemSaver filters plugin Updated less than 3 days ago!
Version: 1.0.7
by: Baertram [More]
FCOItemSaver marked items filter plugin
Depends on the following addon: FCOItemSaver


So far so good, but then...


ATTENTION: The latest update of this addon plugin requires FCOItemSaver version 0.6.1 or higher!

Wait! The latest update of THIS addon requires...FCOItemSaver version....
This does not make any sense. It's stating that to run this addon you need ver 0.6.1 of...this addon?

Very confusing.

Thanks,

Starkman
Report comment to moderator  
Reply With Quote
Unread 04/06/15, 07:03 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 1297
File comments: 1235
Uploads: 43
TOC change was all that was needed to make it show up as "Updated".

Originally Posted by joshmiller83
Will this addon be updated and/or is TOC change all that is needed?
Report comment to moderator  
Reply With Quote
Unread 03/03/15, 05:02 PM  
joshmiller83
AddOn Super User
 
joshmiller83's Avatar
Premium Member

Forum posts: 55
File comments: 181
Uploads: 0
Will this addon be updated and/or is TOC change all that is needed?
Report comment to moderator  
Reply With Quote
Unread 01/15/15, 01:55 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 1297
File comments: 1235
Uploads: 43
Re: Says it Lack Dependency When it is Installed

You will also need the addon "AvdvancedFilters" installed and enabled for this plugin to work.
Is this the case?

If you changed some files of this plugin manually:
The file "AF_FCOItemSaverFilters.txt" should look like this
Lua Code:
  1. ## Title: Advanced Filters - FCO Item Saver Filters
  2. ## Author: Baertram
  3. ## Version: 1.0.4
  4. ## APIVersion: 100010
  5. ## DependsOn: AdvancedFilters FCOItemSaver
  6.  
  7. AF_FCOItemSaverFilters.lua

Otherwise please delete this plugin and install it again.


Originally Posted by Anex
It keeps telling me that it needs the dependency add-on and is highlighted in red while in game (shows up find on add-on list on character select screen) even though the dependency add-on FCO Item Saver is installed and working perfectly fine. O_o
Last edited by Baertram : 01/15/15 at 01:56 PM.
Report comment to moderator  
Reply With Quote
Unread 01/12/15, 01:23 PM  
Anex
 
Anex's Avatar

Forum posts: 4
File comments: 13
Uploads: 0
Says it Lack Dependency When it is Installed

It keeps telling me that it needs the dependency add-on and is highlighted in red while in game (shows up find on add-on list on character select screen) even though the dependency add-on FCO Item Saver is installed and working perfectly fine. O_o
Report comment to moderator  
Reply With Quote
Unread 11/22/14, 04:24 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 1297
File comments: 1235
Uploads: 43
Wrong addon, this is only a plugin for Advanced Filters.
But your request was fullfilled in FCOItemSaver.

Originally Posted by gillysan
Request: see icons in Improvement window. Maybe there isn't room along the bottom for the buttons but seeing the icons next to the items would help a lot. I improved a low level item I had flagged for research.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: