Quantcast
Download
(37 Kb)
Download
Updated: 12/07/14 05:27 PM
Pictures
File Info
Compatibility:
Update 5 (1.5.2)
Updated:12/07/14 05:27 PM
Created:11/26/14 01:31 AM
Monthly downloads:59
Total downloads:9,662
Favorites:3
MD5:
AI Research Grid patch  Popular! (More than 5000 hits)
Version: 2.3d
by: rkuhnjr [More]
v2.3d: Update LibAddonMenu to rev 16 and set Blacksmithing as default craft if the character has zero researches to prevent a blank window on open.

v2.3c: Added the Dwemer motif (i dont have a char with it so someone else will need to test it )
also updated version

Loads with no errors for me. If you works for you, awesome, if not im not sure how much support if any i can provide

enjoy
v2.3d: Update LibAddonMenu to rev 16 and set Blacksmithing as default craft if the character has zero researches to prevent a blank window on open.

v2.3c: Added the Dwemer motif
Archived Files (1)
File Name
Version
Size
Author
Date
2.3c
37kB
rkuhnjr
11/26/14 10:01 AM


Post A Reply Comment Options
Unread 01/30/15, 02:40 AM  
votan
 
votan's Avatar
AddOn Author - Click to view AddOns

Forum posts: 413
File comments: 741
Uploads: 20
Re: Original AIRG addon

No, you don't need. And look at the updated date and the change log. This one is older. Fixes were included in the original already.

The word "patch" is really misleading, because it implies "modified files only". But here on esoui "patch" is usually used as "alternative full version, not from original author".
Sometimes "patches" started as a hotfix and become a new maintained branch.

At least the original team members should be able to mark a patch as "out-dated" or "included" or "maintained branch".


Originally Posted by rbpaiett
So ... since this is a 'patch', do I also need to include the original AIRG addon or is this a standalone addon? This guide didn't say whether it's necessary and the word 'patch' is misleading if I don't need it.
__________________
@votan73 (EU - megaserver)
Report comment to moderator  
Reply With Quote
Unread 01/30/15, 01:11 AM  
rbpaiett

Forum posts: 0
File comments: 43
Uploads: 0
Original AIRG addon

So ... since this is a 'patch', do I also need to include the original AIRG addon or is this a standalone addon? This guide didn't say whether it's necessary and the word 'patch' is misleading if I don't need it.
Report comment to moderator  
Reply With Quote
Unread 12/09/14, 02:27 AM  
QuadroTony
Banned
 
QuadroTony's Avatar
AddOn Author - Click to view AddOns

Forum posts: 828
File comments: 3956
Uploads: 3
ok, i will test!

iwill w8 fir this feature too=)
if you planned to update it - can you add a feature - mark unknow traits if we have items for research? even if this items at the any of our other characters/mules
Report comment to moderator  
Reply With Quote
Unread 12/09/14, 02:24 AM  
hisdad
AddOn Author - Click to view AddOns

Forum posts: 32
File comments: 148
Uploads: 2
AIResearch 3.1.5 With Dwemer Motifs

Thanks rkuhnjr

the updated addon is here

https://www.dropbox.com/s/c0ecndox5r...3.1.5.zip?dl=0

I spent a moment to see if calling AIRG.InitUI() would re-initialise the UI. Nope, because of all the child objects

-dad
Report comment to moderator  
Reply With Quote
Unread 12/09/14, 12:26 AM  
rkuhnjr
 
rkuhnjr's Avatar
AddOn Author - Click to view AddOns

Forum posts: 26
File comments: 8
Uploads: 5
Re: HAve Done new Version 3.1.4

Originally Posted by hisdad
Hi, I have done major update and bumped the version to 3.1.4.
UNfortunately Crazy dutch guy canno give me site access at the moment.

I've stuck it here.
https://www.dropbox.com/s/qhqt2kgkoj...3.1.4.zip?dl=0

It doesn't support Dwemer traits.

[email protected]
If it helps any

Lua Code:
  1. --After Line 664 add:
  2. AIRG.styleLookupIcons[15] = "ESOUI/art/progression/progression_indexicon_weapons_"
  3.  
  4. --After Line 680 add:
  5. AIRG.styleLookupValue[15] = ITEMSTYLE_AREA_DWEMER
  6.  
  7. --After Line 696 add:
  8. AIRG.styleLookupItem[15] = 15   -- Dwemer       = Dwemer Frame
  9.  
  10. --Lines 320,508,545,550 Change from:
  11.     for i = 1, 14 do
  12. --To :
  13.     for i = 1, 15 do

I had to move the motifs to the left 40 as well but in its container its at spot 0 already so i had to change this line as well when i added it as a patch to fit

Lua Code:
  1. --Change Line 316  From:
  2.     AIRG.UI.motifSection:SetAnchor(BOTTOMLEFT, AIResearchGrid, BOTTOMLEFT, 0, 0)
  3. -- To:
  4.     AIRG.UI.motifSection:SetAnchor(BOTTOMLEFT, AIResearchGrid, BOTTOMLEFT, -40, 0)

But there is probably a cleaner way.

And thanks for Updating it!

QuadroGuy had a suggestion below that you may want to consider.
__________________
And the fourth angel poured out his vial upon the sun
and power was given unto him to scorch men with fire
Report comment to moderator  
Reply With Quote
Unread 12/08/14, 11:03 PM  
hisdad
AddOn Author - Click to view AddOns

Forum posts: 32
File comments: 148
Uploads: 2
HAve Done new Version 3.1.4

Hi, I have done major update and bumped the version to 3.1.4.
UNfortunately Crazy dutch guy canno give me site access at the moment.

I've stuck it here.
https://www.dropbox.com/s/qhqt2kgkoj...3.1.4.zip?dl=0

It doesn't support Dwemer traits.

Change log
Known Bugs:
Deleting Data for a char still shows char in list. /relouadui to fix.

2014-12-03 V3.0
New Features
This has a virtual Character called "#ALL".
This provides a composite view of traits known by any of your characters. Thus it is the traits you may need to trade for.
It also provides a "Set Relative to:" button. Chose the character you wish to update and press "Set Relative to:".
The grid will now show which traits that your current character can make that the selected character can research.


2014-12-05 V3.1
New features
If using the relative mode but the destination character is already researching that item, the icon will be a dull red tick.
Characters can only research 1 trait in a item at at time, no matter how many research slots might be available.

2014-12-05 V3.1.2
New Feature
None
Bugs Fixed
Deleting charater data for selected char caused crash
In relative mode, scrolling through chars would not update for completed research.

2014-12-05 V3.1.4
New Feature
Localization files now used for relative button, but translations not provided
Bugs Fixed
None
Note: this file does not have a txt extension, for good reason!



I discovered the hard way that if you put changelog in to the addon/AIRsearch directory, if its got a .txt extention eso will CTD on player load!

[email protected]
Report comment to moderator  
Reply With Quote
Unread 12/07/14, 11:48 PM  
zellwoodcorn

Forum posts: 0
File comments: 28
Uploads: 0
Originally Posted by rkuhnjr
Originally Posted by zellwoodcorn
The error shown in the first picture appears on log-in or upon reloading the UI, but never with the hotkey.

I get the "empty" grid view via hotkey, right after having just logged in or after reloading the UI. It stays empty no matter how many times I open or close the window via hotkey, until I select a crafting category. Then it stays properly populated, until I relog or reload the UI.

Thanks
I just published a new patch with an updated LibAddonMenu lib, 2.3c was using rev 14 and 2.3d is updated to rev 16

I also added a quick check that if your character has zero researches it defaults to Blacksmiths instead of a blank screen.

you can find 2.3d under other files as before.
Try it out and let me know if it resolved your issues as I was unable to replicate them.
Both issues are resolved! I was able to log in cleanly on both TS and non-TS toons, and I see red Xs for Blacksmithing on all non-TS toons via hotkey right away

Thanks again for keeping this add-on going
Report comment to moderator  
Reply With Quote
Unread 12/07/14, 05:31 PM  
rkuhnjr
 
rkuhnjr's Avatar
AddOn Author - Click to view AddOns

Forum posts: 26
File comments: 8
Uploads: 5
Originally Posted by zellwoodcorn
The error shown in the first picture appears on log-in or upon reloading the UI, but never with the hotkey.

I get the "empty" grid view via hotkey, right after having just logged in or after reloading the UI. It stays empty no matter how many times I open or close the window via hotkey, until I select a crafting category. Then it stays properly populated, until I relog or reload the UI.

Thanks
I just published a new patch with an updated LibAddonMenu lib, 2.3c was using rev 14 and 2.3d is updated to rev 16

I also added a quick check that if your character has zero researches it defaults to Blacksmiths instead of a blank screen.

you can find 2.3d under other files as before.
Try it out and let me know if it resolved your issues as I was unable to replicate them.
__________________
And the fourth angel poured out his vial upon the sun
and power was given unto him to scorch men with fire
Report comment to moderator  
Reply With Quote
Unread 12/07/14, 03:57 PM  
zellwoodcorn

Forum posts: 0
File comments: 28
Uploads: 0
The error shown in the first picture appears on log-in or upon reloading the UI, but never with the hotkey.

I get the "empty" grid view via hotkey, right after having just logged in or after reloading the UI. It stays empty no matter how many times I open or close the window via hotkey, until I select a crafting category. Then it stays properly populated, until I relog or reload the UI.

Thanks
Report comment to moderator  
Reply With Quote
Unread 12/07/14, 03:39 PM  
zellwoodcorn

Forum posts: 0
File comments: 28
Uploads: 0
Re: Re: Re: Re: Latest Version Bug?

Report comment to moderator  
Reply With Quote
Unread 12/07/14, 12:22 PM  
QuadroTony
Banned
 
QuadroTony's Avatar
AddOn Author - Click to view AddOns

Forum posts: 828
File comments: 3956
Uploads: 3
Re: Re: Re: Latest Version Bug?

Originally Posted by zellwoodcorn
I don't have the access to attach pictures of the error msg and the empty grid... How do I get access to that? I have two .png files about 540x540 to upload/attach
Thanks
https://code.google.com/p/image-uploader/
Report comment to moderator  
Reply With Quote
Unread 12/07/14, 11:18 AM  
zellwoodcorn

Forum posts: 0
File comments: 28
Uploads: 0
Re: Re: Latest Version Bug?

I don't have the access to attach pictures of the error msg and the empty grid... How do I get access to that? I have two .png files about 540x540 to upload/attach
Thanks
Report comment to moderator  
Reply With Quote
Unread 12/07/14, 02:19 AM  
rkuhnjr
 
rkuhnjr's Avatar
AddOn Author - Click to view AddOns

Forum posts: 26
File comments: 8
Uploads: 5
Re: Latest Version Bug?

Originally Posted by zellwoodcorn
Hello,
I've been using this add-on for a long time... I typically delete the .lua file with any add-on after I upgrade it, and I did so with this one for version 2.3. It is also happening after I patched it with 2.3c.
Since that ugrade, I get an error on log-in for any toon that has never done any tradeskills itself or has never learned any motifs (other than the default motif for that toon's race). These toons are my mule toons, so it doesn't bother my playing very much, but it is annoying that it happens every time I log in with one of these toons.
I have also noticed that the first time I open the grid (via hotkey) after log in, the grid window is "empty": it has no Xs or checks or even column heading icons, until I click on one of the crafting categories (BS, CL, or WW), and then I see all the red Xs in the correct columns, as they should be.
I do not get the log-in error or the "empty" view for any toons that have learned at least one trait or at least one new motif.
Hope this helps to isolate and fix the bug
There is logic in the addon that will load to what it thinks is your primary craft based on completed researches.

Since your bank alts have zero it doesnt know which craft to load and thus is blank until you select one.

I just created a brand new char and did not get any error on login
Can you post what the error msg is, and when it occurs, on login or when you hit the hotkey to open it?
__________________
And the fourth angel poured out his vial upon the sun
and power was given unto him to scorch men with fire
Last edited by rkuhnjr : 12/07/14 at 02:21 AM.
Report comment to moderator  
Reply With Quote
Unread 12/06/14, 03:33 PM  
zellwoodcorn

Forum posts: 0
File comments: 28
Uploads: 0
Latest Version Bug?

Hello,
I've been using this add-on for a long time... I typically delete the .lua file with any add-on after I upgrade it, and I did so with this one for version 2.3. It is also happening after I patched it with 2.3c.
Since that ugrade, I get an error on log-in for any toon that has never done any tradeskills itself or has never learned any motifs (other than the default motif for that toon's race). These toons are my mule toons, so it doesn't bother my playing very much, but it is annoying that it happens every time I log in with one of these toons.
I have also noticed that the first time I open the grid (via hotkey) after log in, the grid window is "empty": it has no Xs or checks or even column heading icons, until I click on one of the crafting categories (BS, CL, or WW), and then I see all the red Xs in the correct columns, as they should be.
I do not get the log-in error or the "empty" view for any toons that have learned at least one trait or at least one new motif.
Hope this helps to isolate and fix the bug
Report comment to moderator  
Reply With Quote
Unread 12/03/14, 07:03 AM  
QuadroTony
Banned
 
QuadroTony's Avatar
AddOn Author - Click to view AddOns

Forum posts: 828
File comments: 3956
Uploads: 3
if you planned to update it - can you add a feature - mark unknow traits if we have items for research? even if this items at the any of our other characters/mules
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: