Quantcast
Download
(90 Kb)
Download
Updated: 08/17/18 10:26 PM
Pictures
File Info
Compatibility:
Wolfhunter (4.1)
Summerset (4.0)
Updated:08/17/18 10:26 PM
Created:07/15/18 12:09 PM
Monthly downloads:394
Total downloads:502
Favorites:6
MD5:
4.1
ElderScrollsOfAlts  Updated Today!
Version: 0.1.12
by: Echomap [More]
Addon/mod for Elder Scrolls Online - to keep general track of alts

Currently with a moderately looking UI, basic sorting, and at least some of the details I want to store/show.
  • This addon only knows about characters it has been loaded with
  • It will probably not hook into changes in realtime, and just update on start, Gui showing and hopefully shutdown.
  • All things/buttons etc may not work, but I hope to not have errors

Slashcommand:
  • /esoa
  • /ElderScrollsOfAlts

TODO:
  • Lots of things I'm sure.
Misc:
(git repo https://github.com/echomap/ElderScrollsOfAlts)

BETA: I hope to at least not cause errors, even if things are unstable and changing, but... well... Oops.
0.1.12 update info on tooltip for Provisioning and Enchanting having 2 skills that effect what you can make.
0.1.11
  • game version update
  • Sort direction and column mentioned in header
  • bug fixes
  • left click select row for hightlight
  • starting character note
  • rename main xml for no other than sorting reasons
  • Skeleton for 3rd screen
  • bindings for show home/equip view
0.1.10b bugfix
0.1.10
  • Updated Equipment display
  • Hover over and clickable links
0.1.9 - showing off where I'm going with Equip UI
  • fix ui button not hiding/showing properly
  • some prework on equipment
  • refresh bug
0.1.8b fixed UI Button not hiding (?)
0.1.8
  • updates to button
  • select character details on rightclick of row, REMOVED dropdown
  • removed submenu in settings
  • Fixed keybinding error (?)
0.1.7 Save settings updated, removed LMM menu, New UI Button
  • UI button to move/click to show/hide /esoa still works
  • LMM menu removed
  • Settings save on QUIT as well
  • UI hide on Champion screen, any other needed?
  • Alliance shown/sortable
  • Were/Vamp sortable
  • Removed Iconify mode
0.1.6 sort updates
  • load current player data when restored/unminimized
  • sort order and direction saved and restored
  • Less loading of player data
0.1.5 Show2 Gui updates, size, selecting row, starting details storing
  • Icon will be restored if style is "show2"
  • Minor GUI updates
  • highlight selected row
0.1.4 Gui updates and WHOOPs fix
  • Settings added Mode select
  • Started gui3 -> which is the character viewer, etc
0.1.3 "/esoa show2" gui update, save position/minimize
  • saving window position
  • ability to 'iconify' the window
0.1.2 window moving/min/max/lock
0.1.1 gui updates
  • Added slashcommand for trial new gui /esoa show2
  • Updated 'mainmenu' gui
  • Code updates
  • Bag space shown now
  • Beginnings of VAMP vs WERE icons showing
  • Fixed Sorting

0.1 Initial
Optional Files (0)


Archived Files (16)
File Name
Version
Size
Author
Date
0.1.11
90kB
Echomap
08/13/18 09:57 PM
0.1.10b
87kB
Echomap
08/08/18 10:02 PM
0.1.10
87kB
Echomap
08/06/18 11:05 PM
0.1.9
84kB
Echomap
08/04/18 04:42 PM
0.1.8b
79kB
Echomap
07/31/18 12:00 PM
0.1.8
79kB
Echomap
07/31/18 11:46 AM
0.1.7c
79kB
Echomap
07/30/18 09:12 PM
0.1.7b
79kB
Echomap
07/30/18 08:57 PM
0.1.7
79kB
Echomap
07/30/18 08:33 PM
0.1.6
79kB
Echomap
07/22/18 05:17 PM
0.1.5
79kB
Echomap
07/20/18 04:39 PM
0.1.4
77kB
Echomap
07/18/18 10:57 PM
0.1.3
75kB
Echomap
07/18/18 03:53 AM
0.1.2
74kB
Echomap
07/17/18 02:02 PM
0.1.1
74kB
Echomap
07/17/18 11:56 AM
0.0.1
72kB
Echomap
07/15/18 12:09 PM


Post A Reply Comment Options
Unread 08/10/18, 10:09 AM  
Echomap
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 4
Uploads: 2
Not a problem, sorry for the issue in the first place, but glad I could fix it.

Originally Posted by motub
I was referring to the error that user "and" had back on July 18th, but looking at it closer, I see that the error was not the same (different function). Sorry for that noise.

The error I got seems indeed to be fixed; the champion menu now displays normally with ESOA active.

Thanks!!!
Report comment to moderator  
Reply With Quote
Unread 08/10/18, 08:00 AM  
motub

Forum posts: 0
File comments: 4
Uploads: 0
I was referring to the error that user "and" had back on July 18th, but looking at it closer, I see that the error was not the same (different function). Sorry for that noise.

The error I got seems indeed to be fixed; the champion menu now displays normally with ESOA active.

Thanks!!!
Report comment to moderator  
Reply With Quote
Unread 08/09/18, 12:30 PM  
Echomap
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 4
Uploads: 2
What is the 'same error' that you are getting?
The below error on the Champion screen should be fixed in 1.0.10b now.

Originally Posted by motub
Hi, thanks for the mod, it's a really useful concept. I'm getting the same error as the person above, but the missing link is that I only get the error when I try to open up the Champion Points Constellation. This is with only the ESOAS button showing (haven't tried it with the info box open or shaded). In any case, as soon as I try to go to the Champion menu, the screen goes black (the colored constellations do not display, although there is some small white numbers scattered around the screen), and the following error appears:
<REMOVED CODE FOR SPACE>

I can escape from the blank black screen. If I then turn of ESOA, reloadUI and then go to my Champion Points menu, it then displays normally. This is not quite a deal breaker (and yes, I get that it's a beta), but it is pretty disturbing, especially since otherwise ESOA doesn't give me any problems (except what's listed in the description) so this kinda comes out of left field when I don't expect it. I'm looking forward to future versions where these last few issues are worked out. Thanks again!
Last edited by Echomap : 08/09/18 at 12:31 PM.
Report comment to moderator  
Reply With Quote
Unread 08/08/18, 08:00 PM  
motub

Forum posts: 0
File comments: 4
Uploads: 0
Hi, thanks for the mod, it's a really useful concept. I'm getting the same error as the person above, but the missing link is that I only get the error when I try to open up the Champion Points Constellation. This is with only the ESOAS button showing (haven't tried it with the info box open or shaded). In any case, as soon as I try to go to the Champion menu, the screen goes black (the colored constellations do not display, although there is some small white numbers scattered around the screen), and the following error appears:

Code:
user:/AddOns/ElderScrollsOfAlts/ElderScrollsOfAlts.lua:98: attempt to index a nil value
stack traceback:
	user:/AddOns/ElderScrollsOfAlts/ElderScrollsOfAlts.lua:98: in function 'ElderScrollsOfAlts.OnChampionPerksSceneStateChange'
	EsoUI/Libraries/Utility/ZO_CallbackObject.lua:111: in function 'ZO_CallbackObject:FireCallbacks'
	EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:269: in function 'ZO_Scene:SetState'
	EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Base.lua:161: in function 'ZO_SceneManager_Base:ShowScene'
	EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Leader.lua:252: in function 'ZO_SceneManager_Leader:ShowScene'
	EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Leader.lua:335: in function 'ZO_SceneManager_Leader:OnSceneStateHidden'
	EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Base.lua:239: in function 'ZO_SceneManager_Base:OnSceneStateChange'
	EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Leader.lua:282: in function 'ZO_SceneManager_Leader:OnSceneStateChange'
	EsoUI/Ingame/Scenes/IngameSceneManager.lua:334: in function 'ZO_IngameSceneManager:OnSceneStateChange'
	EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:270: in function 'ZO_Scene:SetState'
	EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:402: in function 'ZO_Scene:OnTransitionComplete'
	EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:397: in function 'ZO_Scene:DetermineIfTransitionIsComplete'
	EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:325: in function 'ZO_Scene:RefreshFragments'
	EsoUI/Libraries/ZO_Scene/ZO_Scene.lua:278: in function 'ZO_Scene:SetState'
	EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Base.lua:169: in function 'ZO_SceneManager_Base:HideScene'
	EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Leader.lua:256: in function 'ZO_SceneManager_Leader:HideScene'
	EsoUI/Libraries/ZO_Scene/ZO_SceneManager_Leader.lua:224: in function 'ZO_SceneManager_Leader:Show'
	(tail call): ?
	EsoUI/Ingame/MainMenu/Keyboard/ZO_MainMenu_Keyboard.lua:740: in function 'MainMenu_Keyboard:Update'
	EsoUI/Ingame/MainMenu/Keyboard/ZO_MainMenu_Keyboard.lua:748: in function 'MainMenu_Keyboard:ShowScene'
	EsoUI/Ingame/MainMenu/Keyboard/ZO_MainMenu_Keyboard.lua:757: in function 'MainMenu_Keyboard:ToggleScene'
	EsoUI/Ingame/MainMenu/Keyboard/ZO_MainMenu_Keyboard.lua:859: in function 'ZO_MainMenuManager_ToggleCategoryInternal'
	EsoUI/Ingame/MainMenu/Keyboard/ZO_MainMenu_Keyboard.lua:880: in function 'MainMenu_Keyboard:ToggleCategory'
	:1: in function '(main chunk)'
I can escape from the blank black screen. If I then turn of ESOA, reloadUI and then go to my Champion Points menu, it then displays normally. This is not quite a deal breaker (and yes, I get that it's a beta), but it is pretty disturbing, especially since otherwise ESOA doesn't give me any problems (except what's listed in the description) so this kinda comes out of left field when I don't expect it. I'm looking forward to future versions where these last few issues are worked out. Thanks again!
Report comment to moderator  
Reply With Quote
Unread 08/04/18, 04:42 AM  
and

Forum posts: 0
File comments: 197
Uploads: 0
Originally Posted by Echomap
There is a small area at the top that can be grabbed -- no it's not perfect, it's being finicky.
The button should now hide/show based on settings and the keybind should now work.

Originally Posted by and
Hello,
Just reporting a couple of issue with the button:
- I can't move it
- It stays on screen even if I disable it
Thanks!
I think I have found the area BTW, now the button is actually hidden, many thanks!
Report comment to moderator  
Reply With Quote
Unread 08/01/18, 04:03 PM  
MartinL

Forum posts: 5
File comments: 73
Uploads: 0
Fixed keybinding error (?)
Yep works thx
Report comment to moderator  
Reply With Quote
Unread 07/31/18, 12:02 PM  
Echomap
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 4
Uploads: 2
There is a small area at the top that can be grabbed -- no it's not perfect, it's being finicky.
The button should now hide/show based on settings and the keybind should now work.

Originally Posted by and
Hello,
Just reporting a couple of issue with the button:
- I can't move it
- It stays on screen even if I disable it
Thanks!
Report comment to moderator  
Reply With Quote
Unread 07/31/18, 11:32 AM  
and

Forum posts: 0
File comments: 197
Uploads: 0
Hello,

Just reporting a couple of issue with the button:

- I can't move it

- It stays on screen even if I disable it

Thanks!
Report comment to moderator  
Reply With Quote
Unread 07/30/18, 11:40 PM  
MartinL

Forum posts: 5
File comments: 73
Uploads: 0
Thx a ton for the addon

Just ran into a few bug when i set a hotkey and then try to use it i get this:

Code:
:1: function expected instead of nil
stack traceback:
:1: in function '(main chunk)'
When i open the window with /esoa and press the "Select" popdown i get this error:
Code:
user:/AddOns/ElderScrollsOfAlts/ElderScrollsOfAlts_UI2.lua:433: attempt to index a nil value
stack traceback:
	user:/AddOns/ElderScrollsOfAlts/ElderScrollsOfAlts_UI2.lua:433: in function 'ElderScrollsOfAlts:SelectCharacterFromDropdown'
	ESOA_GUI2_Header_Dropdown_MouseUp:2: in function '(main chunk)'
Report comment to moderator  
Reply With Quote
Unread 07/19/18, 05:54 PM  
megnin

Forum posts: 1
File comments: 14
Uploads: 0
I like where you are going with this. This is useful information for all my Alts. Keep working on it. :-)
Last edited by megnin : 07/19/18 at 05:55 PM.
Report comment to moderator  
Reply With Quote
Unread 07/19/18, 01:11 PM  
and

Forum posts: 0
File comments: 197
Uploads: 0
Originally Posted by and
Hello,

first of all thanks for this addon, I do find it useful, although with the latest version I am getting this error:

Lua Code:
  1. Lua Error: user:/AddOns/ElderScrollsOfAlts/ElderScrollsOfAlts.lua:20: attempt to index a nil value
  2. stack traceback:
  3.     user:/AddOns/ElderScrollsOfAlts/ElderScrollsOfAlts.lua:20: in function 'ElderScrollsOfAlts.SaveSettings'
  4.     user:/AddOns/ElderScrollsOfAlts/ElderScrollsOfAlts.lua:106: in function 'ElderScrollsOfAlts.OnAddOnUnloaded'|r

By the way, could you please pack your files including the folder like other addons? It is a bit annoying to unzip the archive and then having to move the files to the proper directory.

Many thanks.
New version solved both, many thanks!
Report comment to moderator  
Reply With Quote
Unread 07/18/18, 02:52 PM  
and

Forum posts: 0
File comments: 197
Uploads: 0
Hello,

first of all thanks for this addon, I do find it useful, although with the latest version I am getting this error:

Lua Code:
  1. Lua Error: user:/AddOns/ElderScrollsOfAlts/ElderScrollsOfAlts.lua:20: attempt to index a nil value
  2. stack traceback:
  3.     user:/AddOns/ElderScrollsOfAlts/ElderScrollsOfAlts.lua:20: in function 'ElderScrollsOfAlts.SaveSettings'
  4.     user:/AddOns/ElderScrollsOfAlts/ElderScrollsOfAlts.lua:106: in function 'ElderScrollsOfAlts.OnAddOnUnloaded'|r

By the way, could you please pack your files including the folder like other addons? It is a bit annoying to unzip the archive and then having to move the files to the proper directory.

Many thanks.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: