Quantcast Minion mis-detects version of installed addons if version string differs in length - ESOUI
Thread Tools Display Modes
02/23/17, 05:26 PM   #1
Locutus
 
Locutus's Avatar
Join Date: Dec 2016
Posts: 1
Minion mis-detects version of installed addons if version string differs in length

Hey!

I just noticed that Minion seems to have an issue with detecting the version of a newly installed addon (or when the Minion config has been reset, or other such circumstances) if the version string in the local installation, and in the latest available version on the web, differ in length.

Current example: the "No Thank You" addon. My installed version: "5". Available version: "5.1".

Upon detection of new addons / after re-installation of Minion, it detects the local version as "5.1" and claims it's up to date.

To verify this bug: If I manipulate the file "NoThankYou\NoThankYou.txt" to say "Version: 5.0" instead of "5", it is detected correctly as "5.0" and the update for "5.1" is offered.

The same happens with S'redarr. My local version: "2.3.5". Available update: "2.3.5b". Upon fresh detection, Minion claims my outdated version is 2.3.5b and up to date.

For other addons where the local and available version string have identical length, e.g. "WPamA 1.2.4" / "WPamA 1.2.4", the local version is detected correctly and the update is offered.

This issue only occurs when an addon is freshly detected. Existing addons don't exhibit this behavior. I noticed the bug when I copied my Addons folder from the Live to the PTS server directory and added the latter to Minion.
__________________
Kind regards,
Frank aka. Locutus

Last edited by Locutus : 02/23/17 at 05:31 PM.
  Reply With Quote

ESOUI » Site Forums » Minion » Minion mis-detects version of installed addons if version string differs in length

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off