Quantcast Slow typing in comments/threads (Android, PC) - ESOUI
Thread Tools Display Modes
03/19/18, 06:32 AM   #1
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 1,500
[Solved] Slow typing in comments/threads (Android, PC)

Hey there,

since a week or even longer now the forums here behave really strange and slow if I create a new thread or post an answer.

If e.g. I answer to an addon comment my CPU starts to get busy as hell and typing the characters needs seconds. I can watch the text "appearing" char by char after I wrote it already.

Is this happening to others too? I first thought this is due to my aandroid device but even my powerfull pc is typing really slow sometimes in this forums.

I noticed it depends on the text in the edit field as it seems. If I answer a comment the quote of the comment is added to the edit box. The more text is in teh box the slower the typing is. Mabye its a bug with the chrome brower, I need to test other browsers. Perhaps the auto spell correction is the culprit.

After writing this text to this point here: Everything was ok until this text line started. Now, if I movethe cursor left or right it's really slow again and I can watch the characters appear once after another

Last edited by Baertram : 03/19/18 at 07:49 AM.
  Reply With Quote
03/19/18, 07:09 AM   #2
sirinsidiator
 
sirinsidiator's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2014
Posts: 1,036
Originally Posted by Baertram View Post
Hey there,

since a week or even longer now the forums here behave really strange and slow if I create a new thread or post an answer.

If e.g. I answer to an addon comment my CPU starts to get busy as hell and typing the characters needs seconds. I can watch the text "appearing" char by char after I wrote it already.

Is this happening to others too? I first thought this is due to my aandroid device but even my powerfull pc is typing really slow sometimes in this forums.

I noticed it depends on the text in the edit field as it seems. If I answer a comment the quote of the comment is added to the edit box. The more text is in teh box the slower the typing is. Mabye its a bug with the chrome brower, I need to test other browsers. Perhaps the auto spell correction is the culprit.

After writing this text to this point here: Everything was ok until this text line started. Now, if I movethe cursor left or right it's really slow again and I can watch the characters appear once after another
No problem on my end. I use Firefox 59 on PC and can type, quote and delete text just fine.
__________________
>siri.exe MyAddon
Does your addon work? [y/n] n
There is a typo in there.
  Reply With Quote
03/19/18, 07:14 AM   #3
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,115
I use chrome on mac os without issue as well. If you find the combination that you think that causes the issue let me know and I can test on my end too.
  Reply With Quote
03/19/18, 07:25 AM   #4
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 1,500
Thanks for your answers.
@dolby
Did you change anything like adds or scripts in the past weeks? Maybe my add blocker or anyplugin is the culprit.

I'll test some more with disabling all plugins of the browser and using another browser. Maybe it's a network issu somehow.

Noticed this behaviour only within the gitter app on android in the past or the outlook . app if there are long conversations you need to answer to and press the "show all" link. Very unrespsonisve somehow
  Reply With Quote
03/19/18, 07:30 AM   #5
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,115
Sorry, I have not changed any scripts in the past few weeks.
  Reply With Quote
03/19/18, 07:38 AM   #6
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 1,500
Using the chrome browser without plugins didn't realy speed it up.
But I found out there were running some backgroud tasks including a failed zip preview (whatever, could have been dropbox maybe) which crashed and slowed down everything.

Terminated everything and closed the plugins, updated everything. Still laggy if the text gets longer or I use the arrow keys, backspace to navigate in the text.

Not sure why this happens, it's annoying.

I'll have to test this on my work laptop, if it behaves the same.
  Reply With Quote
03/19/18, 07:40 AM   #7
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 1,500
Using internet explorer the text typing is fast and normal as it seems.
So it got to do with the brwoser

I guess I should think about trying firefox again if the mayjor bugs are gone

Just found a thread about the iDrive process for online backup which had the same issues. I'm not using this software so I just checked other software for online backup and disabled them.
No better performance so far.

Last edited by Baertram : 03/19/18 at 07:44 AM.
  Reply With Quote
03/19/18, 07:49 AM   #8
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 1,500
Test typing without hardware acceleration.

Seems to have fixed it or at least it's better now.
I have used chrome:settings to open the settings, go to advanced settings and disabled the etting
"Use hardware acceleration where possible". This helped a lot and the typing is fluent again now.

wtf
  Reply With Quote

ESOUI » Site Forums » Site help, bugs, suggestions/questions » Slow typing in comments/threads (Android, PC)

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off