Quantcast
Download
(6 Kb)
Download
Updated: 06/10/20 11:12 AM
Pictures
File Info
Compatibility:
Greymoor (6.0.5)
Harrowstorm (5.3.4)
Updated:06/10/20 11:12 AM
Created:10/26/15 02:31 PM
Monthly downloads:789
Total downloads:11,645
Favorites:37
MD5:
Categories:Group, Guild & Friends, Character Advancement, PvP
6.0.5
Auto Handle Shared Quests  Popular! (More than 5000 hits)
Version: 2.3
by: CaptainBlagbird, Baertram
Description
Automatically accepts/declines quests that are shared by group members.

Features
  • Different actions for AvA and PvE possible (None/Accept/Decline)

Requirements
To be able to use this add-on you'll need to install this library too:
Notes, Please read!
The default value for both options is None, so without changing anything in the settings menu the add-on does nothing.
Baertram:

v2.3 (2020-06-10)
  • Fixed lua error with LibSavedVars due to savedvars version not being a proper number (now the other way around could have occured -> Added a SV scanner to change strings in the version to number, to make ZOs functions not error anymoe (they could have added that themselves actually...)


v2.2 (2020-06-10)
  • Fixed lua error with LibSavedVars due to savedvars version not being a proper number


v2.1 (2020-06-03)
  • Fixed addon's txt file to use encoding UTF-8 w/o BOM to make the ESO addonmanager recognize the SavedVariables properly.
    Sorry, this will reset your settings :-(


v2.0 (2020-05-23)
  • API update to Greymoor/Harrowstorm
  • Added LibAddonMenu-2.0 check to version 28 or newer
  • Fixed auto accept/decline of quests



Captain Blagbird:
v1.2 (partially released: v1.1.15)
  • API update
  • Removed libraries (have to be installed manually by the user)
  • Added chat message back
  • Bugfixes

v1.1 (2015-11-09)
  • Added option for auto accepting
    & added settings menu for choosing different action for AvA and PvE areas
  • Fixed stupid copy-paste mistake

v1.0 (2015-10-26)
  • First version

---

Can also be found on GitHub
Optional Files (0)


Archived Files (22)
File Name
Version
Size
Uploader
Date
2.2
5kB
Baertram
06/10/20 08:36 AM
2.1
5kB
Baertram
06/02/20 04:05 PM
2.0
5kB
Baertram
05/23/20 12:15 PM
1.1.15
5kB
CaptainBlagbird
03/17/19 04:59 AM
1.1.14
5kB
CaptainBlagbird
02/09/19 03:59 AM
1.1.13
49kB
CaptainBlagbird
03/25/18 10:33 AM
1.1.12
47kB
CaptainBlagbird
11/05/17 07:40 AM
1.1.11
47kB
CaptainBlagbird
09/03/17 08:27 AM
1.1.10
45kB
CaptainBlagbird
06/07/17 03:22 AM
1.1.9
45kB
CaptainBlagbird
04/02/17 10:53 AM
1.1.8
42kB
CaptainBlagbird
10/23/16 10:45 AM
1.1.8
44kB
CaptainBlagbird
08/14/16 12:16 PM
1.1.6
44kB
CaptainBlagbird
06/07/16 11:01 AM
1.1.5
44kB
CaptainBlagbird
03/26/16 03:17 PM
1.1.4
40kB
CaptainBlagbird
03/06/16 04:15 PM
1.1.3
39kB
CaptainBlagbird
02/25/16 02:28 PM
1.1.2
39kB
CaptainBlagbird
11/10/15 05:12 PM
1.1.1
39kB
CaptainBlagbird
11/10/15 10:57 AM
1.1
39kB
CaptainBlagbird
11/09/15 07:54 AM
1.0.2
2kB
CaptainBlagbird
11/02/15 04:52 PM
1.0.1
2kB
CaptainBlagbird
10/31/15 08:44 AM
1.0
2kB
CaptainBlagbird
10/26/15 02:31 PM


Post A Reply Comment Options
Unread 06/10/20, 04:24 PM  
MurkyMais

Forum posts: 12
File comments: 40
Uploads: 0
Deleted saved variables and installed new version. All is good!






Originally Posted by Baertram
Hm the update should have exactly addressed this error message, not forcing it.
Before it was a string "2.1" and failed so I changed it to be a number 2.1 now and it should not produce this error message anymore.
But now it does for you?
This is weird.
I guess the old SV containing the "string version" fail to be compared to the correct number version now.
So if you logout and delete the SV file, then login again it should be fixed.

Originally Posted by MurkyMais
I loaded the latest update and got following error.

The addom does not load and cannot be used.

I try a secong time, deleted saved variables and reinstalled it failed again.


EsoUI/Libraries/Utility/ZO_SavedVars.lua:284: operator < is not supported for string < number
stack traceback:
EsoUI/Libraries/Utility/ZO_SavedVars.lua:284: in function 'CreateExposedInterface'
<Locals> rawSavedTable = [table:1]{}, version = 2.1, defaults = [table:2]{ActionAvA = 0, ActionPvE = 0}, profile = "NA Megaserver", displayName = "@MurkyMais", playerName = 8796093022606787, current = [table:3]{$LastCharacterName = "Braelynn", version = "2.1", ActionAvA = 1, ActionPvE = 1}, container = [table:4]{}, containerKey = 8796093022606787 </Locals>
EsoUI/Libraries/Utility/ZO_SavedVars.lua:181: in function 'GetNewSavedVars'
<Locals> savedVariableTable = [table:1], version = 2.1, defaults = [table:2], profile = "NA Megaserver", displayName = "@MurkyMais", characterName = "Braelynn", characterId = 8796093022606787, characterKeyType = 2, finalKey = 8796093022606787 </Locals>
(tail call): ?
user:/AddOns/LibSavedVars/LibSavedVars.lua:399: in function 'ZO_SavedVars:New'
<Locals> self = [table:5]{}, savedVariableTable = "AutoHandleSharedQuests_SavedVa...", version = 2.1, defaults = [table:2], profile = "NA Megaserver", displayName = "@MurkyMais", characterName = "Braelynn", characterId = 8796093022606787, characterKeyType = 2 </Locals>
(tail call): ?
user:/AddOns/AutoHandleSharedQuests/AutoHandleSharedQuests.lua:72: in function 'OnPlayerActivated'
<Locals> eventCode = 589824 </Locals>
Report comment to moderator  
Reply With Quote
Unread 06/10/20, 10:45 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2951
File comments: 3567
Uploads: 62
Hm the update should have exactly addressed this error message, not forcing it.
Before it was a string "2.1" and failed so I changed it to be a number 2.1 now and it should not produce this error message anymore.
But now it does for you?
This is weird.
I guess the old SV containing the "string version" fail to be compared to the correct number version now.
So if you logout and delete the SV file, then login again it should be fixed.

Originally Posted by MurkyMais
I loaded the latest update and got following error.

The addom does not load and cannot be used.

I try a secong time, deleted saved variables and reinstalled it failed again.


EsoUI/Libraries/Utility/ZO_SavedVars.lua:284: operator < is not supported for string < number
stack traceback:
EsoUI/Libraries/Utility/ZO_SavedVars.lua:284: in function 'CreateExposedInterface'
<Locals> rawSavedTable = [table:1]{}, version = 2.1, defaults = [table:2]{ActionAvA = 0, ActionPvE = 0}, profile = "NA Megaserver", displayName = "@MurkyMais", playerName = 8796093022606787, current = [table:3]{$LastCharacterName = "Braelynn", version = "2.1", ActionAvA = 1, ActionPvE = 1}, container = [table:4]{}, containerKey = 8796093022606787 </Locals>
EsoUI/Libraries/Utility/ZO_SavedVars.lua:181: in function 'GetNewSavedVars'
<Locals> savedVariableTable = [table:1], version = 2.1, defaults = [table:2], profile = "NA Megaserver", displayName = "@MurkyMais", characterName = "Braelynn", characterId = 8796093022606787, characterKeyType = 2, finalKey = 8796093022606787 </Locals>
(tail call): ?
user:/AddOns/LibSavedVars/LibSavedVars.lua:399: in function 'ZO_SavedVars:New'
<Locals> self = [table:5]{}, savedVariableTable = "AutoHandleSharedQuests_SavedVa...", version = 2.1, defaults = [table:2], profile = "NA Megaserver", displayName = "@MurkyMais", characterName = "Braelynn", characterId = 8796093022606787, characterKeyType = 2 </Locals>
(tail call): ?
user:/AddOns/AutoHandleSharedQuests/AutoHandleSharedQuests.lua:72: in function 'OnPlayerActivated'
<Locals> eventCode = 589824 </Locals>
Last edited by Baertram : 06/10/20 at 10:48 AM.
Report comment to moderator  
Reply With Quote
Unread 06/10/20, 10:35 AM  
MurkyMais

Forum posts: 12
File comments: 40
Uploads: 0
I loaded the latest update and got following error.

The addom does not load and cannot be used.

I try a secong time, deleted saved variables and reinstalled it failed again.


EsoUI/Libraries/Utility/ZO_SavedVars.lua:284: operator < is not supported for string < number
stack traceback:
EsoUI/Libraries/Utility/ZO_SavedVars.lua:284: in function 'CreateExposedInterface'
<Locals> rawSavedTable = [table:1]{}, version = 2.1, defaults = [table:2]{ActionAvA = 0, ActionPvE = 0}, profile = "NA Megaserver", displayName = "@MurkyMais", playerName = 8796093022606787, current = [table:3]{$LastCharacterName = "Braelynn", version = "2.1", ActionAvA = 1, ActionPvE = 1}, container = [table:4]{}, containerKey = 8796093022606787 </Locals>
EsoUI/Libraries/Utility/ZO_SavedVars.lua:181: in function 'GetNewSavedVars'
<Locals> savedVariableTable = [table:1], version = 2.1, defaults = [table:2], profile = "NA Megaserver", displayName = "@MurkyMais", characterName = "Braelynn", characterId = 8796093022606787, characterKeyType = 2, finalKey = 8796093022606787 </Locals>
(tail call): ?
user:/AddOns/LibSavedVars/LibSavedVars.lua:399: in function 'ZO_SavedVars:New'
<Locals> self = [table:5]{}, savedVariableTable = "AutoHandleSharedQuests_SavedVa...", version = 2.1, defaults = [table:2], profile = "NA Megaserver", displayName = "@MurkyMais", characterName = "Braelynn", characterId = 8796093022606787, characterKeyType = 2 </Locals>
(tail call): ?
user:/AddOns/AutoHandleSharedQuests/AutoHandleSharedQuests.lua:72: in function 'OnPlayerActivated'
<Locals> eventCode = 589824 </Locals>
Report comment to moderator  
Reply With Quote
Unread 06/02/20, 04:03 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2951
File comments: 3567
Uploads: 62
Great it worked. ESO addon manager seems to behave weird with some files which only use the Ansi endocing but contain special chars like the (R) sign.

Originally Posted by Bizicut
@ Baertram

Well I'm unsure how to tell you this. But after all day testing every theory we could come up with, you did it with version 2.1 ! I used the code in chat and it wasn't found, I then downloaded your file from dropbox. I checked every line of code to see if it was just UTF-8 (no BOM) which was fine. Tested on 6 characters with only Auto Handle and LAM 2.0 active. Worked fine and saved to SavedVariables file AutoHandleSharedQuests.lua. I then logged every Character off reactivated all AddOns and retested. And it seems your version 2.1 is the Hero. It worked fine and saved. And threw no LUA Errors. Thank you for working with me today, and hopefully 2.1 will help anyone else with the save issue.
Originally Posted by Baertram
If the file will not be created I dunno why. Even the older version 1.15 is using the same SavedVariables file and table in there called "AutoHandleSharedQuests_SavedVars".
All that is different is that the SV table will save below the servername like EU Megaserver or NA Megaserver now instead of "default" as head table and will use your characterId and not the name anymore (as this is rename safe!).

Could you please try this script after login and loading the addon. Just copy & paste into your chat, and run it.
And tell me what the chat output tells you (either "found" or "not found").

Code:
/script if AutoHandleSharedQuests_SavedVars ~= nil then d("found") else d("not found") end
If this tells you the table was not found logout and try to use this version (deinstall the 2.0 and use this 2.1):
https://www.dropbox.com/s/nknaol88dp...RTRAM.zip?dl=0

It basically is the same only some internal vars were renamed to make sure they get not overwritten by any other addon. But as you said no other addon was active I doubt it will make a difference.
Also checked the file encodings and changed it ti urf-8 without BOM where needed. But this was only the txt which was at ANSI before. Maybe this fixes it as it was not readable properly and then did not create the SV table internally.


If this tells you found the table was already created in memory of the game but cannot be safed to your SavedVariable folder then.
And here I cannot do anything further as it MUST be any program you are using on your computer which blocks this somehow.
Maybe you can search the windows event log if you can find anything about the c:\users\...\dcouments\elder scrolls online\ folder there which matches to the date today.

I don't have any other idea else.
But somehow other addons would have the problem then as well I guess.


Thanks
Report comment to moderator  
Reply With Quote
Unread 06/02/20, 03:36 PM  
Bizicut

Forum posts: 0
File comments: 7
Uploads: 0
@ Baertram

Well I'm unsure how to tell you this. But after all day testing every theory we could come up with, you did it with version 2.1 ! I used the code in chat and it wasn't found, I then downloaded your file from dropbox. I checked every line of code to see if it was just UTF-8 (no BOM) which was fine. Tested on 6 characters with only Auto Handle and LAM 2.0 active. Worked fine and saved to SavedVariables file AutoHandleSharedQuests.lua. I then logged every Character off reactivated all AddOns and retested. And it seems your version 2.1 is the Hero. It worked fine and saved. And threw no LUA Errors. Thank you for working with me today, and hopefully 2.1 will help anyone else with the save issue.
Originally Posted by Baertram
If the file will not be created I dunno why. Even the older version 1.15 is using the same SavedVariables file and table in there called "AutoHandleSharedQuests_SavedVars".
All that is different is that the SV table will save below the servername like EU Megaserver or NA Megaserver now instead of "default" as head table and will use your characterId and not the name anymore (as this is rename safe!).

Could you please try this script after login and loading the addon. Just copy & paste into your chat, and run it.
And tell me what the chat output tells you (either "found" or "not found").

Code:
/script if AutoHandleSharedQuests_SavedVars ~= nil then d("found") else d("not found") end
If this tells you the table was not found logout and try to use this version (deinstall the 2.0 and use this 2.1):
https://www.dropbox.com/s/nknaol88dp...RTRAM.zip?dl=0

It basically is the same only some internal vars were renamed to make sure they get not overwritten by any other addon. But as you said no other addon was active I doubt it will make a difference.
Also checked the file encodings and changed it ti urf-8 without BOM where needed. But this was only the txt which was at ANSI before. Maybe this fixes it as it was not readable properly and then did not create the SV table internally.


If this tells you found the table was already created in memory of the game but cannot be safed to your SavedVariable folder then.
And here I cannot do anything further as it MUST be any program you are using on your computer which blocks this somehow.
Maybe you can search the windows event log if you can find anything about the c:\users\...\dcouments\elder scrolls online\ folder there which matches to the date today.

I don't have any other idea else.
But somehow other addons would have the problem then as well I guess.


Thanks
Report comment to moderator  
Reply With Quote
Unread 06/02/20, 02:05 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2951
File comments: 3567
Uploads: 62
If the file will not be created I dunno why. Even the older version 1.15 is using the same SavedVariables file and table in there called "AutoHandleSharedQuests_SavedVars".
All that is different is that the SV table will save below the servername like EU Megaserver or NA Megaserver now instead of "default" as head table and will use your characterId and not the name anymore (as this is rename safe!).

Could you please try this script after login and loading the addon. Just copy & paste into your chat, and run it.
And tell me what the chat output tells you (either "found" or "not found").

Code:
/script if AutoHandleSharedQuests_SavedVars ~= nil then d("found") else d("not found") end
If this tells you the table was not found logout and try to use this version (deinstall the 2.0 and use this 2.1):
https://www.dropbox.com/s/nknaol88dp...RTRAM.zip?dl=0

It basically is the same only some internal vars were renamed to make sure they get not overwritten by any other addon. But as you said no other addon was active I doubt it will make a difference.
Also checked the file encodings and changed it ti urf-8 without BOM where needed. But this was only the txt which was at ANSI before. Maybe this fixes it as it was not readable properly and then did not create the SV table internally.


If this tells you found the table was already created in memory of the game but cannot be safed to your SavedVariable folder then.
And here I cannot do anything further as it MUST be any program you are using on your computer which blocks this somehow.
Maybe you can search the windows event log if you can find anything about the c:\users\...\dcouments\elder scrolls online\ folder there which matches to the date today.

I don't have any other idea else.
But somehow other addons would have the problem then as well I guess.


Thanks
Report comment to moderator  
Reply With Quote
Unread 06/02/20, 12:18 PM  
Bizicut

Forum posts: 0
File comments: 7
Uploads: 0
@Baertram

So I have thoroughly tested every aspect of the AddOn. I disabled every addon except Auto Handle and LAM2.0. Checked to make sure the file are open and able to be written to, besides read. Fixed both to run under Admin, and ran it under eso64.exe. Unfortunately same result no save file.

I then uninstalled Auto Handle, erased any saved variables (which wasn't any). Loaded the older 1.1.15 file. Added LibStub (so only those 3 were running), and presto got the Saved Variable file. Removed LibStub, and 1.1.15 Auto Handle, and the save file. Reinstalled the new 2.0 version with LAM2.0 and back to no save file. I'm stumped.
Last edited by Bizicut : 06/02/20 at 01:05 PM.
Report comment to moderator  
Reply With Quote
Unread 06/02/20, 10:33 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2951
File comments: 3567
Uploads: 62
The file is definately created at reloadui AND contains the values I have set in the LAM settings menu of the addon.
I have chosen AvV: off, PvE: on.
And my SavedVariables file AutoHandelSharedQuests.lua was updated (already existed) after I did a /reloadui in the chat, having date 2020-06-02 and time 6:25pm properly (local time).
The contents also were correct.
I even changed the version number of the addon to 2.1 internally so the file contains 1 char with older version 2 and one with the 2.1 versio now.
Code:
AutoHandleSharedQuests_SavedVars =
{
    ["EU Megaserver"] = 
    {
        ["@AccountName"] = 
        {
            ["87xxxxxxx"] = 
            {
                ["$LastCharacterName"] = "xxxx",
                ["version"] = "2.1",
                ["ActionAvA"] = 2,
                ["ActionPvE"] = 1,
            },
            ["87xxxxx"] = 
            {
                ["$LastCharacterName"] = "xxx",
                ["ActionAvA"] = 0,
                ["version"] = 2,
                ["ActionPvE"] = 0,
            },
        },
    },

I just checked this and it definately saves fine. Files are properly as well, txt contains the SV name and the SV get created and changed as well properly.
If it does not fo your something in your files of the addon is wrong OR any other tool you have enabled (AntiVirus, Firewall, Windows patches, whatever) blocks the access to this folder and files.
Rightclick the SV file please (if it gets created) and see if it is readonly? Another addon recently got this problem.
Try to logout, delete the file then, and just enable Auto Handle Shared Qeusts at the character selection screen, then login with ONLY this addon active. After login change the settings and do a /reloadui in chat. Should recreate the SV file then. Please check if it is readonly then.



btw: Did you run it AS SINGLE ACTIVE addon to check if it saves then?
Maybe any other addon interferes.
And maybe start ESO64.exe as Administrator once to check if it works then?
Last edited by Baertram : 06/02/20 at 10:34 AM.
Report comment to moderator  
Reply With Quote
Unread 06/02/20, 10:18 AM  
Bizicut

Forum posts: 0
File comments: 7
Uploads: 0
So heres a workaround atm thats working for me: --SavedVariables
AutoHandleSharedQuests.SavedVarsDefault = {
ActionAvA = 1,
ActionPvE = 1,
}I changed the Action to "1" instead of "0" in the addon folder of the AutoHandleSharedQuests.lua , so atm thats keeping the AddOn from switching back to Default even though it still has no SavedVariables.Thats after relog/ reloadui.Thanks again for looking into this. I know I have been a pain.
Originally Posted by Baertram
Lam is not saving anything to savedvariables. There are a lot addons and kinds which don't save anything.
Only the ones having ## SavedVariables: in their txt file save a d create a file <AddonName>.luain the SavedVariables folder (and this only at logout or reloadui).

Originally Posted by Bizicut
Just a heads up: I'm using Win10, and I noticed LAM2.0 also isn't in the SavedVariables file. Not sure if that Lib is hidden or suspose to be seen.


Originally Posted by Baertram
Okay, thanks for testing. Will have a look if the uploaded files are somehow corrupt later.

Originally Posted by Bizicut
@Baertram

I have tested by uninstalling, reinstalling, and whitelisting the folder. To no avail. I have discovered that it's not saving in the SavedVariables file. AutoHandleSharedQuests.lua is'nt being written. All other AddOns have written a saved file there just not that one.

So as of now it will work only during online playtime. I set it to "Accept" and it's good till logoff. Then upon returning back to game, it is back to Default= "None"
I recheck, and still no SavedVariables file.
Last edited by Bizicut : 06/02/20 at 10:22 AM.
Report comment to moderator  
Reply With Quote
Unread 06/02/20, 09:54 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2951
File comments: 3567
Uploads: 62
Lam is not saving anything to savedvariables. There are a lot addons and kinds which don't save anything.
Only the ones having ## SavedVariables: in their txt file save a d create a file <AddonName>.luain the SavedVariables folder (and this only at logout or reloadui).

Originally Posted by Bizicut
Just a heads up: I'm using Win10, and I noticed LAM2.0 also isn't in the SavedVariables file. Not sure if that Lib is hidden or suspose to be seen.


Originally Posted by Baertram
Okay, thanks for testing. Will have a look if the uploaded files are somehow corrupt later.

Originally Posted by Bizicut
@Baertram

I have tested by uninstalling, reinstalling, and whitelisting the folder. To no avail. I have discovered that it's not saving in the SavedVariables file. AutoHandleSharedQuests.lua is'nt being written. All other AddOns have written a saved file there just not that one.

So as of now it will work only during online playtime. I set it to "Accept" and it's good till logoff. Then upon returning back to game, it is back to Default= "None"
I recheck, and still no SavedVariables file.
Report comment to moderator  
Reply With Quote
Unread 06/02/20, 07:59 AM  
Bizicut

Forum posts: 0
File comments: 7
Uploads: 0
Just a heads up: I'm using Win10, and I noticed LAM2.0 also isn't in the SavedVariables file. Not sure if that Lib is hidden or suspose to be seen.


Originally Posted by Baertram
Okay, thanks for testing. Will have a look if the uploaded files are somehow corrupt later.

Originally Posted by Bizicut
@Baertram

I have tested by uninstalling, reinstalling, and whitelisting the folder. To no avail. I have discovered that it's not saving in the SavedVariables file. AutoHandleSharedQuests.lua is'nt being written. All other AddOns have written a saved file there just not that one.

So as of now it will work only during online playtime. I set it to "Accept" and it's good till logoff. Then upon returning back to game, it is back to Default= "None"
I recheck, and still no SavedVariables file.
Report comment to moderator  
Reply With Quote
Unread 06/02/20, 01:56 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2951
File comments: 3567
Uploads: 62
Okay, thanks for testing. Will have a look if the uploaded files are somehow corrupt later.

Originally Posted by Bizicut
@Baertram

I have tested by uninstalling, reinstalling, and whitelisting the folder. To no avail. I have discovered that it's not saving in the SavedVariables file. AutoHandleSharedQuests.lua is'nt being written. All other AddOns have written a saved file there just not that one.

So as of now it will work only during online playtime. I set it to "Accept" and it's good till logoff. Then upon returning back to game, it is back to Default= "None"
I recheck, and still no SavedVariables file.
Report comment to moderator  
Reply With Quote
Unread 06/01/20, 08:17 PM  
Bizicut

Forum posts: 0
File comments: 7
Uploads: 0
@Baertram

I have tested by uninstalling, reinstalling, and whitelisting the folder. To no avail. I have discovered that it's not saving in the SavedVariables file. AutoHandleSharedQuests.lua is'nt being written. All other AddOns have written a saved file there just not that one.

So as of now it will work only during online playtime. I set it to "Accept" and it's good till logoff. Then upon returning back to game, it is back to Default= "None"
I recheck, and still no SavedVariables file.
Report comment to moderator  
Reply With Quote
Unread 06/01/20, 12:22 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2951
File comments: 3567
Uploads: 62
Re: Not saving

It's working fine for me.
Any other addon's settings not saving?
Check the SavedVariables file AutoHandleSharedQuests.lua and it's date and time it was changed last. Is it changed as a reloadui happened or you did logout? Or does the last change date and time not change?

Whitelist the ESO live folder (see here how to find it: https://www.esoui.com/forums/faq.php..._howto_install) in your Windows Defender or any other antivirus you are using so the files can be accecssed properly.
It happens a lot that after a Windows Update the c:\users folder is not free to write to (and eso addons and SavedVariables are located by default in there) anymore.


Originally Posted by Bizicut
I really appreciate your work on this addon. But I have found that it never saves my inputted option of accepting quests for any of my toons. I have logged out and logged back in and it's back to default on every toon. Stating "None" in the dropdown box. Can this get fixed , in order to save per toon or accountwide would be even better. Thanks again for your work on this.
Last edited by Baertram : 06/01/20 at 12:24 PM.
Report comment to moderator  
Reply With Quote
Unread 06/01/20, 12:03 PM  
Bizicut

Forum posts: 0
File comments: 7
Uploads: 0
Post Not saving "Accept" input for toons.

I really appreciate your work on this addon. But I have found that it never saves my inputted option of accepting quests for any of my toons. I have logged out and logged back in and it's back to default on every toon. Stating "None" in the dropdown box. Can this get fixed , in order to save per toon or accountwide would be even better. Thanks again for your work on this.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.