Quantcast
Download
(12 Kb)
Download
Updated: 03/10/17 08:20 PM
Pictures
File Info
Compatibility:
Homestead (2.7)
One Tamriel (2.6)
Shadows of the Hist (2.5)
Dark Brotherhood (2.4)
Thieves Guild (2.3)
Updated:03/10/17 08:20 PM
Created:04/24/16 09:49 PM
Monthly downloads:97
Total downloads:3,883
Favorites:16
MD5:
GodSend+
Version: 1.2.4
by: Noobanidus [More]
This is an enhanced version of Focus's original, MIT-licensed GodSend. That license allows for redistribution so long as the history and license are maintained.

Original features:
- State-table based mailing loop allowing for pausing and continuing
- Ability to filter mail targets by rank
- Mail delivery status (sent/inbox full/ignored)

Additional features:
- Upon initially selecting a guild and rank setup, go to the recipients window and right click on one. An option of "[GodSend] Start from" allows you to skip everyone before that. When sending mail, it will begin from that user and continue forwards. This is exceptionally useful if you are logged off or your system crashes while mid-mail, meaning you don't need to re-mail everyone from the start.
- The "import" tab allows you to enter a new-line separated list of guild members (with or without initial @), which will filter the recipients list to only guild members who match these names. Note: it will not email anyone on the list who is not currently a member of the selected guild.
- Flexible text box that allows for messages up to 940 characters to be pasted and then edited down to size. Until length is 700 or less, message cannot be sent.
- Automatic replacement of wide characters (such as and ) with narrower counterparts in order to reduce the size of outgoing mail and allow for more characters total. Current character replacements include carriage return and all four curly quotes. More to come as required! Replacement is done on-the-fly and changes the text box too, retaining cursor position.

I hope this addon and these additional features help you as much as they have helped me!

Usage:
Slash commands:
/godsend+
/g++
/g+
Or keybind GodSend+ show/hide

Note: This addon was renamed and uploaded to ESOUI to prevent conflicts with other forks of the original GodSend, while allowing those to run my additions to continue using them without errors. All are welcome to use whichever version they prefer.
(1.2.3) Updated API version.

(1.2.2) Updated API version.

[1.2.1] Update API values.

[1.2.0] Implemented replacements system and extended text buffer size. Messages longer than 700 characters will result in the send button being hidden. Replacements maintain cursor position but do modify the text box.

[1.1.0] Merged FocusSend code back into GodSend+. Usage is identical and issues with carriage return+new line separate has been resolved, meaning the filtering code is now more efficient.

[1.0.2] Fix keybinds, something I didn't previously use. They should now be functional, and tooltips should no longer display strange emptiness.
Optional Files (0)


Archived Files (6)
File Name
Version
Size
Uploader
Date
1.2.2
24kB
Noobanidus
10/23/16 05:05 AM
1.2.1
12kB
Noobanidus
05/31/16 06:42 AM
1.2.0
12kB
Noobanidus
05/11/16 04:50 AM
1.1.0
12kB
Noobanidus
04/26/16 06:13 AM
1.0.2
11kB
Noobanidus
04/24/16 11:13 PM
1.0.1
11kB
04/24/16 09:49 PM


Post A Reply Comment Options
Unread 04/28/16, 10:21 PM  
Noobanidus
 
Noobanidus's Avatar
AddOn Author - Click to view AddOns

Forum posts: 23
File comments: 55
Uploads: 23
Re: Re: Re: Re: Re: Re: Re: Not working for me?

Originally Posted by jam08060
I don't have any other versions installed. I deleted and downloaded it again and I'm still experiencing the same issues. I downloaded it with minion, is that problematic? I tried logging in while it was disabled and there were no ui errors, but when I enabled it and reloaded my ui I was still getting the same error.
Unfortunateley the game doesn't give me any tools to determine what the actual error is. Because it's something that's happening in XML, there's just a generic "there's an error somewhere" message which could mean anything. I'll do some experimentation locally to see if I can duplicate the issue.
Report comment to moderator  
Reply With Quote
Unread 04/27/16, 08:29 PM  
jam08060

Forum posts: 0
File comments: 5
Uploads: 0
Re: Re: Re: Re: Re: Re: Not working for me?

Originally Posted by Noobanidus
Originally Posted by jam08060
I uploaded it with another website.
Thanks! From what I can see, that looks as though there's some XML UI code that's calling an undefined function. Can you make sure you don't have any other copies of GodSend installed? It's possible that there's a function name I missed that's being corrupted in the global scope by another function.

Outside of that, try deleting all copies of GodSend from your addons folder (you might need to close the client in case you get a "folder in use" error).

Just for clarification, this is an error you get when logging into the game with the addon enabled, that does not occur while it is disabled?

I don't have any other versions installed. I deleted and downloaded it again and I'm still experiencing the same issues. I downloaded it with minion, is that problematic? I tried logging in while it was disabled and there were no ui errors, but when I enabled it and reloaded my ui I was still getting the same error.
Report comment to moderator  
Reply With Quote
Unread 04/26/16, 09:59 PM  
Noobanidus
 
Noobanidus's Avatar
AddOn Author - Click to view AddOns

Forum posts: 23
File comments: 55
Uploads: 23
Re: Re: Re: Re: Re: Not working for me?

Originally Posted by jam08060
I uploaded it with another website.
Thanks! From what I can see, that looks as though there's some XML UI code that's calling an undefined function. Can you make sure you don't have any other copies of GodSend installed? It's possible that there's a function name I missed that's being corrupted in the global scope by another function.

Outside of that, try deleting all copies of GodSend from your addons folder (you might need to close the client in case you get a "folder in use" error).

Just for clarification, this is an error you get when logging into the game with the addon enabled, that does not occur while it is disabled?
Report comment to moderator  
Reply With Quote
Unread 04/26/16, 10:31 AM  
jam08060

Forum posts: 0
File comments: 5
Uploads: 0
Re: Re: Re: Re: Not working for me?

Originally Posted by Noobanidus
Originally Posted by jam08060
Originally Posted by Noobanidus
Originally Posted by jam08060
I'm getting UI errors when I load this add-on for some reason. Maybe because I'm using windows 10?

I don't know why, but it isn't working for me.
Would you be able to post a copy of some of these UI errors? Unfortunately, without access to them there isn't really any way I can tell if it's an issue with the addon, a compatability issue with another add-on, or an issue with your platform.
I loaded it again and this is the error I got when it loaded:

Can you post the image on imgur instead? I'm getting a permission denied/forbidden trying to view that image.
I uploaded it with another website.
Report comment to moderator  
Reply With Quote
Unread 04/26/16, 08:27 AM  
Noobanidus
 
Noobanidus's Avatar
AddOn Author - Click to view AddOns

Forum posts: 23
File comments: 55
Uploads: 23
Re: Re: Re: Not working for me?

Originally Posted by jam08060
Originally Posted by Noobanidus
Originally Posted by jam08060
I'm getting UI errors when I load this add-on for some reason. Maybe because I'm using windows 10?

I don't know why, but it isn't working for me.
Would you be able to post a copy of some of these UI errors? Unfortunately, without access to them there isn't really any way I can tell if it's an issue with the addon, a compatability issue with another add-on, or an issue with your platform.
I loaded it again and this is the error I got when it loaded:

Can you post the image on imgur instead? I'm getting a permission denied/forbidden trying to view that image.
Report comment to moderator  
Reply With Quote
Unread 04/26/16, 07:43 AM  
jam08060

Forum posts: 0
File comments: 5
Uploads: 0
Re: Re: Not working for me?

Originally Posted by Noobanidus
Originally Posted by jam08060
I'm getting UI errors when I load this add-on for some reason. Maybe because I'm using windows 10?

I don't know why, but it isn't working for me.
Would you be able to post a copy of some of these UI errors? Unfortunately, without access to them there isn't really any way I can tell if it's an issue with the addon, a compatability issue with another add-on, or an issue with your platform.
I loaded it again and this is the error I got when it loaded:

Last edited by jam08060 : 04/26/16 at 10:30 AM.
Report comment to moderator  
Reply With Quote
Unread 04/25/16, 10:22 PM  
Noobanidus
 
Noobanidus's Avatar
AddOn Author - Click to view AddOns

Forum posts: 23
File comments: 55
Uploads: 23
Re: Not working for me?

Originally Posted by jam08060
I'm getting UI errors when I load this add-on for some reason. Maybe because I'm using windows 10?

I don't know why, but it isn't working for me.
Would you be able to post a copy of some of these UI errors? Unfortunately, without access to them there isn't really any way I can tell if it's an issue with the addon, a compatability issue with another add-on, or an issue with your platform.
Report comment to moderator  
Reply With Quote
Unread 04/25/16, 09:29 PM  
jam08060

Forum posts: 0
File comments: 5
Uploads: 0
Question Not working for me?

I'm getting UI errors when I load this add-on for some reason. Maybe because I'm using windows 10?

I don't know why, but it isn't working for me.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: