Quantcast
Download
(188 Kb)
Download
Updated: 11/10/19 05:33 AM
Patch for:
Shissu's Guild Tools.
Compatibility:
Dragonhold (5.2.5)
Scalebreaker (5.1.5)
Elsweyr (5.0.5)
Updated:11/10/19 05:33 AM
Created:08/14/19 05:26 AM
Monthly downloads:1,225
Total downloads:5,915
Favorites:14
MD5:
5.2.5
Shissu Guild Tools Dragonhold Patch V1.4.4  Popular! (More than 5000 hits)
Version: 1.4.4
by: Splat, Sordrak
Update of all Shissu modules to enable functionality with Dragonhold update.

THIS IS STILL A WORK IN PROGRESS - DO NOT EXPECT 100% OF THE ISSUES TO BE FIXED.

This patch file has been tested and is expected to work in most cases.
Some issues related to the way that the guild history has been changed from client side to server side still persist. As many bugs as possible have been fixed or have had features temporarily removed.

I strongly advise that you first BACKUP your AddOns and SavedVariables Folders before installing.

Install this at your own risk. No warranties are offered whatsoever.

Installation:
- Download zip file to a temporary directory (or your desktop)
- Extract all files
- Copy the file to your ...\Documents\Elder Scrolls Online\live\AddOns folder replacing all exisiting shissu files
1.4.4

Fixed the issue with the settings menu (again, for real this time)

-------

1.4.3

Changes made to reset trader bid timer to correct hours
Updated some language issues introduced in the Dragonhold DLC

-------

1.4.2

API bump for Dragonhold PTS testing
Bug fix for Dragonhold that broke the settings menu
Fix to the welcome message so it no longer outputs it twice
Fix to 'to join' so that it now displays a yellow 'to join' when an invite is sent and the player is pending in the roster and a green 'joined' once they have fully joined the guild

--------

1.4.1

Chat bug fixed, so no more %s %s %s
UI elements moved to fit with longer trader bid names for Bid History & Trader Timer

--------
Archived Files (4)
File Name
Version
Size
Uploader
Date
1.4.3
188kB
Splat
11/04/19 05:52 AM
1.4.2
188kB
Splat
09/27/19 06:42 AM
1.4.1
188kB
Splat
09/10/19 04:49 AM
1.4
188kB
08/14/19 05:26 AM


Post A Reply Comment Options
Unread 11/14/19, 01:40 PM  
Gamer1986PAN
AddOn Author - Click to view AddOns

Forum posts: 84
File comments: 434
Uploads: 2
Is there a way to mass-mail to all pending invitations or can you implement that?

Reason why i ask for this:

We have Guild 1 and Guild 2. If someone is inactive in Guild 1 for 7 days or more i invite them to guild 2 and kick them from guild 1 to make sure we can keep guild 1 healthy.
But because you can only invite up to 500 players i have to pull back some invites. But i want the users to know, when they are coming back again and be active again they can always make a new application to our guild/s.
__________________
Co-Author of the Addon BeamMeUp - feel free to check it out.


BankManagerRevived Slim Edition
- changed profiles to accountwide in order to have better performance with BMR and added 4 different global addon profiles for better overview -
most of the working mechancis are created from the original BMR authors - credits to orignal authors
Last edited by Gamer1986PAN : 11/15/19 at 08:10 AM.
Report comment to moderator  
Reply With Quote
Unread 11/10/19, 03:44 PM  
Pyrelle

Forum posts: 5
File comments: 4
Uploads: 0
Originally Posted by Splat
New patch version 1.4.4 should resolve the problem.

Not sure exactly what happened but the version I fixed and uploaded didn't match the 'same' version I was using so didn't actually include the fix, hence my issue with replicating the bug.

The correct version (1.4.4) is now uploaded and should resolve the issue.
Yay! Thank you! Also, thank you for keeping shissu's alive as well. Lord only knows what I would do without it.
Report comment to moderator  
Reply With Quote
Unread 11/10/19, 05:36 AM  
Splat
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 17
Uploads: 5
New patch version 1.4.4 should resolve the problem.

Not sure exactly what happened but the version I fixed and uploaded didn't match the 'same' version I was using so didn't actually include the fix, hence my issue with replicating the bug.

The correct version (1.4.4) is now uploaded and should resolve the issue.
Report comment to moderator  
Reply With Quote
Unread 11/09/19, 04:38 PM  
Pyrelle

Forum posts: 5
File comments: 4
Uploads: 0
Originally Posted by Splat
I am struggling to replicate the issue at the moment.
does this mean I am the only person with this issue? Yeah, that kinda figures with my luck =/
Well, anyone got any thoughts on what I should do to fix the issue?
Report comment to moderator  
Reply With Quote
Unread 11/09/19, 01:06 PM  
Splat
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 17
Uploads: 5
I am struggling to replicate the issue at the moment.
Report comment to moderator  
Reply With Quote
Unread 11/06/19, 05:30 PM  
Pyrelle

Forum posts: 5
File comments: 4
Uploads: 0
UI Error

I just started getting the following error when I try to open the settings for Shissus.

bad argument #1 to 'ipairs' (table/struct expected, got nil)
stack traceback:
[C]: in function 'ipairs'
EsoUI/PregameAndIngame/Z0_Options/Keyboard/Z0_Options_Keyboard.lua:162: in function
'Z0_KeyboardOptions:PanelRequiresDeferredLoading'
EsoUI/PregameAndIngame/Z0_Options/Keyboard/Z0_Options_Keyboard.lua:146: in function
'Z0_KeyboardOptions:ChangePanels'
user:AddOns/ShissuFramework/settings.lua:847: in function 'panelData.callback'
EsoUI/Common/Z0_Gamemenu/Z0_GameMenu/lua:52: in function 'TreeEntryOnSelected'
EsoUI/Libraries/Z0_Tree/Z0_Tree.lua:705: in function 'Z0_TreeNode:OnSelected'
EsoUI/Libraries/Z0_Tree/Z0_Tree.lua:411: in function 'Z0_Tree:SelectNode'
EsoUI/Libraries/Z0_Tree/Z0_Tree.lua:888: in function 'Z0_TreeEntry_OnMouseUp'
(tail call): ?
Z0_CollectionsBook_TopLevelCategoriesScrollChildZ0_CollectionsBook_SubCategory1_Mouseup:3: in function '(main chunk)'

I have turned off all add-ons one by one to see if there is a conflict and it only happens with Shissus on. I made sure I have all the updated Libraries. This all started after the latest update to the patch. No idea why i am just now getting this error.
Last edited by Pyrelle : 11/08/19 at 07:29 PM.
Report comment to moderator  
Reply With Quote
Unread 11/04/19, 05:54 AM  
Splat
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 17
Uploads: 5
Patch released and awaiting verification on esoui.com
Report comment to moderator  
Reply With Quote
Unread 11/04/19, 05:39 AM  
Sordrak
 
Sordrak's Avatar
AddOn Author - Click to view AddOns

Forum posts: 38
File comments: 136
Uploads: 4
Originally Posted by Splat
Just to confirm if anyone has this issue that this was resolved in the most recent patch (1.4.2). Shissu does not make use of Libaddonmenu directly but has similar code included directly within the addon itself by the original author. I experienced the same issue on PTS and fixed the bug prior to release of the DLC.

I will be releasing another update today with a couple more bug fixes so if so are still experiencing the problem then please try the latest version 1.4.3 once it has been released.
Nice and thanks.
Report comment to moderator  
Reply With Quote
Unread 11/04/19, 04:59 AM  
Splat
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 17
Uploads: 5
Just to confirm if anyone has this issue that this was resolved in the most recent patch (1.4.2). Shissu does not make use of Libaddonmenu directly but has similar code included directly within the addon itself by the original author. I experienced the same issue on PTS and fixed the bug prior to release of the DLC.

I will be releasing another update today with a couple more bug fixes so if so are still experiencing the problem then please try the latest version 1.4.3 once it has been released.
Last edited by Splat : 11/04/19 at 05:05 AM.
Report comment to moderator  
Reply With Quote
Unread 10/30/19, 06:24 AM  
refinicus

Forum posts: 0
File comments: 53
Uploads: 0
same error here too
Report comment to moderator  
Reply With Quote
Unread 10/29/19, 02:27 PM  
zathmmo

Forum posts: 0
File comments: 8
Uploads: 0
Re: Re: Re: Re: Settings error

Originally Posted by MAOofDC
...
It's not game breaking just annoying I can live with it for now.
Another #me-too here with this error. Guild welcome message stopped working and when I went to check on it, the setup panel was missing and I found that same error in the bugcatcher log. I see that Votan's addon setup menu is also broken so the same game update likely impacted those as well.
Report comment to moderator  
Reply With Quote
Unread 10/28/19, 03:30 PM  
MAOofDC
 
MAOofDC's Avatar

Forum posts: 6
File comments: 29
Uploads: 0
Re: Re: Re: Settings error

Originally Posted by Sordrak
Originally Posted by IrishValkyrie
Originally Posted by MAOofDC
when you try to open the setting screen you get an error message and the menu area is blank.

I'm using this version, I haven't checked to see is there is a Dragonguard version yet.
Just to show that this isn't a one-off issue. I'm also seeing this problem, as is at least one other person I am aware of. We are up to date on LibAddonMenu and the problem shows up when all other addons are turned off.
Yes, i can reproduce it was well. Unfortunately, I do not have much time to code at the moment. I try to take a look at it on the next weekend (earlier might not be possible).
It's not game breaking just annoying I can live with it for now.
Report comment to moderator  
Reply With Quote
Unread 10/28/19, 02:26 AM  
Sordrak
 
Sordrak's Avatar
AddOn Author - Click to view AddOns

Forum posts: 38
File comments: 136
Uploads: 4
Re: Re: Settings error

Originally Posted by IrishValkyrie
Originally Posted by MAOofDC
when you try to open the setting screen you get an error message and the menu area is blank.

I'm using this version, I haven't checked to see is there is a Dragonguard version yet.
Just to show that this isn't a one-off issue. I'm also seeing this problem, as is at least one other person I am aware of. We are up to date on LibAddonMenu and the problem shows up when all other addons are turned off.
Yes, i can reproduce it was well. Unfortunately, I do not have much time to code at the moment. I try to take a look at it on the next weekend (earlier might not be possible).
Report comment to moderator  
Reply With Quote
Unread 10/26/19, 10:34 PM  
IrishValkyrie

Forum posts: 0
File comments: 1
Uploads: 0
Re: Settings error

Originally Posted by MAOofDC
when you try to open the setting screen you get an error message and the menu area is blank.

I'm using this version, I haven't checked to see is there is a Dragonguard version yet.
Just to show that this isn't a one-off issue. I'm also seeing this problem, as is at least one other person I am aware of. We are up to date on LibAddonMenu and the problem shows up when all other addons are turned off.
Report comment to moderator  
Reply With Quote
Unread 10/25/19, 10:28 AM  
MAOofDC
 
MAOofDC's Avatar

Forum posts: 6
File comments: 29
Uploads: 0
Re: Re: Re: Re: Re: Settings error

Originally Posted by Sordrak
Originally Posted by MAOofDC
Originally Posted by MAOofDC
Originally Posted by Sordrak
Originally Posted by MAOofDC
when you try to open the setting screen you get an error message and the menu area is blank.

I'm using this version, I haven't checked to see is there is a Dragonguard version yet.
Haven't had any issues myself. It could be related to LibAddOnMenu. Could you please try to update that library (i think the current version is r30).
Here is the short form of the error message.

bad argument #1 to 'ipairs' (table/struct expected, got nil)
stack traceback:
[C]: in function 'ipairs'
EsoUI/PregameAndIngame/ZO_Options/Keyboard/ZO_Options_Keyboard.lua:162: in function 'ZO_KeyboardOptions:PanelRequiresDeferredLoading'
EsoUI/PregameAndIngame/ZO_Options/Keyboard/ZO_Options_Keyboard.lua:146: in function 'ZO_KeyboardOptions:ChangePanels'
user:/AddOns/ShissuFramework/settings.lua:847: in function 'panelData.callback'
EsoUI/Common/ZO_GameMenu/ZO_GameMenu.lua:52: in function 'TreeEntryOnSelected'
EsoUI/Libraries/ZO_Tree/ZO_Tree.lua:705: in function 'ZO_TreeNode:OnSelected'
EsoUI/Libraries/ZO_Tree/ZO_Tree.lua:411: in function 'ZO_Tree:SelectNode'
EsoUI/Libraries/ZO_Tree/ZO_Tree.lua:888: in function 'ZO_TreeEntry_OnMouseUp'
ZO_CollectionsBook_TopLevelCategoriesScrollChildZO_CollectionsBook_SubCategory1_MouseUp:3: in function '(main chunk)'



The long form.


bad argument #1 to 'ipairs' (table/struct expected, got nil)
stack traceback:
[C]: in function 'ipairs'
EsoUI/PregameAndIngame/ZO_Options/Keyboard/ZO_Options_Keyboard.lua:162: in function 'ZO_KeyboardOptions:PanelRequiresDeferredLoading'
|caaaaaa<Locals> self = [table:1]{currentPanelId = 104, isGamepadOptions = F, currentPanel = 102}, panelId = 102 </Locals>|r
EsoUI/PregameAndIngame/ZO_Options/Keyboard/ZO_Options_Keyboard.lua:146: in function 'ZO_KeyboardOptions:ChangePanels'
|caaaaaa<Locals> self = [table:1], panelId = 102, panelName = "|c82FA58Shissu|ceeeeee's AddOn...", readyToShowPanel = T </Locals>|r
user:/AddOns/ShissuFramework/settings.lua:847: in function 'panelData.callback'
EsoUI/Common/ZO_GameMenu/ZO_GameMenu.lua:52: in function 'TreeEntryOnSelected'
|caaaaaa<Locals> control = ud, data = [table:2]{id = 102, categoryName = "Settings", name = "|c82FA58Shissu|ceeeeee's AddOn..."}, selected = T, reselectingDuringRebuild = F </Locals>|r
EsoUI/Libraries/ZO_Tree/ZO_Tree.lua:705: in function 'ZO_TreeNode:OnSelected'
|caaaaaa<Locals> self = [table:3]{childrenHeight = 0, childSpacing = 8, childrenCurrentHeight = 0, selectSound = "Click_TreeSubcategory", enabled = T, open = F, childIndent = 30, selected = F, openPercentage = 0}, reselectingDuringRebuild = F </Locals>|r
EsoUI/Libraries/ZO_Tree/ZO_Tree.lua:411: in function 'ZO_Tree:SelectNode'
|caaaaaa<Locals> self = [table:4]{width = 285, autoSelectChildOnNodeOpen = F, defaultIndent = 30, enabled = T, openAnimationDurationMS = 300, exclusive = T, suspendAnimations = F, defaultSpacing = 8}, treeNode = [table:3], reselectingDuringRebuild = F, bringParentIntoView = F </Locals>|r
EsoUI/Libraries/ZO_Tree/ZO_Tree.lua:888: in function 'ZO_TreeEntry_OnMouseUp'
|caaaaaa<Locals> self = ud, upInside = T, NOT_REBUILDING = F, DONT_BRING_PARENT_INTO_VIEW = F </Locals>|r
ZO_CollectionsBook_TopLevelCategoriesScrollChildZO_CollectionsBook_SubCategory1_MouseUp:3: in function '(main chunk)'
|caaaaaa<Locals> self = ud, button = 1, upInside = T, ctrl = F, alt = F, shift = F, command = F </Locals>|r
No idea what this is. I do not get this error and everything is working as before.

Could you try deactivating other addons to verify that it is caused by Shissus alone?
That is the error report I'm getting. I even tried turning off every add-on except for the guild tools and still got the error.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: