Quantcast
Download
(3 Kb)
Download
Updated: 03/01/20 06:48 PM
Pictures
File Info
Compatibility:
Harrowstorm (5.3.4)
Dragonhold (5.2.5)
Scalebreaker (5.1.5)
Elsweyr (5.0.5)
Updated:03/01/20 06:48 PM
Created:08/15/19 05:02 PM
Monthly downloads:669
Total downloads:5,955
Favorites:5
MD5:
Crystal Fragments Proc  Popular! (More than 5000 hits)
Version: 1.3
by: Supplier [More]
This addon detects when Crystal Fragments triggers the effect of granting the next use of 'Crystal Fragments' (Sorcerer's skill) as an instant cast ability with 50% cost of magicka and 20% more damage. It then alerts the user by displaying a big icon, along with a timer, on the screen.

Inspired by Reager's now-Discontinued addon of the same name: https://www.esoui.com/downloads/info443-CrystalFragmentsProc.html

Current Version: v1.3

By default, the addon will display a big alert icon, along with a timer, at the bottom center of the screen when Crystal Fragment Proc is triggered. Position of the icon can be adjusted and its new location will be automatically saved for future play sessions. The icon disappears as soon as it is casted or if buff duration is over.

To adjust the position of the icon:
/cfp show - Displays location of the icon. Simply use your mouse to drag it to your desired position.
/cfp hide - Hides the indicator after icon is at your desired position.

To save computing resources, the add-on will only activate for Sorcerers.

Limitations:
- English version of the game only

Note: As a disclaimer, the addon might not work properly for everyone. This is my first addon and I simply created this for a learning experience. I do plan on improving this addon in the future. The add-on is also fairly lightweight, but it does do a periodic check to see which slot the Crystal Fragment is in. This might have an effect on performance, but I haven't had any problem so far. If this addon does not work for you, I am certain there are other addons out there that does this better.

Please leave feedback! If there is a bug that I have not mentioned above, let me know so I can try to fix it!

Special thanks to: ESO UI Wiki and Forums

Change Log:

v1.3:
- Timer is now implemented in this addon. With this new feature, any bug that causes the alert icon to stay on the screen even when duration is over should now be fixed.
- Maintenance (matching APIVersion, documentation)

v1.2:
- Fixed a bug where the addon was also detecting other player's Crystal Fragment procs. Had no effect on user, but this bug fix should help with performance.

v1.1:
- Optimization
- Icon can now be moved. New location will be saved for future play sessions.
- Icon will remain visible until skill is casted or if duration is over
v1.3:
- Timer is now implemented in this addon. With this new feature, any bug that causes the alert icon to stay on the screen even when duration is over should now be fixed.
- Maintenance (matching APIVersion, documentation)

v1.2:
- Fixed a bug where the addon was also detecting other player's Crystal Fragment procs. Had no effect on user, but this bug fix should help with performance.

v1.1:
- Optimization
- Icon can now be moved. New location will be saved for future play sessions.
- Icon will remain visible until skill is casted or if duration is over
Optional Files (0)


Archived Files (4)
File Name
Version
Size
Uploader
Date
1.2
3kB
Supplier
08/18/19 03:46 PM
1.2
3kB
Supplier
08/18/19 03:40 PM
1.1
3kB
Supplier
08/17/19 02:13 AM
1.0
2kB
Supplier
08/16/19 12:27 PM


Post A Reply Comment Options
Unread 04/23/20, 06:42 PM  
Supplier
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 12
Uploads: 2
Originally Posted by Nyyxxon
Hi Supplier,

First off thanks for the addon, does exactly what I need it to do, but I have had a small issue in V1.3. Quite often I would get an issue with "duration" being "nil" reported at line 95. I am guessing there is another addon which is using "duration" as a global and at some point resetting it.

I changed "duration" to "crystalFragduration" and it fixed it for me, just thought I would let you know in case others are having a similar issue
Thanks for bringing this to my attention. This is definitely something I will be fixing very soon!
Report comment to moderator  
Reply With Quote
Unread 04/22/20, 05:04 AM  
Nyyxxon

Forum posts: 0
File comments: 1
Uploads: 0
Hi Supplier,

First off thanks for the addon, does exactly what I need it to do, but I have had a small issue in V1.3. Quite often I would get an issue with "duration" being "nil" reported at line 95. I am guessing there is another addon which is using "duration" as a global and at some point resetting it.

I changed "duration" to "crystalFragduration" and it fixed it for me, just thought I would let you know in case others are having a similar issue
Last edited by Nyyxxon : 04/22/20 at 05:05 AM.
Report comment to moderator  
Reply With Quote
Unread 03/01/20, 06:41 PM  
Supplier
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 12
Uploads: 2
Originally Posted by sonwon
Originally Posted by Supplier
Originally Posted by sonwon
Originally Posted by Supplier
Originally Posted by sonwon
Originally Posted by Supplier
Hm, I made sure to fix that a while back. Which version do you have installed? You can try to going to the folder of the Addon and clicking CrystalFragmentsProc.txt. The version will be listed there.

Edit: I have ran dungeons a couple of times now, and I can't seem to replicate the problem. I will keep trying though.
Version: 1.2
APIVersion: 100028
Are you casting Crystal Fragments in its normal state, or in other words, when it's not procced?
Normally only when it proc. I didn't have any problem today so maybe the update fixed the problem?
I didn't update it recently. But if you updated to 1.2 just now, then that might be it.

EDIT: The bug finally occurred for me. I don't think I am able to fix it, because I believe it's because of ESO coding. If you look at the skill hotbar, you will see that it gets stuck there too. It fixs itself on the next proc though.
Is it possible to have a watchdog timer that would remove it or maybe issue the remove command twice?

I suppose there is no way for the code to see that the icon is still there.
Really late, but I have updated my addon to prevent that bug from ever happening by introducing a timer like you suggested.
Last edited by Supplier : 03/01/20 at 06:41 PM.
Report comment to moderator  
Reply With Quote
Unread 09/11/19, 01:41 PM  
sonwon

Forum posts: 0
File comments: 43
Uploads: 0
Originally Posted by Supplier
Originally Posted by sonwon
Originally Posted by Supplier
Originally Posted by sonwon
Originally Posted by Supplier
Hm, I made sure to fix that a while back. Which version do you have installed? You can try to going to the folder of the Addon and clicking CrystalFragmentsProc.txt. The version will be listed there.

Edit: I have ran dungeons a couple of times now, and I can't seem to replicate the problem. I will keep trying though.
Version: 1.2
APIVersion: 100028
Are you casting Crystal Fragments in its normal state, or in other words, when it's not procced?
Normally only when it proc. I didn't have any problem today so maybe the update fixed the problem?
I didn't update it recently. But if you updated to 1.2 just now, then that might be it.

EDIT: The bug finally occurred for me. I don't think I am able to fix it, because I believe it's because of ESO coding. If you look at the skill hotbar, you will see that it gets stuck there too. It fixs itself on the next proc though.
Is it possible to have a watchdog timer that would remove it or maybe issue the remove command twice?

I suppose there is no way for the code to see that the icon is still there.
Report comment to moderator  
Reply With Quote
Unread 09/09/19, 03:31 PM  
Supplier
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 12
Uploads: 2
Originally Posted by sonwon
Originally Posted by Supplier
Originally Posted by sonwon
Originally Posted by Supplier
Hm, I made sure to fix that a while back. Which version do you have installed? You can try to going to the folder of the Addon and clicking CrystalFragmentsProc.txt. The version will be listed there.

Edit: I have ran dungeons a couple of times now, and I can't seem to replicate the problem. I will keep trying though.
Version: 1.2
APIVersion: 100028
Are you casting Crystal Fragments in its normal state, or in other words, when it's not procced?
Normally only when it proc. I didn't have any problem today so maybe the update fixed the problem?
I didn't update it recently. But if you updated to 1.2 just now, then that might be it.

EDIT: The bug finally occurred for me. I don't think I am able to fix it, because I believe it's because of ESO coding. If you look at the skill hotbar, you will see that it gets stuck there too. It fixs itself on the next proc though.
Last edited by Supplier : 09/09/19 at 07:41 PM.
Report comment to moderator  
Reply With Quote
Unread 09/09/19, 01:16 PM  
sonwon

Forum posts: 0
File comments: 43
Uploads: 0
Originally Posted by Supplier
Originally Posted by sonwon
Originally Posted by Supplier
Hm, I made sure to fix that a while back. Which version do you have installed? You can try to going to the folder of the Addon and clicking CrystalFragmentsProc.txt. The version will be listed there.

Edit: I have ran dungeons a couple of times now, and I can't seem to replicate the problem. I will keep trying though.
Version: 1.2
APIVersion: 100028
Are you casting Crystal Fragments in its normal state, or in other words, when it's not procced?
Normally only when it proc. I didn't have any problem today so maybe the update fixed the problem?
Report comment to moderator  
Reply With Quote
Unread 09/09/19, 12:12 PM  
Supplier
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 12
Uploads: 2
Originally Posted by sonwon
Originally Posted by Supplier
Hm, I made sure to fix that a while back. Which version do you have installed? You can try to going to the folder of the Addon and clicking CrystalFragmentsProc.txt. The version will be listed there.

Edit: I have ran dungeons a couple of times now, and I can't seem to replicate the problem. I will keep trying though.
Version: 1.2
APIVersion: 100028
Are you casting Crystal Fragments in its normal state, or in other words, when it's not procced?
Report comment to moderator  
Reply With Quote
Unread 09/09/19, 06:52 AM  
sonwon

Forum posts: 0
File comments: 43
Uploads: 0
Originally Posted by Supplier
Hm, I made sure to fix that a while back. Which version do you have installed? You can try to going to the folder of the Addon and clicking CrystalFragmentsProc.txt. The version will be listed there.

Edit: I have ran dungeons a couple of times now, and I can't seem to replicate the problem. I will keep trying though.
Version: 1.2
APIVersion: 100028
Report comment to moderator  
Reply With Quote
Unread 09/08/19, 09:34 AM  
Supplier
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 12
Uploads: 2
Originally Posted by sonwon
Originally Posted by Supplier
Originally Posted by sonwon
Originally Posted by Supplier
Originally Posted by sonwon
Originally Posted by sonwon
Originally Posted by Supplier
I will look into it, but if it doesn't happen that often, just type in /cfp hide to manually hide it.

EDIT: Have you noticed when it usually happens?
I'll try that and report back. I am also thinking it could have something to do with the icon on top of the aiming sight. I will also try moving the position.
It may have something to do with City of Ash since it worked perfectly today. Yesterday I was in CoA when it acted up.
I will run the dungeon a few times and see if I can replicate the problem.
It stuck again today, only happens when I am in a dungeon. The /cfp hide works.
Do you remember if there was another sorcerer in your party?
Recently I've been playing in parties with 2-4 sorcs.
Hm, I made sure to fix that a while back. Which version do you have installed? You can try to going to the folder of the Addon and clicking CrystalFragmentsProc.txt. The version will be listed there.

Edit: I have ran dungeons a couple of times now, and I can't seem to replicate the problem. I will keep trying though.
Last edited by Supplier : 09/08/19 at 12:55 PM.
Report comment to moderator  
Reply With Quote
Unread 09/08/19, 04:11 AM  
sonwon

Forum posts: 0
File comments: 43
Uploads: 0
Originally Posted by Supplier
Originally Posted by sonwon
Originally Posted by Supplier
Originally Posted by sonwon
Originally Posted by sonwon
Originally Posted by Supplier
I will look into it, but if it doesn't happen that often, just type in /cfp hide to manually hide it.

EDIT: Have you noticed when it usually happens?
I'll try that and report back. I am also thinking it could have something to do with the icon on top of the aiming sight. I will also try moving the position.
It may have something to do with City of Ash since it worked perfectly today. Yesterday I was in CoA when it acted up.
I will run the dungeon a few times and see if I can replicate the problem.
It stuck again today, only happens when I am in a dungeon. The /cfp hide works.
Do you remember if there was another sorcerer in your party?
Recently I've been playing in parties with 2-4 sorcs.
Report comment to moderator  
Reply With Quote
Unread 09/07/19, 10:59 PM  
Supplier
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 12
Uploads: 2
Originally Posted by sonwon
Originally Posted by Supplier
Originally Posted by sonwon
Originally Posted by sonwon
Originally Posted by Supplier
I will look into it, but if it doesn't happen that often, just type in /cfp hide to manually hide it.

EDIT: Have you noticed when it usually happens?
I'll try that and report back. I am also thinking it could have something to do with the icon on top of the aiming sight. I will also try moving the position.
It may have something to do with City of Ash since it worked perfectly today. Yesterday I was in CoA when it acted up.
I will run the dungeon a few times and see if I can replicate the problem.
It stuck again today, only happens when I am in a dungeon. The /cfp hide works.
Do you remember if there was another sorcerer in your party?
Last edited by Supplier : 09/08/19 at 12:00 AM.
Report comment to moderator  
Reply With Quote
Unread 09/07/19, 01:27 PM  
sonwon

Forum posts: 0
File comments: 43
Uploads: 0
Originally Posted by Supplier
Originally Posted by sonwon
Originally Posted by sonwon
Originally Posted by Supplier
I will look into it, but if it doesn't happen that often, just type in /cfp hide to manually hide it.

EDIT: Have you noticed when it usually happens?
I'll try that and report back. I am also thinking it could have something to do with the icon on top of the aiming sight. I will also try moving the position.
It may have something to do with City of Ash since it worked perfectly today. Yesterday I was in CoA when it acted up.
I will run the dungeon a few times and see if I can replicate the problem.
It stuck again today, only happens when I am in a dungeon. The /cfp hide works.
Report comment to moderator  
Reply With Quote
Unread 09/07/19, 11:38 AM  
Supplier
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 12
Uploads: 2
Originally Posted by sonwon
Originally Posted by sonwon
Originally Posted by Supplier
I will look into it, but if it doesn't happen that often, just type in /cfp hide to manually hide it.

EDIT: Have you noticed when it usually happens?
I'll try that and report back. I am also thinking it could have something to do with the icon on top of the aiming sight. I will also try moving the position.
It may have something to do with City of Ash since it worked perfectly today. Yesterday I was in CoA when it acted up.
I will run the dungeon a few times and see if I can replicate the problem.
Report comment to moderator  
Reply With Quote
Unread 09/06/19, 02:05 PM  
sonwon

Forum posts: 0
File comments: 43
Uploads: 0
Originally Posted by sonwon
Originally Posted by Supplier
I will look into it, but if it doesn't happen that often, just type in /cfp hide to manually hide it.

EDIT: Have you noticed when it usually happens?
I'll try that and report back. I am also thinking it could have something to do with the icon on top of the aiming sight. I will also try moving the position.
It may have something to do with City of Ash since it worked perfectly today. Yesterday I was in CoA when it acted up.
Report comment to moderator  
Reply With Quote
Unread 09/06/19, 07:41 AM  
sonwon

Forum posts: 0
File comments: 43
Uploads: 0
Originally Posted by Supplier
I will look into it, but if it doesn't happen that often, just type in /cfp hide to manually hide it.

EDIT: Have you noticed when it usually happens?
I'll try that and report back. I am also thinking it could have something to do with the icon on top of the aiming sight. I will also try moving the position.
Last edited by sonwon : 09/06/19 at 02:04 PM.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: