Quantcast
Download
(177 Kb)
Download
Updated: 10/13/18 12:58 PM
Patch for:
AlphaGear 2.
Pictures
File Info
Compatibility:
Wolfhunter (4.1)
Updated:10/13/18 12:58 PM
Created:10/12/17 01:22 PM
Monthly downloads:54
Total downloads:40,597
Favorites:11
MD5:
AlphaGear 2 Test and Debug Channel (inactive)  Popular! (More than 5000 hits)
Version: 6.4.1 beta 1
by: mesota [More]
Version 6.4.1 has Profiles!


This is experimental!
Use at own risk!


Be sure to make a backup of your savedvariables/AlphaGear.lua

You have been warned!


-mesota
Version 6.2.0 alpha 3
  • ESO 3.3 (Dragon Bones)
  • Added outfits to set-configuration
  • Fixed: Texture-Bug
  • Performance improvements
  • Fixed bug when swapping weapon from one slot to another
Archived Files (6)
File Name
Version
Size
Uploader
Date
6.2.0 beta 2
162kB
mesota
03/10/18 06:48 AM
6.2.0 beta 1
162kB
mesota
03/06/18 04:28 PM
6.2.0 alpha 4
160kB
mesota
03/03/18 04:52 PM
6.2.0 alpha 3
160kB
mesota
02/24/18 03:06 PM
6.2.0 alpha 2
159kB
mesota
02/20/18 10:48 AM
6.2.0 alpha
159kB
mesota
02/20/18 01:30 AM


Post A Reply Comment Options
Unread 04/10/18, 12:06 AM  
mesota
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 154
Uploads: 4
Re: Re: Re: Worn items panel

Originally Posted by rumple9
Originally Posted by mesota
Originally Posted by rumple9
On the Worn items panel can you add an indicator such as L,M,H to show whether the armour is light, medium or heavy, next to the level indicator please
Added to the wish-list.

-mesota
Actually the addon FCO item saver does this too - see screenshot


https://imgur.com/a/NJVf8
Thanks for the info.

-mesota
Report comment to moderator  
Reply With Quote
Unread 04/09/18, 07:25 PM  
rumple9

Forum posts: 0
File comments: 11
Uploads: 0
Re: Re: Worn items panel

Originally Posted by mesota
Originally Posted by rumple9
On the Worn items panel can you add an indicator such as L,M,H to show whether the armour is light, medium or heavy, next to the level indicator please
Added to the wish-list.

-mesota
Actually the addon FCO item saver does this too - see screenshot


https://imgur.com/a/NJVf8
Report comment to moderator  
Reply With Quote
Unread 03/31/18, 01:08 PM  
mesota
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 154
Uploads: 4
Re: Thanks for your hard work!

Originally Posted by A_Darklore
Just wanted to add a THANK YOU to Mesota for his hard work in keeping this addon updated and fixing any issues the crop up.
Highly appreciated.

-mesota
Report comment to moderator  
Reply With Quote
Unread 03/31/18, 07:29 AM  
A_Darklore

Forum posts: 0
File comments: 57
Uploads: 0
Thumbs up Thanks for your hard work!

Just wanted to add a THANK YOU to Mesota for his hard work in keeping this addon updated and fixing any issues the crop up.
Report comment to moderator  
Reply With Quote
Unread 03/12/18, 05:44 PM  
Hoft
 
Hoft's Avatar
AddOn Author - Click to view AddOns

Forum posts: 16
File comments: 476
Uploads: 8
Originally Posted by mesota
1. Changed the default to "Keep current outfit" in beta2. But can't reproduce your problem. Changes of the outfit are delayed by ESO. Maybe you're trying to swap sets to fast.

2. Same as 1.

3. Reworked Out-of-Combat queue. Please try again with beta2.
1,2. Outfit removes when I use button that binded to "clean" set section in AG with option "no outfit", so "Keep current outfit" by default solves this problem. Thank you!

3. This happens from time to time. Testing.
Report comment to moderator  
Reply With Quote
Unread 03/10/18, 06:57 AM  
mesota
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 154
Uploads: 4
Originally Posted by Hoft
Hello!
1. Can you make "Keep current outfit" by default? And. This option always do not keeps, but removes equiped outfit. It happens with delay.

2. Selected outfit also disapers with delay.

3. Message "Set n will be equiped when out-of combat" appears even out of combat and nothing happens.

4. Option "Number of set buttons" changes nothing.

5. Can you add Apperance slot to sets?
1. Changed the default to "Keep current outfit" in beta2. But can't reproduce your problem. Changes of the outfit are delayed by ESO. Maybe you're trying to swap sets to fast.

2. Same as 1.

3. Reworked Out-of-Combat queue. Please try again with beta2.

4. It changes the number of shown buttons if "Show UI-set buttons" is enabled

5. Already on wish-list. Maybe 6.2.1

Could you provide feedback for 1 and 3?

Thanks
-mesota
Report comment to moderator  
Reply With Quote
Unread 03/08/18, 11:40 PM  
Hoft
 
Hoft's Avatar
AddOn Author - Click to view AddOns

Forum posts: 16
File comments: 476
Uploads: 8
Hello!
1. Can you make "Keep current outfit" by default? And. This option always do not keeps, but removes equiped outfit. It happens with delay.

2. Selected outfit also disapers with delay.

3. Message "Set n will be equiped when out-of combat" appears even out of combat and nothing happens.

4. Option "Number of set buttons" changes nothing.

5. Can you add Apperance slot to sets?
Last edited by Hoft : 03/09/18 at 05:28 AM.
Report comment to moderator  
Reply With Quote
Unread 03/08/18, 01:01 PM  
mesota
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 154
Uploads: 4
Re: Worn items panel

Originally Posted by rumple9
On the Worn items panel can you add an indicator such as L,M,H to show whether the armour is light, medium or heavy, next to the level indicator please
Added to the wish-list.

-mesota
Report comment to moderator  
Reply With Quote
Unread 03/08/18, 12:57 PM  
mesota
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 154
Uploads: 4
Originally Posted by Majeure
Hey, I get no error, but this addon stops working for action bars after doing some battlegrounds. No hotkeys, no manual clicking in the UI, nothing loads action bars anymore. Gear swaps, but not bars until I reloadui.

Completely unusable for battlegrounds which is what I'd use this most for, since I like to hotswap between DD and heal for them.
Sorry to hear that. As you might have seen, I spend a lot of time in helping and fixing bugs. Just as I'm willing to help you with this problem but I'd appreciate if you'd show a little more respect.

Instead of complaining you could provide some more details:
  • If this situation occurs, can you still assign skills manually from the ESO skill dialog?
  • Can you reproduce this problem without any other AddOn active?
  • Would you like to invest some time to try out a version with additional debug output?

-mesota
Report comment to moderator  
Reply With Quote
Unread 03/08/18, 11:56 AM  
rumple9

Forum posts: 0
File comments: 11
Uploads: 0
Worn items panel

On the Worn items panel can you add an indicator such as L,M,H to show whether the armour is light, medium or heavy, next to the level indicator please
Report comment to moderator  
Reply With Quote
Unread 03/07/18, 05:50 PM  
Majeure
 
Majeure's Avatar

Forum posts: 7
File comments: 129
Uploads: 0
Hey, I get no error, but this addon stops working for action bars after doing some battlegrounds. No hotkeys, no manual clicking in the UI, nothing loads action bars anymore. Gear swaps, but not bars until I reloadui.

Completely unusable for battlegrounds which is what I'd use this most for, since I like to hotswap between DD and heal for them.
__________________
@Majeure | CP 900+ | Former Emperor | Master Angler | PC EU | Blood for the Pact!
Flawless Warden | Flawless Dragonknight | Flawless Templar | Flawless Nightblade | Flawless Sorcerer
YouTube | Website | Twitch | Twitter
Last edited by Majeure : 03/07/18 at 05:53 PM.
Report comment to moderator  
Reply With Quote
Unread 03/06/18, 04:44 PM  
mesota
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 154
Uploads: 4
Originally Posted by MK32
Originally Posted by mesota
Originally Posted by MK32
Originally Posted by mesota
Originally Posted by Nighn_9
I sometimes get an error message when i use "Inventory Insight" with this addon
Please provide more details:
  • Screenshots
  • Error messages
  • Version of Inventory Insight
  • Steps which led to the problem

-mesota
user:/AddOns/IIfA/IIfADataCollection.lua:519:attempt to index a nil value
stack traceback:
user:/AddOns/IIfA/IIfADataCollection.lua:519:in function 'IIfA:EvalBagItem'
user:/AddOns/IIfA/IIfAEvents.lua:52:in function 'IIfA:InventorySlotUpdate'
user:/AddOns/IIfA/IIfAEvents.lua:76:in function 'IIfA_InventorySlotUpdate'

Happens when swapping from one gear set to another but not all the time. Might be related to if it is trying to switch to something that is no longer in inventory. It also might be because IIfA recently switched to real time update of inventory which might conflict with how this addon removes and replaces into inventory.

Latest version of both Inventory Insight and this addon.
Thanks for the details. As you can see by the path (IIfA) the problem occurs in Inventory Insight. I've seen others commenting the same issue over there. Don't think that I'm doing something wrong.

-mesota
I agree. Either addon by itself works correctly. It is just an incompatibility when both are loaded.
They've just provided a fix for the error in line 519. Should work now.

-mesota
Report comment to moderator  
Reply With Quote
Unread 03/05/18, 07:47 PM  
MK32

Forum posts: 0
File comments: 121
Uploads: 0
Originally Posted by mesota
Originally Posted by MK32
Originally Posted by mesota
Originally Posted by Nighn_9
I sometimes get an error message when i use "Inventory Insight" with this addon
Please provide more details:
  • Screenshots
  • Error messages
  • Version of Inventory Insight
  • Steps which led to the problem

-mesota
user:/AddOns/IIfA/IIfADataCollection.lua:519:attempt to index a nil value
stack traceback:
user:/AddOns/IIfA/IIfADataCollection.lua:519:in function 'IIfA:EvalBagItem'
user:/AddOns/IIfA/IIfAEvents.lua:52:in function 'IIfA:InventorySlotUpdate'
user:/AddOns/IIfA/IIfAEvents.lua:76:in function 'IIfA_InventorySlotUpdate'

Happens when swapping from one gear set to another but not all the time. Might be related to if it is trying to switch to something that is no longer in inventory. It also might be because IIfA recently switched to real time update of inventory which might conflict with how this addon removes and replaces into inventory.

Latest version of both Inventory Insight and this addon.
Thanks for the details. As you can see by the path (IIfA) the problem occurs in Inventory Insight. I've seen others commenting the same issue over there. Don't think that I'm doing something wrong.

-mesota
I agree. Either addon by itself works correctly. It is just an incompatibility when both are loaded.
Report comment to moderator  
Reply With Quote
Unread 03/04/18, 05:15 PM  
mesota
AddOn Author - Click to view AddOns

Forum posts: 2
File comments: 154
Uploads: 4
Originally Posted by MK32
Originally Posted by mesota
Originally Posted by Nighn_9
I sometimes get an error message when i use "Inventory Insight" with this addon
Please provide more details:
  • Screenshots
  • Error messages
  • Version of Inventory Insight
  • Steps which led to the problem

-mesota
user:/AddOns/IIfA/IIfADataCollection.lua:519:attempt to index a nil value
stack traceback:
user:/AddOns/IIfA/IIfADataCollection.lua:519:in function 'IIfA:EvalBagItem'
user:/AddOns/IIfA/IIfAEvents.lua:52:in function 'IIfA:InventorySlotUpdate'
user:/AddOns/IIfA/IIfAEvents.lua:76:in function 'IIfA_InventorySlotUpdate'

Happens when swapping from one gear set to another but not all the time. Might be related to if it is trying to switch to something that is no longer in inventory. It also might be because IIfA recently switched to real time update of inventory which might conflict with how this addon removes and replaces into inventory.

Latest version of both Inventory Insight and this addon.
Thanks for the details. As you can see by the path (IIfA) the problem occurs in Inventory Insight. I've seen others commenting the same issue over there. Don't think that I'm doing something wrong.

-mesota
Report comment to moderator  
Reply With Quote
Unread 03/04/18, 04:46 PM  
MK32

Forum posts: 0
File comments: 121
Uploads: 0
Originally Posted by mesota
Originally Posted by Nighn_9
I sometimes get an error message when i use "Inventory Insight" with this addon
Please provide more details:
  • Screenshots
  • Error messages
  • Version of Inventory Insight
  • Steps which led to the problem

-mesota
user:/AddOns/IIfA/IIfADataCollection.lua:519:attempt to index a nil value
stack traceback:
user:/AddOns/IIfA/IIfADataCollection.lua:519:in function 'IIfA:EvalBagItem'
user:/AddOns/IIfA/IIfAEvents.lua:52:in function 'IIfA:InventorySlotUpdate'
user:/AddOns/IIfA/IIfAEvents.lua:76:in function 'IIfA_InventorySlotUpdate'

Happens when swapping from one gear set to another but not all the time. Might be related to if it is trying to switch to something that is no longer in inventory. It also might be because IIfA recently switched to real time update of inventory which might conflict with how this addon removes and replaces into inventory.

Latest version of both Inventory Insight and this addon.
Last edited by MK32 : 03/04/18 at 04:49 PM.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: