Quantcast
Download
(51 Kb)
Download
Updated: 09/20/18 07:27 AM
Compatibility:
Wolfhunter (4.1)
Summerset (4.0)
Updated:09/20/18 07:27 AM
Created:08/02/18 07:00 PM
Monthly downloads:105
Total downloads:374
Favorites:2
MD5:
4.1
STFU Elemental Weapons
Version: 1.5
by: Jodynn [More]
Try to reduce the Painful sound of imbue/crushing/elemental weapon.

Also, has an option to show your Spell Orb Count
V 1.1 - Add spell orb text indicating how many you have up
V 1.2 - Fixed a bug with font for spell orb and use ability id instead of name so that it will be language independent.
V 1.3 - Remove the debugging, @[email protected], and also updated version numbers
V 1.4 - Requires LibMediaProvider and LibAddonMenu now
Archived Files (4)
File Name
Version
Size
Author
Date
1.4
48kB
Jodynn
09/02/18 10:31 AM
1.2
48kB
Jodynn
08/31/18 10:58 AM
1.1
48kB
Jodynn
08/04/18 11:52 PM
1
48kB
Jodynn
08/02/18 07:00 PM


Post A Reply Comment Options
Unread 09/20/18, 02:35 PM  
Andrea

Forum posts: 0
File comments: 13
Uploads: 0
Originally Posted by Jodynn
Originally Posted by Andrea
Originally Posted by Jodynn
Originally Posted by Jodynn
Originally Posted by Andrea
Just installed the app, also downloaded LibMediaProvider but i am getting this error



I will lool into it, sorry for that!!
try 1.5 out
You mean this ?
LibMediaProvider 1.0 r5 - 07/17/14 08:49 PM

I didn't understand correctly what to do (I downloaded all through minion client)
nah just update elemental weapon, it was my fault, I'm not hosting the lib
Nice, it works now, thanks !
Report comment to moderator  
Reply With Quote
Unread 09/20/18, 01:40 PM  
Jodynn
 
Jodynn's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 45
Uploads: 3
Originally Posted by Andrea
Originally Posted by Jodynn
Originally Posted by Jodynn
Originally Posted by Andrea
Just installed the app, also downloaded LibMediaProvider but i am getting this error



I will lool into it, sorry for that!!
try 1.5 out
You mean this ?
LibMediaProvider 1.0 r5 - 07/17/14 08:49 PM

I didn't understand correctly what to do (I downloaded all through minion client)
nah just update elemental weapon, it was my fault, I'm not hosting the lib
Report comment to moderator  
Reply With Quote
Unread 09/20/18, 09:50 AM  
Andrea

Forum posts: 0
File comments: 13
Uploads: 0
Originally Posted by Jodynn
Originally Posted by Jodynn
Originally Posted by Andrea
Just installed the app, also downloaded LibMediaProvider but i am getting this error



I will lool into it, sorry for that!!
try 1.5 out
You mean this ?
LibMediaProvider 1.0 r5 - 07/17/14 08:49 PM

I didn't understand correctly what to do (I downloaded all through minion client)
Last edited by Andrea : 09/20/18 at 10:01 AM.
Report comment to moderator  
Reply With Quote
Unread 09/20/18, 07:27 AM  
Jodynn
 
Jodynn's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 45
Uploads: 3
Originally Posted by Jodynn
Originally Posted by Andrea
Just installed the app, also downloaded LibMediaProvider but i am getting this error



I will lool into it, sorry for that!!
try 1.5 out
Report comment to moderator  
Reply With Quote
Unread 09/20/18, 06:44 AM  
Jodynn
 
Jodynn's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 45
Uploads: 3
Originally Posted by Andrea
Just installed the app, also downloaded LibMediaProvider but i am getting this error



I will lool into it, sorry for that!!
Report comment to moderator  
Reply With Quote
Unread 09/20/18, 02:54 AM  
Andrea

Forum posts: 0
File comments: 13
Uploads: 0
Just installed the app, also downloaded LibMediaProvider but i am getting this error


user:/AddOns/STFUElementalWeapon/STFUElementalWeapon.lua:1: Cannot find a library instance of "LibMediaProvider-1.0".
stack traceback:
user:/AddOns/DeathReport/libs/LibStub/LibStub.lua:29: in function 'LibStub:GetLibrary'
|caaaaaa<Locals> self = tbl, major = "LibMediaProvider-1.0" </Locals>|r
user:/AddOns/STFUElementalWeapon/STFUElementalWeapon.lua:1: in function '(main chunk)'
Report comment to moderator  
Reply With Quote
Unread 09/07/18, 05:29 AM  
Iliana
 
Iliana's Avatar

Forum posts: 0
File comments: 9
Uploads: 0
Originally Posted by Jodynn
Thank you so much for your continued feedback and patience!!
You are more than welcome!
Report comment to moderator  
Reply With Quote
Unread 09/06/18, 10:08 AM  
Jodynn
 
Jodynn's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 45
Uploads: 3
Originally Posted by Iliana
Okay. Me again. It is still working as it should, but I get this now



Not sure what it means or how it will affect anything, just thought I would share it
@[email protected] ohmygoodness, that's my fault, I need to require that library in the mainfest so that it tells you you must install the library to use that addon so whenever it tries to access that library it won't give you that error.

Currently at work, but! if you install the addon LibMediaProvider it'll fix the issue, it's a library that the font or sound depend on ( I don't remember which I think font though ).

Thank you so much for your continued feedback and patience!!
Report comment to moderator  
Reply With Quote
Unread 09/06/18, 09:58 AM  
Iliana
 
Iliana's Avatar

Forum posts: 0
File comments: 9
Uploads: 0
Okay. Me again. It is still working as it should, but I get this now



Not sure what it means or how it will affect anything, just thought I would share it
Last edited by Iliana : 09/06/18 at 09:59 AM.
Report comment to moderator  
Reply With Quote
Unread 09/02/18, 10:26 AM  
Jodynn
 
Jodynn's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 45
Uploads: 3
X.X

Oh my goodness I forgot to take that out haha, thank you so much, let me fix that super quick X.X

Originally Posted by Iliana
It works great now!
Only thing I get now in chat is this:



I guess it's the debugging?

Edit:

Actually, as long as the addon is active I get that for every skill I cast.
Report comment to moderator  
Reply With Quote
Unread 09/01/18, 03:45 AM  
Iliana
 
Iliana's Avatar

Forum posts: 0
File comments: 9
Uploads: 0
It works great now!
Only thing I get now in chat is this:



I guess it's the debugging?

Edit:

Actually, as long as the addon is active I get that for every skill I cast.
Last edited by Iliana : 09/01/18 at 04:04 AM.
Report comment to moderator  
Reply With Quote
Unread 08/31/18, 10:45 AM  
Jodynn
 
Jodynn's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 45
Uploads: 3
Sorry!

Sorry it took me so long to respond!

I have a fix pending, V1.2 local testing worked but let me know if it doesn't!

Thank you!
Last edited by Jodynn : 08/31/18 at 10:58 AM.
Report comment to moderator  
Reply With Quote
Unread 08/21/18, 12:09 PM  
Iliana
 
Iliana's Avatar

Forum posts: 0
File comments: 9
Uploads: 0
God, this would be such an amazing addon, if it would still work!

But when I want to use it, it returns these errors:

user:/AddOns/STFUElementalWeapon/STFUElementalWeapon.lua:297: attempt to index a nil value
stack traceback:
user:/AddOns/STFUElementalWeapon/STFUElementalWeapon.lua:297: in function 'STFU.createSettingsPage'
<Locals> LAM = tbl, dropFontStyle = tbl, panelData = tbl </Locals>
user:/AddOns/STFUElementalWeapon/STFUElementalWeapon.lua:39: in function 'STFU.OnInitialized'
<Locals> eventCode = 65536, addOnName = "STFUElementalWeapon" </Locals>

---

user:/AddOns/STFUElementalWeapon/STFUElementalWeapon.lua:79: operator + is not supported for nil + number
stack traceback:
user:/AddOns/STFUElementalWeapon/STFUElementalWeapon.lua:79: in function 'STFU.gimmeSoundBack'
Last edited by Iliana : 08/21/18 at 12:10 PM.
Report comment to moderator  
Reply With Quote
Unread 08/05/18, 05:59 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 1767
File comments: 1862
Uploads: 47
Hey good idea but could you pleae make the skill check not using the names but their abiliityIds instead as this will make the addon work with multiple languages!
If you would check the names within other clients you might get in trouble too as the names in French and German contain gender specific strings at the end, like "Poison injection^f" as it is feminin etc.

Not sure how you are able to get the abilityId of the actionSlot. If I use /zgoo mouse on my 2nd bar's 1st slot having poision injection slotted there is the control "ActionButton2Button" with the atrtibute "actionId" = 38660 which is the abilityId for poison injection.

I remember there was a function to return this ability/actionId. Still searching it for you.
Edit:
GetSlotBoundId(slotId) where slotId is the slot number of the action slot.
e.g. Slot 3 is the 1st skill, and 7 the last on the bar.

And the abilityIds for the abilities in question can be found here via their names:
http://esoitem.uesp.net/viewSkills.php

The ids should be the following ones.
You need to use abilityId not baseAbilityId (as this is only the base skill's ability id, not the morph ids, so Imbue weapon is the base)

Name
baseAbilityId
abilityId
Imbue weapon
103483
103483
Elemental weapon
103483
103571
Crushing weapon
103483
103623
Last edited by Baertram : 08/05/18 at 06:11 AM.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: