Quantcast
Download
(86 Kb)
Download
Updated: 05/23/19 04:10 PM
Pictures
File Info
Compatibility:
Elsweyr (5.0.5)
Wrathstone (4.3)
Murkmire (4.2)
Wolfhunter (4.1)
Summerset (4.0)
Updated:05/23/19 04:10 PM
Created:09/02/18 07:05 AM
Monthly downloads:2,282
Total downloads:34,504
Favorites:61
MD5:
SuperStar - Summerset Update  Popular! (More than 5000 hits)
Version: 4.2.0
by: Sigo Dest [More]
This is a patch to bring SuperStar in line with the Summerset/Wolfhunter (#100024) patches, and now Elsweyr (#100027) as well!
Please visit the actual add-on site >> here << for the description, and a 25 minute demonstration video by the author, Ayantir.

With the revamp to the ZO_Skills system, a lot of functionality has changed (for the better), and SuperStar should probably be re-written from the ground up.

Major Changes:
Added new class "Necromancer". *still in testing*
Added new guild skill line "Psijic Order".
Added new tradeskill skill line "Jewelry Crafting".
Changed the skill revision to "3" from "2", and added functionality to try to update older favorites to reflect the new skill changes.
* Older favorites may not update. More testing is required. The update makes a copy of the old favorite, so your saves should not be overwritten.

Notes:
I play on an "en" client. I've tested as much as I could on the "fr" client. A major difference I noticed is the Werewolf line "Loup-garou" seems to have changed places in the new update. This might cause issues I didn't anticipate. Please send me feedback if something is not functioning for you.
Also, I did the best I could with translations. I welcome others to help out with improvements.

I hope these changes get SuperStar back in working order for those of you that enjoy the addon. If this update is successful and the interest is there, I will consider working on the addon further.

Thank you,

-Sigo
v4.2.0
=======
- Updated for Elsweyr (Patch 22 - 5.0.5 / #100027)
- Added support for the new Necromancer class
- Updated the ability Ids for racial passives (should now show the correct skill)
- Updated API version
- Added screenshots for Necromancer class

v4.1.4
=======
- Added a fix for the in-game SKILLS_DATA_MANAGER error for crafting skill lines
- Updated API version for Wrathstone

v4.1.3
=======
- Fixed hashes not building properly for class and racial skills
- Corrected tooltips showing the wrong class and racial skills when loading saved builds
- Added the ability to view builds that require more skill points than the character has
- Minor internal updates to skill points and UI controls
- Corrected some default race names (Looking at you, Hight-Elf!)
- Updated API version for Murkmire

v4.1.2a
=======
- Corrected tooltips for skill morphs.
- Corrected auto-granted skills counting incorrectly.

v4.1.1a
=======
- Corrected a tooltip issue for class and racial skills different from the player.

Please let me know if the issue persists. Thank you for all the feedback, and my apologies for the rocky start.

Known Issue: The tooltips for classes/races different from the player will show red text due to the player not meeting the proper rank to unlock the skill. I will try to address this in a future patch.

v4.1.1
=======
- German clients should be working now (if problems persist, please send feedback)
- Auto-granted skills should now display their names when loading a favorite

v4.1
=======
- Updated handling of skills to start using new ZO system (more to be done)
- Added new guild skill line "Psijic Order".
- Added new tradeskill skill line "Jewelry Crafting".
- Bumped skill revision due to addition of new skill lines, and previous lines switching places.
- Added support to update previous skill profiles (not 100% successful yet)
Archived Files (6)
File Name
Version
Size
Uploader
Date
4.1.4
84kB
Sigo Dest
03/11/19 04:55 PM
4.1.3
324kB
Sigo Dest
02/09/19 10:02 PM
4.1.2a
83kB
Sigo Dest
10/09/18 08:05 PM
4.1.1a
83kB
Sigo Dest
09/02/18 04:52 PM
4.1.1
82kB
Sigo Dest
09/02/18 11:23 AM
4.1
82kB
09/02/18 07:05 AM


Post A Reply Comment Options
Unread 08/15/19, 12:25 PM  
TootY

Forum posts: 0
File comments: 25
Uploads: 0
Originally Posted by Sigo Dest
Originally Posted by TootY
Hi,

Any chance you could help me with the following error when logging in?

user:/AddOns/SuperStar/SuperStar.lua:103: Cannot find a library instance of "LibSkillsFactory".
stack traceback:
user:/AddOns/CombatMetrics/libs/LibStub/LibStub/LibStub.lua:29: in function 'LibStub:GetLibrary'
user:/AddOns/SuperStar/SuperStar.lua:103: in function '(main chunk)'

Thank you- I'm also using the 'SuperStar - Summers Update' version 4.2.0
Hi @TooTy,
Please try reinstalling the addon, and let me know if the problem persists. It sounds like some of the files are missing, and line 103 does not match up with where LibSkillsFactory is called in the current version.

-sigo
Wow, I did that yesterday and it didn't work, today it did ha- sorry for wasting your time
Report comment to moderator  
Reply With Quote
Unread 08/15/19, 08:29 AM  
Sigo Dest
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 22
Uploads: 1
Originally Posted by TootY
Hi,

Any chance you could help me with the following error when logging in?

user:/AddOns/SuperStar/SuperStar.lua:103: Cannot find a library instance of "LibSkillsFactory".
stack traceback:
user:/AddOns/CombatMetrics/libs/LibStub/LibStub/LibStub.lua:29: in function 'LibStub:GetLibrary'
user:/AddOns/SuperStar/SuperStar.lua:103: in function '(main chunk)'

Thank you- I'm also using the 'SuperStar - Summers Update' version 4.2.0
Hi @TooTy,
Please try reinstalling the addon, and let me know if the problem persists. It sounds like some of the files are missing, and line 103 does not match up with where LibSkillsFactory is called in the current version.

-sigo
Report comment to moderator  
Reply With Quote
Unread 08/14/19, 01:24 PM  
TootY

Forum posts: 0
File comments: 25
Uploads: 0
Hi,

Any chance you could help me with the following error when logging in?

user:/AddOns/SuperStar/SuperStar.lua:103: Cannot find a library instance of "LibSkillsFactory".
stack traceback:
user:/AddOns/CombatMetrics/libs/LibStub/LibStub/LibStub.lua:29: in function 'LibStub:GetLibrary'
user:/AddOns/SuperStar/SuperStar.lua:103: in function '(main chunk)'

Thank you- I'm also using the 'SuperStar - Summers Update' version 4.2.0
Report comment to moderator  
Reply With Quote
Unread 07/23/19, 08:40 PM  
radarcg

Forum posts: 1
File comments: 3
Uploads: 0
Re: Re: Startup error for necro

Originally Posted by Sigo Dest
Originally Posted by radarcg
I get this error every time I start the game with my necromancer (doesn't happen with my sorc)
Hi radarcg,
I logged in on my necro and did not have any issues (on en,de,fr). Can you please verify you have version 4.2.0 installed?

If you do have the latest version and are still receiving the error, please let me know and include what client you're using.

-sigo
Well that's embarrassing. Yes, I was not on the correct version. All is well. Thanks for the awesome addon.
Report comment to moderator  
Reply With Quote
Unread 07/20/19, 11:30 PM  
Sigo Dest
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 22
Uploads: 1
Re: Startup error for necro

Originally Posted by radarcg
I get this error every time I start the game with my necromancer (doesn't happen with my sorc)
Hi radarcg,
I logged in on my necro and did not have any issues (on en,de,fr). Can you please verify you have version 4.2.0 installed?

If you do have the latest version and are still receiving the error, please let me know and include what client you're using.

-sigo
Report comment to moderator  
Reply With Quote
Unread 07/20/19, 01:32 PM  
radarcg

Forum posts: 1
File comments: 3
Uploads: 0
Startup error for necro

I get this error every time I start the game with my necromancer (doesn't happen with my sorc)

https://pasteboard.co/IoTx4G8.png
Last edited by radarcg : 07/20/19 at 01:36 PM.
Report comment to moderator  
Reply With Quote
Unread 07/02/19, 07:23 PM  
Sigo Dest
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 22
Uploads: 1
Originally Posted by iMilazzo
Hi!

I'm looking for an addon to use with https://en.uesp.net/wiki/Special:EsoBuildEditor to import/export builds.

This addon looks promissing.

Can I ask to try to integrate your addion with their site?

Thanks
Ivan
Hi iMilazzo! I'm not sure if you're asking me to do something, or if you're asking if it is okay for you to do something?

-sigo
Report comment to moderator  
Reply With Quote
Unread 07/02/19, 11:05 AM  
iMilazzo

Forum posts: 0
File comments: 1
Uploads: 0
Hi!

I'm looking for an addon to use with https://en.uesp.net/wiki/Special:EsoBuildEditor to import/export builds.

This addon looks promissing.

Can I ask to try to integrate your addion with their site?

Thanks
Ivan
Report comment to moderator  
Reply With Quote
Unread 06/16/19, 01:39 AM  
Sigo Dest
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 22
Uploads: 1
Originally Posted by izgoose
https://imgur.com/a/Nq0MNAO

So. This pops up every time I log in, and the add-on is 100% non-functional.

I imagine my mod collection will be needed if this isn't a known and solved issue, so just in case anyone needs it and I forget to check back later, here it is.

https://imgur.com/a/YgRQJzm

send help x.x
@izgoose
Hi, sorry for the delay... I've tested it and everything works from my end.

It sounds like a library dependency was deleted from your SuperStar folder. You'll have to reinstall the addon to get it back (if you can't find where it went).

If you'd like to verify yourself that it is missing, look in your SuperStar folder for a sub-folder named "lib", and inside "lib", should be "LibMainMenu", with one file, "LibMainMenu.lua" sizing in at about 17k. If it isn't there, check the root AddOns folder.

Also... your screenshot shows SuperStar as out of date, which should not be the case. Please verify you installed version 4.2.0.

-sigo
Last edited by Sigo Dest : 06/16/19 at 01:42 AM.
Report comment to moderator  
Reply With Quote
Unread 06/13/19, 10:11 PM  
izgoose

Forum posts: 0
File comments: 1
Uploads: 0
https://imgur.com/a/Nq0MNAO

So. This pops up every time I log in, and the add-on is 100% non-functional.

I imagine my mod collection will be needed if this isn't a known and solved issue, so just in case anyone needs it and I forget to check back later, here it is.

https://imgur.com/a/YgRQJzm

send help x.x
Last edited by izgoose : 06/13/19 at 10:12 PM.
Report comment to moderator  
Reply With Quote
Unread 05/23/19, 04:13 PM  
Sigo Dest
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 22
Uploads: 1
Patch release for Elsweyr

Hi all,
I've just released an update to add support for the Necromancer class, and update some of the racial abilities to show their proper skill/tooltip.

I tested it as well as I could, but please let me know if anything breaks as a result.

New version should be 4.2.0. I left it as "SuperStar - Summerset Update" for now.

Thank you!
-Sigo
Last edited by Sigo Dest : 05/23/19 at 04:14 PM.
Report comment to moderator  
Reply With Quote
Unread 05/23/19, 03:14 PM  
PhnxZ

Forum posts: 4
File comments: 63
Uploads: 0
Originally Posted by Sigo Dest
Originally Posted by Marazota
elsweyr error

Hi Marazota, where are you receiving this error? At login?
I have not purchased Elsweyr yet. I'll try to pick it up tomorrow and start working on adding the new class.

-- Edited because I realized you mentioned Elsweyr.
I get this error too, when I log in with a necromancer
Last edited by PhnxZ : 05/23/19 at 03:15 PM.
Report comment to moderator  
Reply With Quote
Unread 05/21/19, 08:49 PM  
Sigo Dest
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 22
Uploads: 1
Originally Posted by Marazota
elsweyr error

Hi Marazota, where are you receiving this error? At login?
I have not purchased Elsweyr yet. I'll try to pick it up tomorrow and start working on adding the new class.

-- Edited because I realized you mentioned Elsweyr.
Last edited by Sigo Dest : 05/21/19 at 08:52 PM.
Report comment to moderator  
Reply With Quote
Unread 05/20/19, 03:31 PM  
Marazota

Forum posts: 136
File comments: 1103
Uploads: 0
elsweyr error
Report comment to moderator  
Reply With Quote
Unread 03/16/19, 04:20 PM  
SammiSakura
 
SammiSakura's Avatar

Forum posts: 0
File comments: 36
Uploads: 0
Originally Posted by Sigo Dest
Originally Posted by SammiSakura
Yes its still happening, it occurs on all of my characters, regardless of race or class. im playing on pc/eu

this is the error im currently getting
Code:
user:/AddOns/SuperStar/SuperStar.lua:707: number expected for loop variables
stack traceback:
user:/AddOns/SuperStar/SuperStar.lua:707: in function 'SuperStarSkills:InitInternalFactoryForBuilder'
|caaaaaa<Locals> self = tbl, skillType = 1, skillLineIndex = 4 </Locals>|r
user:/AddOns/SuperStar/SuperStar.lua:198: in function 'SuperStarSkills:New'
|caaaaaa<Locals> self = tbl, container = ud, manager = tbl </Locals>|r
user:/AddOns/SuperStar/SuperStar.lua:1547: in function 'InitSkills'
|caaaaaa<Locals> control = ud </Locals>|r
user:/AddOns/SuperStar/SuperStar.lua:4805: in function 'OnAddonLoaded'
|caaaaaa<Locals> _ = 65536, addonName = "SuperStar" </Locals>|r
@SammiSakura Sorry Sammi, but I am unable to reproduce this at the moment. I saw another person post it on the main SuperStar forums, but the line numbers in both of your errors seem off from where they should be. The only suggestion I have for now is please try re-installing the SuperStar - Summerset 4.1.4 patch.

I'll keep trying to reproduce it. Are you on an English ("en") client, or is it "fr", "de", "jp"?

Sorry I can't get it working sooner for you!

-sigo
Yeah im using the English client. Its no worries, no rush Apparently reinstalling it seems to have stopped the error for now, but I will let you know if anything changes
__________________
@SammiSakura - EU Server - CP 810+ - Here Since 14th October 2016
Visit my home at the Alinor Townhouse


GM of Demonic Baanditos (Social Guild)
GM of The Forbidden Cleavage in Skywatch (Trading & Social Guild)
Officer of Brave Cat Trade in Rawl'kha (Trading & Social Guild)
Officer of Inevitable in Windhelm (Trading Guild)
PM @SammiSakura In-Game for Invites. (EU Only!)

Warning: Spoiler
Last edited by SammiSakura : 03/16/19 at 04:41 PM.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: