Quantcast
Download
(15 Kb)
Download
Updated: 07/19/22 10:35 AM
Patch for:
DressingRoom.
Pictures
File Info
Compatibility:
High Isle (8.0.0)
Updated:07/19/22 10:35 AM
Created:09/12/20 01:01 AM
Monthly downloads:5,118
Total downloads:95,452
Favorites:86
MD5:
8.0.0
Dressing Room Original (2015) - Updated  Popular! (More than 5000 hits)
Version: 0.6.5.d
by: amuridee [More]
This is just update API version and a little adjustments to some of the Lib used only for the original Addons DressingRoom by dividee for future Update. Check the 0.6.2 changelog for more detail.
I use this addons for personal use only! feel free to use it if you want.
If you want to more feature of this Addons, please check this addons below:


Description

DressingRoom allows you to save your action bars and equipped gear items as unique sets. You can then equip any saved set, including gear and both action bars, with the press of one customizable hotkey.

Its interface is similar to AlphaGear's (AlphaTools).

Features
  • You can change the number of sets available in the interface (by adjusting the number of rows and columns), up to 24 sets. The size of the interface is customizable.
  • By default, sets are named after the type of your equipped weapons, but you can rename them to your liking (delete the name to reset it to default)
  • English, french and german localization
  • Up to 12 hotkeys to equip the saved gear and both action bars (manual weapon swap is mandatory to load both skill bars)
  • Inventory markers for gear that is part of a saved set


Limitations

Like any other add-on of this kind, it won't work in combat.

Current Bug

Equip same poison in both bars sometimes makes poison only equipped in the front bar only


Thanks
  • dividee for create this great Addons
  • AlphaLemming for making AlphaTools, on which this add-on is based
  • Nita65 for all her invaluable help with testing, reporting bugs, suggesting features and translation.
  • s0rdrak for kindly reviewing the german translation
0.6.5.d

Updated API for High Isle

0.6.5.c

Updated API for Ascending Tide

0.6.5.b

Updated API for Deadlands

0.6.5.a

Updated API for Waking Flame

0.6.5

Updated API for Blackwood

0.6.4

Updated API for Flames of Ambition

0.6.3

Updated API for Markarth

0.6.2

Updated API for Stonethorn
Remove LibStub Dependencies
Remake LibAddonMenu Dependencies
Archived Files (7)
File Name
Version
Size
Uploader
Date
0.6.5.c
15kB
amuridee
04/06/22 05:23 PM
0.6.5.b
15kB
amuridee
11/16/21 05:04 AM
0.6.5.a
15kB
amuridee
08/23/21 10:47 PM
0.6.5
15kB
amuridee
06/02/21 10:49 AM
0.6.4
15kB
amuridee
03/04/21 06:58 AM
0.6.3
15kB
amuridee
11/02/20 10:18 PM
0.6.2
15kB
amuridee
09/12/20 01:01 AM


Post A Reply Comment Options
Unread 07/21/22, 10:20 AM  
Qcell
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 44
Uploads: 5
I find the duplicity of DressingRoom forks and "UPDATED" disturbing. @Baertram

I'm using WhoCares + ownedbynico and it works perfectly fine both in live and PTS (8.1.1)

Report comment to moderator  
Reply With Quote
Unread 05/21/22, 08:18 AM  
amuridee
 
amuridee's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 50
Uploads: 7
Originally Posted by Baertram
Hello guys,

to unstress the topic about the versions available I'd like you to consider a compromise:

@Messajah
I get your point and you are right from a technical point of view.
But as amuridee and Anceane also answered everyone should be fine to just decide that on their own.
If the addon works and there is no licensing prohitibing the copy just for an technically non-sense ## APIVersion: update, why not.

As long as no addon user is complaining about the bugs they might get -> The dev (amuridee) needs to clarify this then as it was uploaded by this name and the responsibility is clear then.

If users complain because they find this buggy version from 2015 they should be able to install a newer version.

@amuridee
"Dressing Room - Updated" just implies that you have a very new version.
As the users should be able to see at a glance that this version here is old (2015) and might be buggy you should add this to the name of the addon directly.
For example: Dressing Room 0.6.0 - Updated or Dressing Room 2015 - Updated
Minion and esoui will show it directly which makes users re-think using an old but non-outdated version then > At least that's what raises my attention at update/revised/new addon names.

You definately should remove the links to officially non working versions of this addon as Messajah stated already:


I do neither see any sense in releasing an very old addon code just to update the txt file's apiversion but as there are 2 users using it already now, who are happy with it, it kinda made sense (if you had known in advance ).
But please guys rethink releasing old addons for the public, really makes not sense and increases the missunderstandings
AND from a long time author perspective here: It also raises work for other authors who need to find out why their addons break or users report errors that are happening etc.
Addons always need to live next to each other and having very old code definately is a problem, even if it works for you, it might break many other addons.

If you want to fix this APIversion only "do it locallly for yourself". If there are others that ask for your version: share it by cloud drives or maybe release it then, but do not release it provisionally for all just because "there might be any other who could maybe...".
This is troubling in so many cases, I hope you understand and believe me there if I try to explain it


btw: As this is your addon "copy" and you are the owner you should have the auth to delete comments that disturb the flow. If you feel Messajah's message is wrong here, delete it. It's up to you. Just don't overstress this please.
Noted sir.
I already change the title and some of the detail,
If the moderator and owner of ESOUI decide to take down this addons,
please I would happy for it and have no complain at all. Thank you
Report comment to moderator  
Reply With Quote
Unread 05/18/22, 07:57 AM  
Baertram
Super Moderator
 
Baertram's Avatar
ESOUI Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 4165
File comments: 5195
Uploads: 73
Hello guys,

to unstress the topic about the versions available I'd like you to consider a compromise:

@Messajah
I get your point and you are right from a technical point of view.
But as amuridee and Anceane also answered everyone should be fine to just decide that on their own.
If the addon works and there is no licensing prohitibing the copy just for an technically non-sense ## APIVersion: update, why not.

As long as no addon user is complaining about the bugs they might get -> The dev (amuridee) needs to clarify this then as it was uploaded by this name and the responsibility is clear then.

If users complain because they find this buggy version from 2015 they should be able to install a newer version.

@amuridee
"Dressing Room - Updated" just implies that you have a very new version.
As the users should be able to see at a glance that this version here is old (2015) and might be buggy you should add this to the name of the addon directly.
For example: Dressing Room 0.6.0 - Updated or Dressing Room 2015 - Updated
Minion and esoui will show it directly which makes users re-think using an old but non-outdated version then > At least that's what raises my attention at update/revised/new addon names.

You definately should remove the links to officially non working versions of this addon as Messajah stated already:
Speaking of the README file, please delete the extra link to "Dressing Room Reborn". It's an old and buggy fork. The Stonethorn version explicitly warns people to not install "Reborn".
I do neither see any sense in releasing an very old addon code just to update the txt file's apiversion but as there are 2 users using it already now, who are happy with it, it kinda made sense (if you had known in advance ).
But please guys rethink releasing old addons for the public, really makes not sense and increases the missunderstandings
AND from a long time author perspective here: It also raises work for other authors who need to find out why their addons break or users report errors that are happening etc.
Addons always need to live next to each other and having very old code definately is a problem, even if it works for you, it might break many other addons.

If you want to fix this APIversion only "do it locallly for yourself". If there are others that ask for your version: share it by cloud drives or maybe release it then, but do not release it provisionally for all just because "there might be any other who could maybe...".
This is troubling in so many cases, I hope you understand and believe me there if I try to explain it


btw: As this is your addon "copy" and you are the owner you should have the auth to delete comments that disturb the flow. If you feel Messajah's message is wrong here, delete it. It's up to you. Just don't overstress this please.
Last edited by Baertram : 05/18/22 at 10:28 AM.
Report comment to moderator  
Reply With Quote
Unread 05/17/22, 05:06 PM  
amuridee
 
amuridee's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 50
Uploads: 7
This is just update API version only for original Addons DressingRoom by dividee for future Update.
I use this addons for personal use only! feel free to use it if you want.

my man, you must read that line before came to download and use this addons.
If everything still work for me, then I will keep use this addons and make it up to date to current API version.
Originally Posted by Messajah
Sorry to say it but there is no point for this addon existing and it just confuses people...

The code of THIS addon is still from 2015. Almost a decade old.

Everyone who is installing THIS is installing Dressing Room 0.6.0 from July 12th, 2015:

https://www.esoui.com/downloads/info...oom.html#other

All that this "Updated" version does is increase the API version in 1 text file. Just check the changelog. The code actually isn't updated at all:

https://www.esoui.com/downloads/info...html#changelog

Previously, there was a reason to bump the API version. But nowadays the game allows add-ons flagged as "out of date" to still load perfectly as long as the code still works. So there is no reason to keep bumping the API version of this outdated addon. It just confuses people as evidenced by people still installing this old 2015 code in 2022.

Everyone who is installing THIS "Dressing Room Updated" is installing the year 2015 code, which is almost as old as when the game first launched, with just a minor version change in a text file. Seriously. Stop it. It's full of bugs.

If people want a version that has ACTUALLY updated Dressing Room then check the changelog of this other year 2020 fork which has tons of bugfixes and improvements:

https://www.esoui.com/downloads/file...2138#changelog

You might want to at least base this "API version update addon" on the improved 2020 code (which has an absolute ton of bug fixes as you can see above), instead of the broken 2015 code. As a courtesy for all the people who wrongly thought that this was a new/maintained addon.

Alternatively, people can simply uninstall this 2015 "updated" and run the actually updated 2020 version instead, from here:

https://www.esoui.com/downloads/file...p?id=2138#info

And yeah I saw that you linked to it already from the README page, but why even base yours on the ancient decade-old version at all? Base it on the new 2020 version if this is gonna be labeled an "Updated" version. Then this "Updated" title would actually become true.

Speaking of the README file, please delete the extra link to "Dressing Room Reborn". It's an old and buggy fork. The Stonethorn version explicitly warns people to not install "Reborn".

The 2015 version (this one) is very broken. The Reborn (February 2018) version is broken. The only updated version is Stonethorn (October 2020)...

I completely agree with you, don't dictate others to use what you considere a valid version.

I like the original version because it's very simple and doesn't give any errors for me at all, thats why I keep use it and keep it up to date with current API version.
Thank you.
Originally Posted by Anceane
i AM sorry but i totally hate the version with so much options and pages. I want something simple. And the version i use is working fine even on PTS.

So stop to decide for everyone.

You like a version, use the one you like and do not dictate others to use what you considere a valid version.

If the version i use

## Author: |[email protected]|r
## Version: 0.6.6

is giving me no error, why should i take an other version.

My version is up to date, with no error at all even on pts.
Last edited by amuridee : 05/17/22 at 05:17 PM.
Report comment to moderator  
Reply With Quote
Unread 05/09/22, 10:58 PM  
Anceane
 
Anceane's Avatar
AddOn Author - Click to view AddOns

Forum posts: 286
File comments: 1000
Uploads: 1
Stop deciding for everyone

i AM sorry but i totally hate the version with so much options and pages. I want something simple. And the version i use is working fine even on PTS.

So stop to decide for everyone.

You like a version, use the one you like and do not dictate others to use what you considere a valid version.

If the version i use

## Author: |[email protected]|r
## Version: 0.6.6

is giving me no error, why should i take an other version.

My version is up to date, with no error at all even on pts.
__________________
Report comment to moderator  
Reply With Quote
Unread 05/09/22, 10:01 PM  
Messajah
AddOn Author - Click to view AddOns

Forum posts: 11
File comments: 29
Uploads: 1
Sorry to say it but there is no point for this addon existing and it just confuses people...

The code of THIS addon is still from 2015. Almost a decade old.

Everyone who is installing THIS is installing Dressing Room 0.6.0 from July 12th, 2015:

https://www.esoui.com/downloads/info...oom.html#other

All that this "Updated" version does is increase the API version in 1 text file. Just check the changelog. The code actually isn't updated at all:

https://www.esoui.com/downloads/info...html#changelog

Previously, there was a reason to bump the API version. But nowadays the game allows add-ons flagged as "out of date" to still load perfectly as long as the code still works. So there is no reason to keep bumping the API version of this outdated addon. It just confuses people as evidenced by people still installing this old 2015 code in 2022.

Everyone who is installing THIS "Dressing Room Updated" is installing the year 2015 code, which is almost as old as when the game first launched, with just a minor version change in a text file. Seriously. Stop it. It's full of bugs.

If people want a version that has ACTUALLY updated Dressing Room then check the changelog of this other year 2020 fork which has tons of bugfixes and improvements:

https://www.esoui.com/downloads/file...2138#changelog

You might want to at least base this "API version update addon" on the improved 2020 code (which has an absolute ton of bug fixes as you can see above), instead of the broken 2015 code. As a courtesy for all the people who wrongly thought that this was a new/maintained addon.

Alternatively, people can simply uninstall this 2015 "updated" and run the actually updated 2020 version instead, from here:

https://www.esoui.com/downloads/file...p?id=2138#info

And yeah I saw that you linked to it already from the README page, but why even base yours on the ancient decade-old version at all? Base it on the new 2020 version if this is gonna be labeled an "Updated" version. Then this "Updated" title would actually become true.

Speaking of the README file, please delete the extra link to "Dressing Room Reborn". It's an old and buggy fork. The Stonethorn version explicitly warns people to not install "Reborn".

The 2015 version (this one) is very broken. The Reborn (February 2018) version is broken. The only updated version is Stonethorn (October 2020)...

Last edited by Messajah : 05/09/22 at 10:30 PM.
Report comment to moderator  
Reply With Quote
Unread 01/14/22, 11:47 AM  
Baertram
Super Moderator
 
Baertram's Avatar
ESOUI Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 4165
File comments: 5195
Uploads: 73
Remove SetTracker's libraries from the subfolder "libs" of the addon and install the libraries standalone to live/AddOns!

This does not only apply to SetTracker but ALL addons:
Libraries in subfolders tend to create errors as they will be "always loaded" via the txt file of the addon (here: SetTracker.txt) even though their code might be several years old, so remove the libs in subfolders.

btw: SetTracker got other bugs and is not maintained any longer so maybe remove it from your addons, or check the addon comments for updated versions where the libraries are removed and fixed already.

Originally Posted by amuridee
Originally Posted by everlasting
user:/AddOns/SetTracker/libs/LibAddonMenu-2.0/LibAddonMenu-2.0.lua:147: attempt to index a nil value
stack traceback:
user:/AddOns/SetTracker/libs/LibAddonMenu-2.0/LibAddonMenu-2.0.lua:147: in function 'RefreshReloadUIButton'
user:/AddOns/SetTracker/libs/LibAddonMenu-2.0/LibAddonMenu-2.0.lua:157: in function 'RequestRefreshIfNeeded'
|caaaaaa<Locals> control = ud, panel = ud, panelData = [table:1]{name = "Dressing Room", version = "0.6.5.a", slashCommand = "/dressingroom", author = "@amuridee, dividee", type = "panel"} </Locals>|r
user:/AddOns/SetTracker/libs/LibAddonMenu-2.0/controls/checkbox.lua:65: in function 'UpdateValue'
|caaaaaa<Locals> control = ud, forceDefault = F, value = T </Locals>|r
user:/AddOns/SetTracker/libs/LibAddonMenu-2.0/controls/checkbox.lua:111: in function '(anonymous)'
|caaaaaa<Locals> control = ud </Locals>|r


Keep getting this message.
try to reinstall LibAddonMenu may help
Last edited by Baertram : 01/14/22 at 11:48 AM.
Report comment to moderator  
Reply With Quote
Unread 12/09/21, 04:44 AM  
nanoTechnicianHQ
 
nanoTechnicianHQ's Avatar

Forum posts: 3
File comments: 5
Uploads: 0
Post Use on NA & EU

Hi,
This one was wondering if there was a way of defining EU and NA characters.
Report comment to moderator  
Reply With Quote
Unread 11/16/21, 09:51 AM  
john_trinca

Forum posts: 0
File comments: 2
Uploads: 0
Since today's update i lost all my setups and can't change pages anymore, in addition when i open the builds page i gets this error
Code:
user:/AddOns/DRCPA/DRCPA.lua:157: attempt to index a nil value
stack traceback:
user:/AddOns/DRCPA/DRCPA.lua:157: in function 'DRCPA.HookDressingRoom'
<Locals> oldLoadSet = user:/AddOns/DressingRoom/DressingRoom.lua:334, oldResizeWindow = user:/AddOns/DressingRoom/DressingRoomUI.lua:219, setId = 1 </Locals>
user:/AddOns/DRCPA/DRCPA.lua:243: in function 'func'
/EsoUI/Libraries/Globals/globalapi.lua:227: in function '(anonymous)'
Report comment to moderator  
Reply With Quote
Unread 11/05/21, 09:46 PM  
LiteEmUp

Forum posts: 0
File comments: 1
Uploads: 0
has anyone's saved setup got removed and reset to default settings(no saved gears/skills + back to default no. of sets)????



i have several characters with at least more than 1 saved sets/skills per character, and when i loaded the game today, everything is back to default and no saved sets/skills at all....



this is abit annoying, coz now i have to remember what setup i did per character with 13 characters lol...



now i dont know if this has something to do with the cp bug and forced reset by zos, or its just coincidental timing lol...
Last edited by LiteEmUp : 11/05/21 at 09:49 PM.
Report comment to moderator  
Reply With Quote
Unread 10/28/21, 06:35 AM  
amuridee
 
amuridee's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 50
Uploads: 7
Originally Posted by everlasting
user:/AddOns/SetTracker/libs/LibAddonMenu-2.0/LibAddonMenu-2.0.lua:147: attempt to index a nil value
stack traceback:
user:/AddOns/SetTracker/libs/LibAddonMenu-2.0/LibAddonMenu-2.0.lua:147: in function 'RefreshReloadUIButton'
user:/AddOns/SetTracker/libs/LibAddonMenu-2.0/LibAddonMenu-2.0.lua:157: in function 'RequestRefreshIfNeeded'
|caaaaaa<Locals> control = ud, panel = ud, panelData = [table:1]{name = "Dressing Room", version = "0.6.5.a", slashCommand = "/dressingroom", author = "@amuridee, dividee", type = "panel"} </Locals>|r
user:/AddOns/SetTracker/libs/LibAddonMenu-2.0/controls/checkbox.lua:65: in function 'UpdateValue'
|caaaaaa<Locals> control = ud, forceDefault = F, value = T </Locals>|r
user:/AddOns/SetTracker/libs/LibAddonMenu-2.0/controls/checkbox.lua:111: in function '(anonymous)'
|caaaaaa<Locals> control = ud </Locals>|r


Keep getting this message.
try to reinstall LibAddonMenu may help
Report comment to moderator  
Reply With Quote
Unread 10/20/21, 01:15 AM  
everlasting

Forum posts: 0
File comments: 4
Uploads: 0
user:/AddOns/SetTracker/libs/LibAddonMenu-2.0/LibAddonMenu-2.0.lua:147: attempt to index a nil value
stack traceback:
user:/AddOns/SetTracker/libs/LibAddonMenu-2.0/LibAddonMenu-2.0.lua:147: in function 'RefreshReloadUIButton'
user:/AddOns/SetTracker/libs/LibAddonMenu-2.0/LibAddonMenu-2.0.lua:157: in function 'RequestRefreshIfNeeded'
|caaaaaa<Locals> control = ud, panel = ud, panelData = [table:1]{name = "Dressing Room", version = "0.6.5.a", slashCommand = "/dressingroom", author = "@amuridee, dividee", type = "panel"} </Locals>|r
user:/AddOns/SetTracker/libs/LibAddonMenu-2.0/controls/checkbox.lua:65: in function 'UpdateValue'
|caaaaaa<Locals> control = ud, forceDefault = F, value = T </Locals>|r
user:/AddOns/SetTracker/libs/LibAddonMenu-2.0/controls/checkbox.lua:111: in function '(anonymous)'
|caaaaaa<Locals> control = ud </Locals>|r


Keep getting this message.
Report comment to moderator  
Reply With Quote
Unread 10/20/21, 01:13 AM  
everlasting

Forum posts: 0
File comments: 4
Uploads: 0
Re: error-popup

Originally Posted by Jupp
I have a error popup everytime after login a char with following message:

157 attempt to index a nil value stack traceback
... in function DRCPA.HookDressingRoom
... in function func
... in function (anonymus)
I too keep getting this error with all variations of dressing room.
Report comment to moderator  
Reply With Quote
Unread 08/26/21, 12:40 AM  
Jupp

Forum posts: 0
File comments: 16
Uploads: 0
error-popup

I have a error popup everytime after login a char with following message:

157 attempt to index a nil value stack traceback
... in function DRCPA.HookDressingRoom
... in function func
... in function (anonymus)
Report comment to moderator  
Reply With Quote
Unread 07/13/21, 09:23 PM  
Maelstroa
 
Maelstroa's Avatar

Forum posts: 0
File comments: 5
Uploads: 0
Missing keybind

So, I found after the maintenance update that the keybind for 'remove all equipment' is no longer available..

I really hope this feature is not removed and this is just some sort of bug.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.