ESOUI

ESOUI (https://www.esoui.com/forums/index.php)
-   AddOn Help/Support (https://www.esoui.com/forums/forumdisplay.php?f=164)
-   -   awesome guild store (https://www.esoui.com/forums/showthread.php?t=8611)

halfrunt 06/20/19 01:18 PM

awesome guild store
 
ok I have disabled all my adds except those required for awesome guild store and I still get a error message that reads like this .
user:Addons/Awsome/guild/store/Backend/Activity/ActivityBase/.lua:72 table index is nil '(MAINCHUNK) user:/addons/awesome/guild/store/backend/activity/activitybase.lua:72 table is nil stack traceback user: <locals>AGS=tbl,promise=tbl,ActivityBase=tbl,RESPONSE_TYPE_BY_ACTIVITY_TYPE=tbl,STATE_TO_STRING=tbl,FINISHED_STATE=tbl<locals>

sirinsidiator 06/20/19 02:15 PM

this means you haven't updated your addons in a very long time...

halfrunt 06/20/19 07:35 PM

Awsome Guild Store
 
I haven't played for 6 months when I came back when elswry expansion had started ...its why I came back...zos had the adds jacked so I could get nothing to work I have shut down ags completely and reloaded along w all the libs I do this through minion shouldn't it update it there ? I have it set for auto update!

halfrunt 06/20/19 07:38 PM

awesome guild store
 
and no it does not work!lol

Wheels 06/20/19 08:50 PM

This version of minion does not auto download necessary libs, you must do so yourself for the time being.

halfrunt 06/20/19 09:16 PM

awesome guild store
 
unloaded and downloaded all the proper libs for it downloaded the new 3.0 minion and did it again , manually updated all adds I get the gas screen when I open guild store but is non functional ! still have same error messages only without the shaded area last section that starts with <local>AGS= is it possible I just need to let it sit and update ingame the ags screen has a little downloading spinner near the bottom ?

Baertram 06/20/19 09:45 PM

AGS cannot be updated ingame, you need to do this outside of the game. Addons or other files cannot be downloaded/uploaded from the ESO game.
The spinner at the guild store got nothing to do with downloads of addons. It's just a feature of AGS showing you the information about the current guild data fetched from the servers.


!!!Logout!!!
Or you might get in trouble with addon and/or library updates.

Then use Minion and delete AGS completely + SavedVariables or delete it manually.
Reinstall it then via Minion or manually.

Check here if you got the correct Addons folder so you do not update addons with Minion in the wrong folder and ingame nothing changes:
https://www.esoui.com/forums/faq.php..._howto_install
-> Best hint to find the AddOns directory: Search for the file "AddOnSettings.txt" on your harddrive. It should be in the folder where your AddOns folder is located too.
-> Be sure to check if OneDrive is enabled and if your documents folder is in there. If so remove the elder scrolls online folder from it again so it will be in the old documents folder again. ESO does not like the OneDrive folder.


Then login, enable AGS and the needed libraries. I reommand to use "Votans Addon List" as well as it will automatically enable the dependencies for you (like libraries) if you enable an addon.

halfrunt 06/22/19 01:24 PM

awesome guild store
 
did I mention I'm not very tech oriented it just became a pain and to much trouble if it's gonna be that much a pain in the ass ill just do without lol not worth the hassle I want to play the game not spend all my time screwing with the idiot adds lol I'm not dumb I'm a engineer … not with PC,s lol with a slide rule !!!!!!! been doing it that way for 50 years so thanks for your time sorry I took so much but I'm done w awesome guild store lol my MM works fine so I'm good
toodles :)

Rhyono 06/22/19 01:42 PM

The only problem with your response was "idiot adds"; you're implying because you're not dumb but don't understand it that there is something wrong with it or that it is dumb. I don't know exactly what kind of engineer you are, but maybe you've never interacted directly with a client. If you had, you would be well aware of what it looks like when someone who doesn't understand something is criticizing someone who is extremely capable.

How to use AGS:
Be logged out.
Add it.
Add the libraries it requires.
Login.

If it doesn't work, it means one of two things: you messed up or one of the most popular addons is broken and everyone else is just lucky that it's working for them.

Verbalinkontinenz 06/22/19 02:30 PM

Tbh i dont get the aggressiveness against the addon now. people trying to help you and giving you tips how to solve your problem.

Anceane 06/22/19 03:03 PM

Actually i think i know what could have happened

You have to know first what you do with Minion so it does not overwrite the things you manually updated.

I know it because before i stopped using Minion, if i forget about that, it happened that sometimes the addons i downloaded for the last version, would be replaced by an older version.

Not always but it happened

So i dont know if he was using minion, but if he downloaded the addon first with Minion, then downloaded manually the libs, then went back to Minion, i fear that Minion did some behavior,


This does not excuse his ways though.

Scootworks 06/22/19 03:08 PM

oh the best fix ist to uninstall all your addons. this might be the best solution. should i write you a quick guide how to do that?

Baertram 06/22/19 06:15 PM

In my last post my first sentence was about using more punctuation marks please, so we are able to read your wall of text. I had removed it as I thought it might sound to offensive. Better should have left this in.
Btw glad we could help:rolleyes:


All times are GMT -6. The time now is 10:41 PM.

vBulletin © 2020, Jelsoft Enterprises Ltd
© 2014 - 2019 MMOUI