-   Minion (
-   -   Minion won't restore from backup. (

iWoodsman 03/31/17 10:21 AM

Minion won't restore from backup.
1 Attachment(s)
I did a backup of my 8 ESO Tamriel addons, which gave no error, and that backup appears in the list of both backups, and as a file to restore. I select that restore file and it turns red. But when I click restore, nothing happens. Well, the button turns grey until my mouse moves off of it, but no response is given.
This is Minion 3.0.5 on Win 10, ESO is latest version form Zenimax.
Restarting Minion as Administrator doesn't help.




<?xml version="1.0" encoding="UTF-8"?>








<position y="325.3333435058594" x="638.0" width="1364.0" height="726.0"/>








-<game-configs never-ask-about-scanning="true">

<game-config scannable="false" game-id="WOW"/>

<game-config scannable="true" game-id="ESO"/>


<drive-configs never-ask-about-scanning="true"/>


-<game game-id="ESO" unique-game-id="ESO-1" last-auto-update="March 31, 2017 11:58AM" display-name="Elder Scrolls Online" auto-update="true" addon-path="QzpcVXNlcnNcS2lkc1xEb2N1bWVudHNcRWxkZXIgU2Nyb2xscyBPbmxpbmVcbGl2ZVxBZGRPbnM=">


<addon title="SkyShards" version="5.1" date="02.12.2017 3:39PM"/>

<addon title="Lost Treasure" version="4.25" date="03.02.2017 7:22PM"/>

<addon title="Shissu's LUA Memory" version="" date="03.03.2017 3:43PM"/>

<addon title="Shissu's LUA Memory" version="" date="03.12.2017 3:08PM"/>

<addon title="Shissu's LUA Memory" version="" date="03.22.2017 9:42PM"/>

<addon title="Lui Extended" version="5.03" date="03.31.2017 11:58AM"/>

<addon title="Crafting Preview (Armor)" version="1.4" date="03.31.2017 11:58AM"/>


<addons> </addons>


<last-data-refresh>March 31, 2017 12:20PM</last-data-refresh>




iWoodsman 03/31/17 10:44 AM

Partial but lame workaround found
The log contained the error:
ERROR 2017-03-31 12:31:37,770 [JavaFX Application Thread] gg.minion.controller.BackupPane:clearAndRestoreAddOns(133): Catching C:\Users\Kids\.minion\ESO-1\test-addons.txt (The system cannot find the path specified)

That is not the path that Minion configured for the backup file, but manually moving the ESO-1 directory up a level out of the subdirectory "minion-backups" up a level right into the .minion directory instantly replaced most of my addons.

For some reason, one of the add-ons has not been returned. And a few others are not actually recognized by the game. And my settings seem to be gone.

I see no other discussion of this issue, which is surprising to me: there's nothing nonstandard about my game and minion installations.

Baertram 03/31/17 11:05 AM

I think the backup is working like this, or it WAS:
Normally the backup will only backup the SavedVariables and the addon names that you had installed as you did the backup.
It will store the data into a ZIP archive at C:\Users\windows username\.minion\minion-backups.

If you restore it Minion restores the SavedVariables and puts the addons back into Minion "Installed addons" so you're able to update them via Minion.

Backup isn't working for me anymore! If I try to backup I specfiy the filename and press backup and nothing happens at all.
I'm using the live and pts servers and both are not working for the backup.

Dolby 03/31/17 11:53 AM

Thanks for the heads up, I'll take a look at this and test it out myself later tonight.

Dolby 03/31/17 01:20 PM


Originally Posted by Baertram (Post 30398)
Backup isn't working for me anymore! If I try to backup I specfiy the filename and press backup and nothing happens at all.
I'm using the live and pts servers and both are not working for the backup.

The backup portion is working just fine for me...

Go into your minion-backup folder, delete everything in there. Now open Minion and do a backup. You should see sub-folders made that corrospond with the GAME ID we use in the minion.xml. So if you backup your fist ever detected ESO game it would in in subfolder ESO-1.

Once you're inside that folder you'll find a text file with the name of the backup you use and inside it is a list of addon id's that were installed at the time of the backup. You'll also see a zipfile named the same name you used when you created the backup and that zip contains the savedvariables and a few other game settings.

Now restoring the backup I do see the bug. Currently seeing if theres a way I can fix this from our api (via a config change) or a patch is needed.

Baertram 03/31/17 02:06 PM

Hey Dolby thanks for the info.
But the backup is not working for me at all.

Deleted all files in the folders initial-backup and minion-backups.
Started minion, selected ESO live, changed to backup, chose name 2017-03-31_live and pressed the backup button.
Nothing happens, no new entry in the restore list, no folder or zip or txt in the 2 folders.

Same for the 2nd game in my minion, ESO pts.

Got the error, it was sitting in front of the monitor :-)
Didn't start minion with admin rights ...

Tcheu 04/11/17 09:21 AM

3 Attachment(s)

I'm unearthing this topic because I'm having the "same" issue (Minion won't restore my backup). The parameters of my problem are a bit specific I'm afraid.

I recently changed my computer. I used to run on Windows 7 Pro 64bits, and my new system is on Windows 10 Family 64bits. I saved my minion backups to be able to reinstall them on the new system but it won't work. I'm having the same result as iWoodsman: nothing happens. Well, not exactly nothing. Nothing happens in Minion BUT it creates a new user profile under C:\Users (the name corresponds to the user name I had on my previous system).
I managed to understand that it comes from the architecture of the .zip backup file. I tried tempering with the archive but even though I managed to have it copy its contents into the right folder instead of creating a new one, nothing happens still. I just end up with a bunch of .lua files in my AddOns folder, which does not do anything. Sometimes, one addon (Skyshards) does appear in the Minion installed addons list but not always, and it disappears from the list if I attempt a new restore, even if it's from the same file.

I a running Minion as admin. I tried to run it in Win7 compatibility mode but that doesn't seem to do anything. Here are the minion .log & .xml files, as well as the backup archive if that helps.

Thank you :)

All times are GMT -6. The time now is 05:09 PM.

vBulletin © 2018, Jelsoft Enterprises Ltd
© 2014 - 2017 MMOUI