ESOUI

ESOUI (https://www.esoui.com/forums/index.php)
-   Minion (https://www.esoui.com/forums/forumdisplay.php?f=183)
-   -   [BUG] Minion wont download anything (https://www.esoui.com/forums/showthread.php?t=871)

nerdgrind 04/14/14 01:52 AM

[BUG] Minion wont download anything
 
When i first installed minion, I was able to look through all of the available add-ons, but after i clicked on the "Download" button for the add-on it would eternally show a downloading bar and never actually download anything. I have since gone and manually downloaded the addons from the esoui website. But now (a couple of days later) i have opened up minion to see if it was working. Upon minion starting up, i was notified that minion, itself, has an update available. when i click on the "Update Now!" button, it also shows an updating bar that never moves or does anything. (i have also tried downloading/updating addons and it still has this problem) I have tried uninstalling minion and reinstalling, but that didnt solve anything.

Dolby 04/14/14 09:57 AM

It sounds like a firewall or scanner is preventing Minion from downloading anything.

nerdgrind 04/14/14 06:42 PM

My computer uses Norton Internet Securities to manage the Firewall. After reading your reply, i have tried changing the Norton firewall settings to forcefully allow minion through. Ive tried turning off my norton firewall. And lastly ive tried adding minion to my computers firewall allow list (just incase it was somehow being blocked still by windows and not norton) and nothing has worked.

Dolby 04/14/14 06:56 PM

You should have a minion.xml and minion0.log file located in a folder called .minion under your windows user folder
C:\Users\<your windows username>\.minion\

Can you post those files here? That may help me find the issue.

Thanks

nerdgrind 04/14/14 07:05 PM

1 Attachment(s)
Below are the XML file and the Minion0.txt file. Im not sure how to include the Minion0.log file through this thread.
XML

<minion>
<config-version>2</config-version>
<version>2.0.0-SNAPSHOT</version>
<build>ecf4a24aa5f225e936d434f4917fae0492b072fd</build>
<client>
<concurrent-updates>2</concurrent-updates>
<game-scan-depth>4</game-scan-depth>
</client>
<user>
<ga-user-id>78255c62-5b1b-4033-b30e-0acd5d3f1ffb</ga-user-id>
<access-token>d3697435d5921b0bf719ee97ac1efad523be60e2</access-token>
<refresh-token>66299d2a0a39212895e549e10725e55fdc8efec7</refresh-token>
<login-id>EDITED OUT FOR POSTING</login-id>
</user>
<games>
<game addon-path="QzpcVXNlcnNcSmVmZlxEb2N1bWVudHNcRWxkZXIgU2Nyb2xscyBPbmxpbmVcbGl2ZVxBZGRPbnM=" auto-update="true" game-id="ESO" unique-game-id="ESO-1"/>
</games>
</minion>

Dolby 04/14/14 08:49 PM

Thanks for posting your error log.

Code:

java.net.SocketException: Network is unreachable: connect
It confirms Minion is having trouble connecting to the internet on your machine. It connects to api.mmoui.com over port 443 and cdn.eso.mmoui.com over port 80 for downloads. Is there anything that you can think of that would be blocking that?

Are you using a proxy maybe? Do you have any internet proxy settings entered into your default web browser?

nerdgrind 04/14/14 09:14 PM

nope. im not using a proxy and i have no settings entered into my default web browser (chrome)

Nerror 04/15/14 01:34 AM

Getting the same problem now. It was working fine until Minion did an update this morning. Now I can't download anything. No other change in any settings on the PC.

Edit: tried to uninstall, and noticed I had 3 instance of minion.exe running ever after uninstalling. So something is bugging out. I manually removed everything now and will try a reinstall.

Edit2: After a full reinstall and checking it's only running 1 instance of minion in the process explorer, downloading works again.


All times are GMT -6. The time now is 02:06 PM.

vBulletin © 2019, Jelsoft Enterprises Ltd
© 2014 - 2019 MMOUI