-   Minion (
-   -   New Addon not showing in minion (

Cuhlen 07/27/20 12:29 PM

New Addon not showing in minion
Have a new addon listed on esoui (CraftBagger) but it's not showing up in Minion. The addon zip file is (I believe) correctly structured, and when I check the minion log, this is what I see:

DEBUG 2020-07-01 13:53:56,548 [Thread-33] gg.minion.service.AddOnDetectionService:interrogateDirs(333): interrogating TOC: C:\Users\---\Documents\Elder Scrolls Online\live\AddOns\CraftBagger\CraftBagger.txt
DEBUG 2020-07-01 13:53:56,549 [Thread-33] gg.minion.service.AddOnDetectionService:interrogateDirs(354): CraftBagger - TOC Version: 1.0
DEBUG 2020-07-01 13:53:56,555 [Thread-33] gg.minion.service.AddOnDetectionService:detectAddOn(268): No addons match CraftBagger

So it sees my (manually installed) local copy, but no results show in the minion window. Removing the local copy does not change the result. Searching for other addons that are already installed shows the addons as expected.

Any assistance is appreciated.

Sharlikran 07/27/20 01:24 PM

I don't think this is your issue, I don't know what would cause it really. However...

## APIVersion: <<-- delete this

## AddOnVersion: 103 <<-- add this

## Title: CraftBagger
## Author: Cuhlen (@Tooslow001)
## APIVersion: 100030 100031
## Description: None
## Version: 1.04
## AddOnVersion: 104
## SavedVariables: CraftBaggerData
## OptionalDependsOn: LibPrice

Then upload a new version as 1.04 so that the site can process it.

Cuhlen 07/27/20 02:33 PM

Thanks for having a look, but that hasnt fixed it.

Sharlikran 07/27/20 02:39 PM

The weirdest thing is, like you say, it doesn't show up at all. This obviously isn't meant to make you do things for nothing and testing you uploads like this isn't ideal. I just don't have an explanation.

I am curious though. If you include only the Lua and the .txt file, the manifest, as version 1.05 and make the same change I suggested for both lines (one is for Minion specifically) what does that do?

sirinsidiator 07/27/20 02:54 PM

Minion doesn't show it because you put it in the tools category. That category - among some others - is hidden due to the assumption that it contains things that are not traditional addons and cannot be installed by Minion.

Cuhlen 07/27/20 06:25 PM

Thanks for looking. I tried updating the category under manage addon 'optional categories', but that hasnt fixed it.

Is there an API call that Minion uses to check latest? I would be curious if it was ESOUI not returning the addon, or minion somehow filtering it out maybe because of the ps1 or cmd files.

Baertram 07/27/20 07:02 PM

Optional categories won't change the "main" category. Ask Dolby to change it for you maybe.

Cuhlen 07/28/20 11:27 AM

Thanks everybody! I did have to email Dolby and ask him to move change the primary category, but once he did it started showing up in Minion.

All times are GMT -6. The time now is 10:13 AM.

vBulletin © 2022, Jelsoft Enterprises Ltd
© 2014 - 2021 MMOUI