-   Minion (
-   -   Minion on Linux (

Dolby 04/30/19 07:06 PM

1 Attachment(s)
This is how I was able to install the oracle jdk8 on Pop!_os (since the oracle java ppa is no longer available due to license changes) but should work on most up to date distro's out there.
  • Register for a free Oracle account and download the latest JDK8 tar.gz(jdk-8u211-linux-x64.tar.gz).
  • Download these bash scripts and follow the simple directions to install jdk8 from the tar.gz file you downloaded.
  • Check if java -version shows the correct version:

    [email protected]:~/Downloads/Minion$ java -version
    java version "1.8.0_211"
    Java(TM) SE Runtime Environment (build 1.8.0_211-b12)
    Java HotSpot(TM) 64-Bit Server VM (build 25.211-b12, mixed mode)

  • Download the Minion jar from and extract the zip into location and folder of your choice.
  • Now run java -jar Minion-jfx.jar in the folder you extracted the zip to

    [email protected]:~/Downloads/Minion$ java -jar Minion-jfx.jar
  • Choose to update Minion and restart. (It won't restart)
  • Before you start minion we need to apply the patch manually. Navigate to the folder you are running minion from and you should see a new folder named "null" grab the Minion-jfx.jar from there and copy over the old Minion-jfx.jar in the parent directory.
  • now start minion again java -jar Minion-jfx.jar and it should work like mine...

maxheadroom2000 05/05/19 04:41 PM

Minion Lives!
Finally, a usable set of instructions that work! You are a saint. :banana:

I am using these instructions with the Steam version of ESO on Linux Mint, and it is working perfectly.

For those that are doing the same, and have no idea where to find the AddOns folder, it is buried in a somewhat weird place. Try turning on "Show hidden files" and look for someplace like this:
~/.steam/steam/steamapps/compatdata/306130/pfx/drive_c/users/steamuser/My Documents/Elder Scrolls Online/live/AddOns

See you in Tamriel!

Dolby 05/17/19 07:31 AM

This is a guide by VERNSTOKED to install Minion with Lutris

calvin.scones 05/20/19 07:19 PM

Java Error
I followed the instructions here, but I am getting an error at running java -jar Minion-jfx.jar

X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 151 (GLX)
Minor opcode of failed request: 24 (X_GLXCreateNewContext)
Value in failed request: 0x0
Serial number of failed request: 29
Current serial number in output stream: 30

I verified that java is the right version, and tried 8u212 as well


Simple reboot fixed this

For anyone finding this post later the issue was that Manjaro/arch uses openJDK, and using:
"archlinux-java set <JRE version>"
fixes the issue, but will error out until after a reboot

Feel free to remove this post if you want since this is a sticky.

ettavolt 08/16/19 01:20 PM

You don't need JRE/JDK from Oracle speicifically, OpenJDK has no difference (but freer license).
Though not all distros provide OpenJFX 8. For Ubuntu-based a possible solution is outlined here:

To run on JDK+JFX 11 Minion will need be converted to modules, it seems. At least that the error I got from trying to launch it in this setup.

Instead of changing the default JDK as calvin.scones suggests, one may simply run

/usr/lib/jvm/java-8-openjdk/bin/java -jar Minion-jfx.jar

Techwolf 09/09/19 11:55 AM

Just found this thread. I will add my two cents. :-D

I run minion from the command line. What I ended up doing a year and half ago was installed Oracle version 9.0.4 of java as the open source version did not work graphics wise. It did ran, but the UI was all messed up.

My OS is gentoo and CPU is currently Threadripper.

I installed Oracle java using the guild from the wiki:

I su to the steam user. I use a different user from the main to keep things seperate as games have a bad habit of doing things the users does not want. So running a seperate user is recommended on Linux systems.

Manually download the .jar and place in ".wine_Tamriel/drive_c/users/steam/Local Settings/Application Data/Minion/app/" Note on my sytem, I installed it using the .exe and hence why the full path to the normal install. It was later I found the GUI bugs.

I did not set the system wide java as I wanted the default java to be not oracle, so my command line is:


[email protected] ~ $ /opt/oracle-jre-bin-9.0.4/bin/java -jar ".wine_ESO/drive_c/users/steam/Local Settings/Application Data/Minion/app/Minion-jfx.jar"
Getting minion to find the right place for the addons was tricky and I forgot how I did it. See previous posts for tips on getting minion to find the right place where the addons should be.

I have been running minion like that for over year with only one issue, you must update from the first window, using the update button from sub-windows will not work. Example is clicking on the addon and reading the change log and updateing from there does not work.

Update: Gentoo removed oracle bin version 9.0.4 for security issues. So one may have to manually install version 9.04. Will be testing other versions.

Update 2:
Tested oracle version works
Tested icedtea version 3.13.0: failed with "Error: Could not find or load main class gg.minion.Minion"
Tested openjdk version 11.0.4: failed with "Error: Could not find or load main class gg.minion.Minion
Caused by: java.lang.NoClassDefFoundError: javafx/application/Application"

FIGBird 09/09/19 03:17 PM

The issue I run into with the JAR version is as follows:

java.lang.NoClassDefFoundError: it/sauronsoftware/junique/AlreadyLockedException

I have attempted a few different java versions. I am not entirely sure where the error is, but that looks like a unit testing framework which suggests it is an issue with the JAR file itself. I can post the whole stack if needed.

For reference here is the output from java -version after the bash scripts were used on the originally suggested oracle file.

java version "1.8.0_221"
Java(TM) SE Runtime Environment (build 1.8.0_221-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.221-b11, mixed mode)

Baertram 09/09/19 10:31 PM

Seems the class it.sauronsoftware.junique.AlreadyLockedException is missing in the jar file, or a jar dependency is missing in the classpath entry of the jar's manifest.
Weird it is working for some and not for others.
Maybe they have the same class somewhere else in there environment variables and you could download it somewhere and add it as well to yours, so it's "globally" known for all jar files?

sirinsidiator 09/10/19 05:02 AM

Sounds more like you are either missing the lib folder accompanying the Minion-jfx.jar or it is not found on the classpath for some reason. You could try to specify it manually like so:

java -cp .;lib -jar Minion-jfx.jar

FIGBird 09/10/19 03:29 PM

My face is a little red at the moment. I somehow managed to extract only the JAR file and missed the lib folder. Works like a charm as soon as I have the dependencies...

Tar000un 01/08/20 07:00 AM

I m running Minion from Lutris as I got the java error and didn't want to dig too long.

But I tilted on :

Originally Posted by ettavolt (Post 38893)
To run on JDK+JFX 11 Minion will need be converted to modules, it seems. At least that the error I got from trying to launch it in this setup.

So I tried more longer and I got this "working" :

wget -O /tmp/
unzip /tmp/ -d /tmp/
java --module-path="/tmp/javafx-sdk-11.0.2/lib/" --add-modules=javafx.swing,,javafx.fxml,,javafx.web \
  --add-reads \
  --add-opens javafx.controls/com.sun.javafx.charts=ALL-UNNAMED \
  --add-opens \
  --add-opens \
  --add-opens \
  --add-opens javafx.base/com.sun.javafx.runtime=ALL-UNNAMED \
-jar Minion-jfx.jar

But addons are not listed after I pointed to the addOns dir. :(

Getting a lot of :

DEBUG 2020-01-08 13:56:19,947 [Thread-9] gg.minion.service.AddOnDetectionService:interrogateDirs(354): PotionMaker - TOC Version: 5.7.9
DEBUG 2020-01-08 13:56:19,947 [Thread-9] gg.minion.service.AddOnDetectionService:detectAddOn(268): No addons match PotionMaker

How do you "convert as module" ?

Baertram 01/08/20 08:19 AM

Minion got some settings at the top right UI corner where you can change the addon directory scan depth. Sometimes increasing this helps.

I can not speak for Unix, only for the Windows versions:
-Use 32bit version even on 64bit OS
-Start as admin to give it access to the user directory
-Allow the minion directory and elder scrolls online directory access (whitelist/exclusion list) in Antivirus/Firewalls

Maybe this helps you for Unix as wlel somehow :confused:

You could also try to stop minion, rename/delete the Minion.xml file!
Then go to your AddOns directory. Remove all addons (move them elsewhere).

Start minion, point to the addon dir.
Download a few addons new.
Close Minion.
Move/Copy the other addons into the AddOns directory again but do not overwrite any files.

Start minion again and check if it scans and updates properly now.

Tar000un 01/10/20 02:28 AM

I recently changed the depth, lowering it. But I tried raising with theses values:
- Concurrent downloads: 4
- Game Scan Depth: 3

Still getting the issue. I can't find "more addon" to download and install a new addon.

I would like to highlight an issue in your list.

Originally Posted by Baertram (Post 39987)
-Start as admin to give it access to the user directory

Running a bin as admin (ie root) is very unsafe.

Instead running as admin, you have to set the proper ACL.
Even largely permissive ACL still better than giving root access to an app.

Baertram 01/10/20 08:54 AM

Okay, thanks. As I said the admin info was for a Windows system :p

ettavolt 06/16/20 10:56 PM

Managed to run Minion on OpenJDK 14 with

java --module-path=/usr/lib/jvm/default/lib/javafx.web.jar:/usr/lib/jvm/default/lib/ --add-modules=javafx.swing,,javafx.fxml,,javafx.web \
  --add-reads \
  --add-opens javafx.controls/com.sun.javafx.charts=ALL-UNNAMED \
  --add-opens \
  --add-opens \
  --add-opens \
  --add-opens javafx.base/com.sun.javafx.runtime=ALL-UNNAMED \
-jar Minion-jfx.jar

If you happen to have no /usr/lib/jvm/default/lib/jrt-fs.jar, you might be able to run with just --module-path=/usr/lib/jvm/default/lib/

Lizzi's Bow 01/15/21 07:24 PM

Why doesn't this work?
/usr/java/jre1.8.0_271/bin/java -jar "/home/lizzias/Downloads/Minion3.0.5-java/Minion-jfx.jar"

download java 8 from here:

easy install follow these instructions:

Change to the directory in which you want to install. Type:
cd directory_path_name
For example, to install the software in the /usr/java/ directory, Type:
cd /usr/java/

Move the .tar.gz archive binary to the current directory.
Unpack the tarball and install Java
tar zxvf jre-8u73-linux-x64.tar.gz

The Java files are installed in a directory called jre1.8.0_73 in the current directory. In this example, it is installed in the /usr/java/jre1.8.0_73 directory. When the installation has completed, you will see the word Done.
Delete the .tar.gz file if you want to save disk space.

All times are GMT -6. The time now is 10:54 PM.

vBulletin © 2021, Jelsoft Enterprises Ltd
© 2014 - 2020 MMOUI