ESOUI

ESOUI (https://www.esoui.com/forums/index.php)
-   Minion (https://www.esoui.com/forums/forumdisplay.php?f=183)
-   -   Minion is unable to connect to the internet (https://www.esoui.com/forums/showthread.php?t=8898)

MomsBaguetti 12/31/19 10:25 PM

Minion is unable to connect to the internet
 
3 Attachment(s)
Hi, so Minion was working perfectly then two days ago not working anymore all of a sudden
I tried everything that i found about on the board.

Baertram 01/01/20 05:07 PM

Your firewall or antivirus is blocking it then or your router does.
Or some malware or similar bad virus program installed a proxy server which your browser/standard windows system uses.

Search for your windows version and proxy to find out how to disable a proxy server.
Scan your PC for malware and virus infections.
Anything I can find about this so far got to do with these threads, or I can remmeber (but not find anymore :-( ) some info about a java changes which set your java to always use ipv6 as connection settings. Try to search for java and ipv4 to find out how to enable ipv4 and ipv6 protocolls for the java applications so both can pass through java network packages again in java applications.

MomsBaguetti 01/01/20 08:31 PM

I allowed minion on firewall and put it in exclusions on windows defender, my windows install was a few days ago so its clean, i checked anyway using malwarebytes and its clean, now running fullscan but unlikely.
I checked my proxy settings, not using proxy.
All that remains i guess is about java protocols which i have no idea what to do about them and google has confused me even more, can you elaborate please?

Baertram 01/02/20 03:19 PM

Did you run minion with admin/priviledged rights?

The log file says "IOException: Read timed out" which means Java was not able to connect to the http website of Minion.
It tried using your proxy server (if enabled. You already said there is none so it uses the direct connection of your ISP).

You need to check Windows Firewall if Minion is really enabled for all protocolls (tcp, udp, others) and ports.
If so, you need to check if your router allows the connection or some other firewall software in your computer is installed and used.

I cannot fix this from here and cannot tell you more about the ipv4 and ipv6 stuff as I'm not java dev. Basically these 2 are different network protocolls. ipv4 is the typical ip address protocoll you might know, looking like this: 192.168.178.4 or any x.x.x.x type of address.
As the number range of these is limited from 1.1.1.1 to 255.255.255.255 the ipv4 protocoll was not able to provide numbers for the increasing number of devices in the wolrd wide web (internet). So ipv6 was created which supports way more number combinations + other features.
Your network adapter drivers either use ipv4 or ipv6, or both, to connect to the internet. If your java applications is set to only use ipv4 and your network connections settings says use ipv6 only this might be a problem.

So there was some command console (WIN key + r, type "cmd" and run as administrator) command to switch the java stack to use both or only one of these I remember.
I found this thread about it e.g.
https://stackoverflow.com/questions/...pv4-ips-on-jre

Close Minion.
Use taskmanager to check if all minion.exe processes are really closed!

Windows:
If you are using Windows, just run this command on Windows cmd (WIN key+r -> type cmd and run as admin then):
Code:

setx _JAVA_OPTIONS -Djava.net.preferIPv4Stack=true
Press return key afterwards.

Run Minion 32bit version then (if you have installed Minion 64bit client deinstall it and download the Minion 32bit client instead!) as admin and tyr again. Hope it helps.

MomsBaguetti 01/02/20 05:22 PM

Alright i "fixed" it unconventionally while i was typing this reply - BY USING A VPN PROGRAM.
What made me try this is that the same day that minion stopped working, a website on which i read manga everyday stopped loading, later i found out that only the main page was not working so i just bypassed it, now i turned on my vpn and the main page suddenly works, so i tried it on minion and it works as well!

So basically the problem is either router rules or ISP blocking some servers or what its called ha.

Im gonna keep what i was gonna write below because my troubleshooting might help someone else :p

...

Always running minion on admin.
I enabled all protocols for minion through Inbound Rules, my router's control panel has been not responding for about a year so i cant go and check it, but it has been working with no problems ever since, and since Minion was working without a problem just a few days ago, i think there is no need to fix the router if it isnt broken no?
I have tried to look into the java ipconfig through google but all the guides are very confusing and seem to be for developers only, so i just went with command console, which i have tried before might i add, but nothing.
Also found that i had a vpn program installed somewhere, i uninstalled it still nothing.

Quick reminder that the timeline for this problem goes like this: Old windows install, minion working > new windows install, minion working > few days later of new install, minion stops working

If there is no other element then might have been a program i installed after installing minion, for that im gonna attach a screenshot below of my last installs because im pretty sure none of them should screw with proxies or stuff.





TLDR; Used vpn application, problem solved. Turns out my ISP or their asshole company is blocking sth.


All times are GMT -6. The time now is 04:10 AM.

vBulletin © 2020, Jelsoft Enterprises Ltd
© 2014 - 2020 MMOUI