ESOUI

ESOUI (https://www.esoui.com/forums/index.php)
-   Minion (https://www.esoui.com/forums/forumdisplay.php?f=183)
-   -   Minion not detecting my ESO Addon directory (https://www.esoui.com/forums/showthread.php?t=1991)

Zylith 08/20/18 04:40 PM

all you have to do is create a text file in the AddOns folder called AddOns.txt leave it blank but minion looks for that file in the log. Hope it helps :)

djeki 09/09/18 04:30 AM

I also had this problem in Windows 10 and had only one blank field in the program. The program must be started as an administrator. Then it works correctly.

Sammica 12/10/18 01:49 PM

Doesnt work
 
I have ESO installed through steam, cant find the addon folder anywhere on my drive. I tried looking in the Documents folder that was mentioned in this thread, not there, not in the steam's ESO folder anywhere. So minion cant find it even with turning it to 6 and I cant manually add it because i cant find it lol.

sirinsidiator 12/10/18 02:24 PM

Try to copy the following command into your start menu:
Code:

explorer /e,::{FDD39AD0-238F-46AF-ADB4-6C85480369C7}
This should open a new explorer window in the documents folder which contains the "Elder Scrolls Online" folder. When you right-click on it and select properties, it should show you the correct path.

Sammica 12/10/18 02:42 PM

Thank you so much! that worked!

brassrod 01/21/19 02:05 PM

I've tried all these recommendations. Unfortunately I can't use minion at all. I have a rather complex home network and my PC is a member of a Windows domain. Does it not account for the change in path for domain joined machines?

Domain joined machines use for example:

C:\Users\username.domain\Documents\Elder Scrolls Online\live\AddOns

if I manually download the addon and place it in the directory it works fine.

From the logs:

DEBUG 2019-01-21 13:07:44,174 [Thread-17] gg.minion.service.AddOnDetectionService:interrogateDirs(333): interrogating TOC: C:\Users\user.domain\Documents\Elder Scrolls Online\live\AddOns\VotansMiniMap_v1.4.14\VotansMiniMap_v1.4.14.txt
DEBUG 2019-01-21 13:07:44,175 [Thread-17] gg.minion.service.AddOnDetectionService:interrogateDirs(380): Toc not found for: C:\Users\user.domain\Documents\Elder Scrolls Online\live\AddOns\VotansMiniMap_v1.4.14\VotansMiniMap_v1.4.14.txt
DEBUG 2019-01-21 13:07:44,176 [JavaFX Application Thread] gg.minion.util.ProgressManager:lambda$null$1(37): Adding GamInstall ''ESO-1'' to ProgressManager.

Baertram 01/21/19 03:48 PM

This folder is wrong:
Code:

AddOns\VotansMiniMap_v1.4.14
Did you maybe download and extract the file manually and thus the ZIP name was "VotansMiniMap_v1.4.14.zip" and the folder was created this way?

Remove it as Minion tries to read the txt file, which does not exist, and then hangs!
The folder must be only "AddOns\VotansMiniMap"

Batucada 10/11/19 10:48 PM

Minion not recognizing ESO addons
 
When I check Minion, it says I have no addons for ESO. ESO shows the addons and they work fine. How can I correct this so I can update addons as needed? :confused:

Baertram 10/12/19 03:44 AM

Did you read the sticky forum post about Minion troubleshooting?
If not, please do so and follow the steps there.

In addition:
-Set in Minion's settings (gear icon at top right corner) has set the scan depth to higher subfolder level.
-Disable Microsoft OneDrive or move documents folder from OneDrive back to normal C:\users\windows user name folder

Elysida 01/01/20 03:22 PM

I was having this trouble as well so I analyzed the issue on my PC. I am running Windows 10 Enterprise (1809) and I did the default install of both Minion and ESO. When I found where ESO had placed the addon folder it is not in the location specified in the information you have posted. For my install it is here:
C:\Users\Home\Documents\Elder Scrolls Online\live\AddOns

I could not get Minions to accept that location no matter how many times I followed the instructions here to delete the minion file and run it as admin.

After some additional trouble shooting I got it to work by using these steps:

1) Close ESO and Minion
2) Manually download one mod (I used Map Pins because it is a simple install
a) Create a folder in the AddIns Directory named appropriate for the mod you have (for Map Pins the folder should be called MapPins)
b) Copy all of the files in the zip folder into the MapPins folder
3) Delete the minion.xml file (Mine was located in C:\Users\Home\.minion folder)
4) Start ESO and log in. Make sure that the Map Pins Add on is showing in the Add Ons section of ESO and it has a check mark to the left indicating that it is to be loaded. Select a character and press play. (This creates the AddOnSettings.txt file in the AddOns folder.
5) Close ESO
6) Start Minion and stop when it asks you to search for ESO or Warcraft.
7) Use the gear icon in the top right of the minion screen to go to settings.
8) On the folder Depth section set this to a value several greater than the number of folder names in the path to your AddOns folder (I used 10 even though my explorer only shows I had 6 folder names. It would not work with it set at 6). Save the settings and it will take you back to the search screen.
9) I then allowed Minion to use the default settings and agreed to continue on each screen.

Minion then detected my ESO install and found the Map Pins files. It works fine for me now. Some of the steps above may not be necessary but this is what worked for me.

Kronn8 05/23/20 05:45 PM

After I changed the search depth to 6 and closed the ESO launcher, it was able to detect my Addon directory.

spooky 05/28/20 06:44 PM

Quote:

Originally Posted by chronos1981 (Post 32637)
Run it as admin worked for me.

This worked for me. :D

Baertram 05/28/20 08:12 PM

Just in case you did not see it:
https://www.esoui.com/forums/showthread.php?t=8082

Each forum got (or can have) sticky threads and posts at the top.
Search there first if you look for answers to re-occuring problems, or at least problems that might others got as well.


All times are GMT -6. The time now is 07:26 PM.

vBulletin © 2020, Jelsoft Enterprises Ltd
© 2014 - 2020 MMOUI