ESOUI

ESOUI (https://www.esoui.com/forums/index.php)
-   AddOn Help/Support (https://www.esoui.com/forums/forumdisplay.php?f=164)
-   -   Addons don't work (https://www.esoui.com/forums/showthread.php?t=8608)

FreddyJ 06/20/19 11:27 AM

Addons don't work
 
Decided (after several months) to finally fix my addons. Running them with the "load out of date addons," but still having issues.

I use Minion to install an update them.

Tried to Update them from Minion but that didn't work

Found them manually and deleted the old ones and re-installed them with Minion (all 4).

Checked and made sure my Addons folder is in the correct place (path is correct).
Checked the addons, and they show being installed today, when I did that earlier, and there's a folder under the Addons folder for each one reflecting today's date/time.
Back into the game, and 3 are still red. All three show out of date, and two also show Dependency in red.

After reboot, there was a change in the color as seen in-game. With the "allow out of date addons" button selected, one addon showed as out of date; one showed as out of date and dependency; and one only showed dependency.

Resetting UI didn't have any effect.



I checked/unchecked the "Load out of date addons," button several times, and reloaded the UI after each change - results still the same, 3 red addons.

I'll post this here if someone could help, appreciate it. Meanwhile, I'm rebooting (cold) my computer and see if that makes a difference.

Thanks.

After reboot, there was a change in the color as seen in-game. With the "allow out of date addons" button selected, one addon showed as out of date; one showed as out of date and dependency; and one only showed dependency.

Resetting UI didn't have any effect.

Wheels 06/20/19 11:37 AM

If you're getting alerts for dependencies, then you'll need to install the libraries and such they depend on. They can also be found on minion.

Drakanwulf 06/20/19 12:43 PM

For those add-ons that are showing dependency errors, the manifest (e.g. "addonName.txt") file for that add-on may be so far out of date that it is trying to load these dependent libraries itself.

Look for directive lines that start with a "lib/" or "libs/" directory name and contain the name of the library that is giving you problems. Delete these lines after making a back up copy first.

Then, add the library folder name to an existing "## DependsOn:" directive to insure the game loads the dependent library before it loads the add-on.

Do a forum Search for my posts to get more information and to see some manifest file example fixes.

Baertram 06/20/19 01:50 PM

General hint:
If you update addons, and especially libraries, you should logout first before putting the new files into the live/AddOns folder!
Otherwise the ingame addon manager could behave wrong as new txt files got not loaded properly.

FreddyJ 06/21/19 10:47 AM

Thank you for the answers.

Crazy thing is, one of the addons is a Lib file, that is supposedly needed by one of my other addons.

FreddyJ 06/21/19 11:03 AM

Quote:

Originally Posted by Baertram (Post 38466)
General hint:
If you update addons, and especially libraries, you should logout first before putting the new files into the live/AddOns folder!
Otherwise the ingame addon manager could behave wrong as new txt files got not loaded properly.

Thanks.

I was logged out off the game when I deleted and reinstalled the addons.

In the years before, I never had to load Lib files. But now it seems that the original people no longer keep addons up-to-date, and those addons are passed to other people, the newer people are changing things. I just checked each addon, and discovered I need at least 6 Lib files to run my addons. So, maybe that is my problem.

I may have some additional questions for you if that's OK?

Thanks again.

FreddyJ 06/21/19 11:44 AM

I unstalled my addons again, and noticed there was a check mark I could put next to another file that seemed to save variables. So, I uninstalled the addons and check that part, hoping that would eliminate every trace of each addon.

Next, the instruction state that you either embed the addons in the file, or put them separately as an addon. But if you list them separately, you must add a dependency statement in the Addon Manifest. So, my question is (I never had to do this before, so I'm a noob with this problem) where is the Addon Manifest. Is there a Addon Manifest for each addon? Or a separate one for each addon? Note that I have on addon that in it's text description lists 5 files I would need to add as a dependency (4 are lib files, one is CostumCompassPin file (not Lib), and there's a discussion about this in another part of the forum).

sirinsidiator 06/21/19 12:13 PM

As a regular user you don't have to worry about modifying addon manifests and whatnot. Just install the addon and all the dependencies listed on its description page. Then check the "Allow outdated addons" checkbox in the addon menu ingame and you are done.

FreddyJ 06/22/19 07:57 AM

Quote:

Originally Posted by sirinsidiator (Post 38487)
As a regular user you don't have to worry about modifying addon manifests and whatnot. Just install the addon and all the dependencies listed on its description page. Then check the "Allow outdated addons" checkbox in the addon menu ingame and you are done.

There are 3 addons I use.

MiniMap - Loaded, no issues.
Skyshard - Not loaded, out of date, dependency
Quest Map - out of date, dependency
LibMapPins - although a Lib file, it's listed under addons. It's shown as out of date.

Even if I check the "Allow outdated addons" checkbox, Quest Map and Skyshard still show "Dependency" in red. If I use the command to activate Skyshards, it tells me it's an invalid command, so the Dependency issue is preventing me from running that addon (although I have all the Lib files listed in the addon description, the LibMapPins is causing this problem, I think).

I have 6 Lib files loaded that were shown as needed to run the addons.

Well, thanks everyone, I'm going to see if there are other programs that do the same thing and just replace the addons that don't work. I appreciate your help.

t31os 06/22/19 11:39 AM

For LibMapPins, you only need open the LibMapPins-1.0.txt and update the APIVersion.

Quote:

## APIVersion: 100027 100028
Likely similar for other dependancies you're having a problem with. I have Skyshards running fine, not sure if or what i had to edit to get it running, but it would have been trivial.

Baertram 06/22/19 06:20 PM

If an addon shows dependency in red there is a missing library not activated. You will see the missing ones if you expand the addon name.
Or install Votans Addon List and check the red circle in the addon line. The tooltip will tell you what is missing. Other benefit:if you enable an addon Votans Addon List will enable the depenciesnneedednfor you automatically (not install, this must be done manually or via Minion.)

FreddyJ 06/22/19 07:06 PM

Thanks again.

I got Skyshards working. I expanded the writeup and discovered I was missing a lib file, although earlier today I had installed it. Don't know where it disappeared to.

The only one that doesn't work now is Quest Map. The out of date issue is taken care of by the little checkmark that allows out of date addons. I'll have to go back and check the dependency. I had downloaded all the Lib files I needed for Quest Map, but maybe I made an error.

Note: The only "required" Lib file for Map Quest is "LibMapPins," and I have that in my files. Don't know if this makes a difference, but that Lib file was last updated 2 years ago, 10 June 2017.

Question: All the years I've been playing ESO, and had these 3 addons running. Now, suddenly, I need to add the Lib files for each addon. Was that a change that happened in recent years?

Baertram 06/23/19 07:25 AM

Libraries were included in the addon zip packages but this lead to several errors and a huge amount of time for each addon dev to update addons where only a lib changed.
Libd are not intended to be included. They are reusable code which is an addon on its own, if you see it like this, which other addons are able to use as well.

So you need to install them as standalone version now once (also possible via Minion) and are able to update them via Minion like normal addons now.
It saves a lot of time, reduces errors, makes addon updates easier as all addons will benefit from a fixed library as soon as the lib gets updated.
Is only a bit confusing if you do it the first time.

Burlarr 08/25/19 03:17 AM

Thanks
 
I just wanted to say thanks, after reading this post and dl Votan Addon list I was able to figure out that the reason my add-ons were not working was I need to dl additional add-on's.

Minion is great help too.

Thanks again everyone

Burl

Baertram 08/25/19 11:52 AM

You can see the needed dependencies (other addons) as well without Votans Addon List.
If an addon cannot be enabled (it's red) you need to expand this entry with the button at the left (small arrow/triangle) and below you see a list of needed dependencies then.


All times are GMT -6. The time now is 11:48 AM.

vBulletin © 2020, Jelsoft Enterprises Ltd
© 2014 - 2020 MMOUI