-   Minion (
-   -   Minion on Linux (

Faulon 06/11/21 02:43 PM


Originally Posted by Baertram (Post 44144)
Others having a similar issue had either a corrupt download of the jar containing file, or at least missing subfolders of that downloaded file (like the libs folder).
Try to validate it's the full file and you have extracted all properly.

I come across another post and forgot to insert it here, but it is saying I need the jJavaFX installed. Well I am extremely new to Linux so I have the zip file of the javafx, but I'm three sheets to the wind on installing it correctly. Ive tried extracting it to my usr/local directory, fired up netbeans but its not registering any JavaFX file.

I did run the other option of installing through lutris but it is next to impossible to read and last time I attempted to run it, (which was months ago) minion would simply crash.

I like the instructions from Dolby, but it sounds like I need to install the JavaFX for it to properly install. the .jar

UPDATE: I'm just using the Lutris install instructions to run Minion. I am not going to worry about JvaFX right now, don't need to.

[Daniel] 07/09/21 03:39 PM


Originally Posted by Techwolf (Post 39161)
Update 3: I revisited this issue and found out the root cause of the error was missing openjfx from openjdk. Search for and install the openjfx package for the distro. For gentoo system, enable and openjfx USE flag and re-emerge openjdk. Got past the error but gets stuck at init. Can get to settings and so on, but the black popup will not go away. Can close the program normally.

Lots of great information in this thread, but Techwolf's update held the answer I needed to get passed the "Could not find or load main class gg.minion.Minion" error I was getting after first trying to launch Minion.

I'm a relatively new Linux user testing out Manjaro 21.07 (KDE Plasma) as my possible Windows replacement and finding that every moment is a learning opportunity.

Here's what I did (craddle to grave) in case the steps help someone else:
1) Installed ESO via Steam/Proton (steam pre-installed by Manjaro KDE)
2) Copied my pre-existing Windows Addon folder to the new Linux/Steam path... /home/<userid>/.local/share/Steam/steamapps/compatdata/306130/pfx/drive_c/users/steamuser/My Documents/Elder Scrolls Online/live/AddOns/
3) Downloaded and extracted the Minion Java archive file to a Minion folder on my desktop
4) Used Manjaro's "Add/Remove Software" to install jre8-openjdk-headless 8.u292-1
5) Opened the Minion Folder on my desktop and launched a terminal from there
6) executed java -jar Minion-jfx.jar... and received the "Could not find or load main class gg.minion.Minion" error
7) Found Techwolf's note and used Manjaro's "Add/Remove Software" to install java8-openjfx 8.u.202-3 (quite possibly the only software I needed to install as it includes the JDK in its dependencies)
8) Returned to the terminal session at the Minion Folder and re-executed java -jar Minion-jfx.jar... Success!
9) copied the Null folder update over the original JAR
10) Returned to the terminal session at the Minion Folder and re-executed java -jar Minion-jfx.jar... Success!
11) I noticed Minions tree for navigating to the addon folder was not showing hidden folders, but found that if I clicked the pencil you could type/paste in your own path... /home/<userid>/.local/share/Steam/steamapps/compatdata/306130/pfx/drive_c/users/steamuser/My Documents/Elder Scrolls Online/live/AddOns/
12) I watched in the terminal as it successfully parsed all my addons, but noticed that the UI didn't update with my ESO Addon list
13) Closed Minion and relaunched once more via terminal... java -jar Minion-jfx.jar... Success, ESO and it's addons listed as expected!
14) Added a script to my desktop with the following code so I can click-to-launch (replace your userid for <userid>)

cd /home/<userid>/Desktop/Minion/
java -jar Minion-jfx.jar

Dolby 01/10/22 06:35 PM

1 Attachment(s)
Just posting an update since its been awhile and I just had to test Minion in Ubuntu 18x.

This is what I did to get Minion running...
  1. Download jdk8 from oracle, you need an account but its free
    Download latest jkd-8u___-linux-x64.tar.gz into your Download directory ~/Downloads
  2. Open up terminal and...
  3. cd ~/Downloads
  4. wget
  5. chmod +x
  6. sudo ./ -f jdk-8u311-linux-x64.tar.gz
    Answer 'y' to all questions
  7. Verify we have jdk8 as default:
    java -version
    java version "1.8.0_311"
    Java(TM) SE Runtime Environment (build 1.8.0_311-b11)
    Java HotSpot(TM) 64-Bit Server VM (build 25.311-b11, mixed mode)
  8. wget
  9. mkdir minion
  10. unzip -d minion
  11. cd minion
  12. java -jar Minion-jfx.jar
  13. Update Minion and it will quit. There is a bug where it will download the update into a sub directory named "null" inside the minion directory.
  14. cd null
  15. java -jar Minion-jfx.jar

10leej 03/18/22 09:32 AM

Just out of curiousity, would this work with openjdk? If so we could just package it up as flatpak or appimage so we don't have to go through so much work just to get it running.

k33ny 03/24/22 03:15 PM

I've written a script to install Minion-java properly on Lutris (without wine).

k33ny 03/25/22 06:36 AM


Originally Posted by 10leej (Post 45524)
Just out of curiousity, would this work with openjdk? If so we could just package it up as flatpak or appimage so we don't have to go through so much work just to get it running.

Unfortunatelly, this does NOT work with openjdk8. I did manage to make it run with openjdk17 + openjfx17, however only partially as updates would still not work.

Baertram 03/25/22 07:05 AM

Updates of Minion do not work?
Well I'd refrain from not installing the updates and using it like that as the log4j security fixes are only available in the updted Minion 3.0.6+ versions, but not in any 3.0.5 version (or early 3.0.6 versions).

XXXBold 04/05/22 07:03 AM

Can't start minion anymore
3 Attachment(s)
I'm having a weird issue with minion on my Linux machine, I followed the instructions on how to install and also got it working.

Didn't use minion for a while then (about 2 months or so), and now I can't start it anymore.
It keeps throwing exceptions on startup (Only visible when starting from terminal), and the window is not fully shown, just the border. There it hangs forever, see terminal.txt. minion.log is also included, but probably not helpful.

After some testing, I found out that it seems to be an issue with the proprietary NVIDIA Driver, maybe an update broke this. When I switch to the free nouveau driver, I can start minion normally and it works as intended (Systemdetails: system.txt).

I installed it like this: "Minion-jfx.jar" + "lib" and the required java-runtime in the same directory, with a startscript containing the following:

#Start minion addon manager
export PATH=./jdk1.8.0_311/bin:$PATH
export JAVA_HOME=./jdk1.8.0_311
java -jar Minion-jfx.jar

Feel free to ask for more information, I'm glad to help solving this.

Thanks and Regards,


All times are GMT -6. The time now is 02:23 AM.

vBulletin © 2022, Jelsoft Enterprises Ltd
© 2014 - 2021 MMOUI