ESOUI - View Single Post - Minion hardcodes Documents folder
View Single Post
08/11/21, 11:13 AM   #3
Join Date: May 2017
Posts: 2
Hi Baertram, thanks for the reply.

Originally Posted by Baertram View Post
It's a known problem and ESO is not supporting this, it's not Minion! ESO won't read your documents/live/AddOns folder anymore as it was moved to OneDrive and thus all addons are missing/not found anymore.
You need to disable this OneDrive documents backup OR use something like Symlink/MKlink for windows to redirect your c:\users\...\documents\elder scrolls online folder to your OneDrive folder. And even then it might trouble ESO. You can easily check this by adding addons to your documents folder and check if ES shows and updates the SavedVariables etc. properly ingame. If it works you are one of the small amount of lucky guys wher eit does
For me ESO itself has always worked fine using the OneDrive backup feature. In fact I just built my new PC last weekend, I reinstalled ESO and launched it without doing anything else and all my Addons were already installed because OneDrive had already synced the files from my old PC's Documents folder.

Originally Posted by Baertram View Post
About Minion:
In fact YOU specify the addons folder within Minion yourself, as you define the game and it's addons folder! So if you try to point it to the OneDrive folder it should work, or maybe could. But as one can easily point it to something like d:\documents (after moving the documents folder) this should work as well as long as OneDrive is not blocking the access. So maybe Minion needs to be started with admin / priviledged rights then.
Just to be clear I have Minion working with my setup. The "complaint" (very minor nickpicky inconvenience really) is that when I installed Minion it made a new empty fake Documents folder in C:\Users\<user>\Documents that has nothing in it except a shortcut file, I don't know what the purpose of this shortcut is but it's annoying that it doesn't put it in my real Documents folder.

I was also speculating whether the reason Minion did not automatically find my Addons folder is because of this incorrect Documents folder hardcoding (but I don't know if automatically finding the Addons folder is even a Minion feature). To be clear when I manually specified the folder it worked (although for some reason I had to restart Minion before it showed any addons).
  Reply With Quote