ESOUI - View Single Post - bugs: Minion has issues with Win10 live logins
View Single Post
06/24/20, 04:04 PM   #3
Join Date: Jun 2020
Posts: 2
Originally Posted by Baertram View Post
Minion was not the problem if OneDrive is used, but OneDrive was/is!
The standard behavior of Win10 when you log in with a live account is to stick documents, pictures, etc. on OneDrive for backup. The non-onedrive documents folder was empty except for a minion created file (I can't speak to whether the folder existed previously or not because I never checked). I'd argue that ESO is doing the right thing (well not really since it should be sticking things in Documents\My Games and it isn't) and Minion isn't. I can tell you if I tried to get this one by my boss as a feature and not a bug I suspect he'd be less than amused.

Originally Posted by Baertram View Post
Use Minion 32bit version even on a 64bit OS, start Minion as admin (both like mentioned in the troubleshooting Minion guide)
I tried using 32 bit minion before posting, it didn't help. Admittedly I didn't try elevating but I install minion in a non-default path that allows writes w/o requiring elevation.

I admit I'm also puzzled why / vs \ matters. .NET (and I think Win32, but it's been a long time since I've done raw Win32 coding) is tolerant of getting forward slashes in paths. I thought I saw somewhere that Minion was Java, I'm not at all familiar with the Java IO libraries but I'd expect them to eventually end up calling into Win32.
  Reply With Quote