Quantcast ESOUI - View Single Post - Minion Issues
Thread: Minion Issues
View Single Post
09/28/18, 08:02 AM   #4
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,623
The lines before the Java error appears tell us there will be used the standard proxy of your internet (browser):
Code:
DEBUG 2018-09-27 09:51:24,891 [JavaFX Application Thread] gg.minion.util.FeedClient:getRoutePlanner(61): System Default Http Proxy.
The next messag then afterwards is:
Code:
WARN 2018-09-27 09:51:24,973 [Thread-8] gg.minion.util.FeedClient:run(164): IOException: Address family not supported by protocol family: connect
Searched for the message and found:
1. Try to check whether the spy program called "RelevantKnowledge" is installed. Its uninstallation helped me to solve the problem.
2. https://www.oxygenxml.com/doc/versio...supported.html

Code:
Question:
I have experienced the following error: "Address Family Not Supported by Protocol Family; Connect". How do I solve it?
Solution:
This seems to be an IPv6 connectivity problem. By default, the Java runtime used by Oxygen XML Author prefers to create connections via IPv6, if the support is available. However, even though it is available in appearance, IPv6 sometimes happens to be configured incorrectly on some systems.

A quick fix for this problem is to set the java.net.preferIPv4Stack Java property to true (java.net.preferIPv4Stack=true).

In order to do this, follow this procedure:
Edit the custom_commons.vmoptions file that is located in the Oxygen XML Author installation folder, by adding the Java property java.net.preferIPv4Stack=true, and save it in the same location.
Restart Oxygen XML Author.
Make sure the procedure was successful by going to Help > About > System properties and check that the value of the java.net.preferIPv4Stack property is true.

3.
Try to disable your proxy server/check your proxy settings if there is some proxy active which you haven't activated by your own:
Description of a "proxy" and how to change it within "Windows 10"

If your proxy was set by yourself and should be used try to temporarily disable it and start Minion then, go to the settings and enter the proxy in there. Then enable the proxy in your windows settings again if you need to.
  Reply With Quote