Quantcast
ESOUI - View Single Post - UX Issue: No error shown if mod can't be updated
View Single Post
08/03/20, 06:08 PM   #2
Sharlikran
 
Sharlikran's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2014
Posts: 303
I do not see what could be different about a mac. Obviously a windows person does not have to worry about owners of the directories or files and we won't set that. I can't make that happen prior to uploading this to ESOUI.

However, none of this makes any sense. Mac is a supported environment for the game. So ZOS will make any windows mod work the same on a mac.

For that reason you need to have all the proper requirements installed. LibMapPins for one and LibGPS requires three other mods as mentioned on the authors page for LibGPS. So if you do not have the most recent version of everything then you will get an error that SkyShards will not run because you are required to use a newer version of the mod.

Rather then hack the code up to make it work get the proper libraries. Then post the error. If the error tells me you didn't install one of the requirements then that's where you should start.

If there is obviously something that Zenimax needs to change then they need to know. There is no reason a Mac can not run the same mods as a PC. Unix, no that's not supported. Mac does use Unix but it's a supported environment and ZOS has ways they should be able to test anything.
__________________
Admin for TES5Edit, occasional LOOT masterlist contributor, and Wrye Bash contributor. I also maintain special Fallout 3 and Fallout NV versions of Wrye Flash.
  Reply With Quote