Quantcast
ESOUI - View Single Post - minion is unable to connect to the internet please check your firewall security proxy
View Single Post
11/07/20, 12:31 PM   #5
iKorv1n
Join Date: Nov 2020
Posts: 3
I checked firewall exclusions, did not have a proxy, ran anti-virus, tried running with all anti-virus and firewalls completely off, checked router settings and reset it and none of these things worked, but interestingly a slightly older post for the same pop-up actually had the solution for me.

Originally Posted by Baertram View Post
Did you run minion with admin/priviledged rights?

The log file says "IOException: Read timed out" which means Java was not able to connect to the http website of Minion.
It tried using your proxy server (if enabled. You already said there is none so it uses the direct connection of your ISP).

You need to check Windows Firewall if Minion is really enabled for all protocolls (tcp, udp, others) and ports.
If so, you need to check if your router allows the connection or some other firewall software in your computer is installed and used.

I cannot fix this from here and cannot tell you more about the ipv4 and ipv6 stuff as I'm not java dev. Basically these 2 are different network protocolls. ipv4 is the typical ip address protocoll you might know, looking like this: 192.168.178.4 or any x.x.x.x type of address.
As the number range of these is limited from 1.1.1.1 to 255.255.255.255 the ipv4 protocoll was not able to provide numbers for the increasing number of devices in the wolrd wide web (internet). So ipv6 was created which supports way more number combinations + other features.
Your network adapter drivers either use ipv4 or ipv6, or both, to connect to the internet. If your java applications is set to only use ipv4 and your network connections settings says use ipv6 only this might be a problem.

So there was some command console (WIN key + r, type "cmd" and run as administrator) command to switch the java stack to use both or only one of these I remember.
I found this thread about it e.g.
https://stackoverflow.com/questions/...pv4-ips-on-jre

Close Minion.
Use taskmanager to check if all minion.exe processes are really closed!

Windows:
If you are using Windows, just run this command on Windows cmd (WIN key+r -> type cmd and run as admin then):
Code:
setx _JAVA_OPTIONS -Djava.net.preferIPv4Stack=true
Press return key afterwards.

Run Minion 32bit version then (if you have installed Minion 64bit client deinstall it and download the Minion 32bit client instead!) as admin and tyr again. Hope it helps.
Using this command prompt line seems to have been the key. That thread closed out saying that a VPN solved the issue for the claimant, but I tried this and it worked for me. Not sure if it'll help OP here.
  Reply With Quote