Quantcast
Python2 Dependency - ESOUI
Thread Tools Display Modes
01/20/23, 10:36 AM   #1
elzzid
Join Date: Dec 2019
Posts: 2
Nevermind!

Edit: I don't know how to delete this thread, but ignore this all... I don't know where I saw that it required python2, but I don't see it anymore... Apologies.

Last edited by elzzid : 01/25/23 at 11:13 AM.
  Reply With Quote
01/20/23, 11:50 AM   #2
Baertram
Super Moderator
 
Baertram's Avatar
WoWInterface Super Mod
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 4,321
I'm not into the depth of the dependencies and the coding of Minion but you might have a look here if you search for a working Minion replacement for Linux:
https://www.esoui.com/downloads/info...onManager.html

I cannot say something about its dependencies and versions etc. but it's pretty new and the dev is still around -> using the addon comments.

Last edited by Baertram : 01/20/23 at 12:32 PM.
  Reply With Quote
01/20/23, 12:24 PM   #3
elzzid
Join Date: Dec 2019
Posts: 2
Thanks! I will definitely check that out.

Edit: Definitely shows promise, but it doesn't seem to handle addons as well as the official Minion app. I have several that show up with updates that can't be updated, and it seems those that I did update through Linion were subsequently broken. It very well could be an issue that I can fix on my end, but it will take a considerable amount of work I think. Hopefully I can find the time to troubleshoot it at some point and submit a bug report.

Last edited by elzzid : 01/25/23 at 11:06 AM.
  Reply With Quote
01/26/23, 10:39 AM   #4
Baertram
Super Moderator
 
Baertram's Avatar
WoWInterface Super Mod
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 4,321
Have a look over here, someone said you can rebuild the dependencies of Java SDK that Minion needs, and which uses Python2.
https://www.esoui.com/forums/showpos...6&postcount=38

Edit:
I just saw you had edited your post. There must have been that Python2 dependency somehwere as other Linux users also wrote about it.
Maybe the Java SDK was updated and the dependency removed there.
  Reply With Quote

ESOUI » Site Forums » Minion » Python2 Dependency

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off