Quantcast [Mac] Unable to start Minion - ESOUI
Thread Tools Display Modes
04/25/14, 05:27 AM   #1
MRizk
Join Date: Mar 2014
Posts: 8
[Mac] Unable to start Minion

Hello Minion team,

My minion client is also stuck loading on Mac at Initializing Window controls.. I have seen you guys asking everyone to delete minion.xml and few other files, the problem is that I am not sure where I can find those files or how to access them. Please help.

Best wishes,
M.Rizk
  Reply With Quote
04/25/14, 07:21 AM   #2
Sionnach58
Join Date: Apr 2014
Posts: 2
Minion for Mac not working

Minion for Mac was working with version 2.04 but it stopped working today (locked up at initial start ZAM/Minion logo). I uninstalled v2.04 and installed v2.05, but get the same "not responding" result. Are there any files that I should delete?

I don't see a Minion folder in the ESO AddOns folder, btw.

Last edited by Sionnach58 : 04/25/14 at 07:25 AM.
  Reply With Quote
04/25/14, 07:27 AM   #3
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,193
Please post your minion.xml and minion0.log

For Mac they are located in your user folder under the hidden .minion folder. From command line you can find them ~/.minion/

If you open terminal and type

cp ~/.minion/minion.xml ~/Desktop/

and

cp ~/.minion/minion0.log ~/Desktop/

the files will show up on your desktop.

I'm guessing something is wrong with your minion.xml like a bad path but I'll know for sure if you post those files. Then if thats true you can delete the minion.xml with "rm ~/.minion/minion.xml"

Last edited by Dolby : 04/25/14 at 07:41 AM.
  Reply With Quote
04/25/14, 08:22 AM   #4
Sionnach58
Join Date: Apr 2014
Posts: 2
Minion for Mac works after reboot

I restarted my iMac because the ESO Launcher was acting weird. I then tried Minion v2.05 and it works again. I'll still look at the settings files. Thanks for the reply.
  Reply With Quote
04/25/14, 08:28 AM   #5
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,193
Originally Posted by Sionnach58 View Post
I restarted my iMac because the ESO Launcher was acting weird. I then tried Minion v2.05 and it works again. I'll still look at the settings files. Thanks for the reply.
Oh if rebooting helped I'm guessing Minion had crashed and was still running in the background. When you loaded Minion it was actually a 2nd one and the crashed Minion was causing problems. Rebooting or ending the Minion process will fix this.

We need to have Minion check for this on startup. Minion doesn't give an error if you try and open it multiple times.

Thanks for letting me know you got it working.
  Reply With Quote
04/26/14, 12:53 PM   #6
MRizk
Join Date: Mar 2014
Posts: 8
Here are the files:
Attached Files
File Type: xml minion.xml (1.9 KB, 221 views)
File Type: log minion0.log (1.5 KB, 215 views)
  Reply With Quote
04/26/14, 12:55 PM   #7
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,193
Hi MRizk,

Your minion.xml looks a little messed up. There are a few games with out any paths added. Deleteing your minion.xml should fix this. rm ~/.minion/minion.xml

Thanks for posting your config file. I'll make sure to bug this as Minion should not be adding games with blank paths.
  Reply With Quote
04/26/14, 12:57 PM   #8
MRizk
Join Date: Mar 2014
Posts: 8
Originally Posted by Dolby View Post
Hi MRizk,

Your minion.xml looks a little messed up. There are a few games with out any paths added. Deleteing your minion.xml should fix this. rm ~/.minion/minion.xml

Thanks for posting your config file. I'll make sure to bug this as Minion should not be adding games with blank paths.
It's fixed now! Thanks a lot!
  Reply With Quote

ESOUI » Site Forums » Minion » [Mac] Unable to start Minion

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off