Quantcast
Bugged Quickslots - ESOUI
Thread Tools Display Modes
06/29/22, 12:02 PM   #1
Simon Belmont
 
Simon Belmont's Avatar
Join Date: Nov 2020
Posts: 1
Unhappy Bugged Quickslots

Hello,

As of the last patch, my Quickslots, on all characters, are broken. I'll explain "broken" in a sec.

First though, I've used Rhalyf's (QuickSlot) Keybindings for the past two years. As well as Emacs, Aenathel's Keybinds, Votan's Keybinder and LUI Extended. I run others, but none that should be doing anything with Quickslots. I have since discontinued using Rhalyf's (QuickSlot) Keybindings. Which sucks. I realize there are better-maintained alternatives (I.E: maintained at all), but I like that this Addon does ONE THING, and nothing else. I don't need fancy "profiles"...I just need to be able to assign Keybinds to each Quickslot.

So: "broken" = on all but one character (my MAIN character), after the patch I could not change Quickslots. On most characters, it's stuck on Slot 6 (counting clockwise from 12:00). A couple characters were stuck on other Slots. But, in every case, I can't change Slots. My main character differs only in that her displayed current Quickslot appears to be blank (despite all Slots being filled, in the Quickslot Wheel view, in her inventory).

On the "Alts", I've simply moved their potions to the Slot that they're stuck on (via the wheel/inventory view), so that at least their one Quickslot can provide some utility. My main though...is just screwed! I can't get anything to show up in that seemingly empty Slot. Which, if her profile adhered to the trend many of my Alt's Quickslots followed, would have shown a Pet.

Another way of stating the problem I'm encountering would be: I can't change my selected Quickslot on any character. And my main character has no Quickslot selected at all.

I am not entirely unfamiliar with code, and I have opened up all .txts and .luas in my SavedVariables folder, hoping to Find the word "quick", to more specifically look for likely suspects. I then ended up checking the .luas for ALL my addons, beyond just what was in my SavedVariables folder. Bar the most search-hits were in Votan's Keybinder. But quite a few were found in LUI Extended too.

Nothing seemed inconsistent between characters in the SavedVariables files, and I assume nothings is wrong with the actual Addon's files, because no one else seems to be having this problem (I.E: complaining of it in the respective Addon's comment section). I get no UI errors from any of this. Of course I've tried running without each addon, in turn. Which has had no effect on the Quickslot issue. I just don't know what to do.

Typical ZOS; a feature no one asked for gets implemented and causes more problems than it "solves"; for me, anyway. Any advice would be great. And of course I'll do my best to answer any questions you might ask, in your attempt to help.

Last edited by Simon Belmont : 06/29/22 at 06:06 PM.
  Reply With Quote

ESOUI » General Discussion » Tech Chat » Bugged Quickslots

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off