Quantcast
CLS error - ESOUI
Thread Tools Display Modes
11/07/20, 01:39 PM   #1
Marazota
AddOn Author - Click to view addons
Join Date: Sep 2015
Posts: 232
CLS error

https://www.esoui.com/downloads/file...p?id=1381#info

anyone able to help to fix this usefull addon?
i hope it dont need full full rework

user:/AddOns/CombatLogStatistics/Combat Log Statistics.lua:246: attempt to index a nil value
stack traceback:
user:/AddOns/CombatLogStatistics/Combat Log Statistics.lua:246: in function 'CLog.SkillPointsUpdate'
|caaaaaa<Locals> eventCode = 131431, skillCategory = 7, skillType = 2, reason = 5, rank = 8, previousXP = 16854, currentXP = 19659, diff = 0, inLevel = 0, display = "" </Locals>|r
  Reply With Quote
11/07/20, 03:08 PM   #2
Baertram
Super Moderator
 
Baertram's Avatar
WoWInterface Super Mod
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,749
Do the same as described with all the other threads "how to remove LibAddonMenu-2.0" from old addons.
e.g. https://www.esoui.com/forums/showthread.php?t=9431
https://www.esoui.com/forums/showthr...t=libaddonmenu
https://www.esoui.com/forums/showthread.php?t=9420

Summary:
Remove folder and fildes embedded old libs in the subfolders libs or directly in the zip file.
Change all calls to LibAddonMenu-2.0 via e.g. local LAM= LibStub("LibAddonMenu-2.0") to directly use local LAM = LibAddonMenu2 instead.
Change the txt manifest file to ## DependsOn: LibAddonMenu-2.0>=31
Remove the word LibStub in the ## DependsOn or OptionalDependsOn lines in the txt.

Delete all lines from the txt that says something like
/libs/LibStub...
/libs/LibAddonMenu-2.0/
or similar

Install the newest version of LAM 2.0 to your live/AddOns folder directly (standalone installations like ana ddon with it's own LibAddonMenu-2.0.txt)

Last edited by Baertram : 11/07/20 at 03:12 PM.
  Reply With Quote

ESOUI » AddOns » AddOn Help/Support » CLS error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off