Quantcast
Update 32 (Version 7.2) - Page 2 - ESOUI
Thread Tools Display Modes
11/17/21, 02:05 PM   #21
Baertram
Super Moderator
 
Baertram's Avatar
WoWInterface Super Mod
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,817
Originally Posted by andy.s View Post
It would be nice to see a list of changes to core classes next time too. ZO_ObjectPool doesn't set the default resetFunction anymore, which caused some oddities in my addon that were hard to track based just on a few user reports of controls staying on screen when they shouldn't. Had to dive deep into the class code, which is not a problem, but it could've been avoided if I had known where to look sooner
Nice to know. Thank you andy.s.

This one? https://github.com/esoui/esoui/blob/...ctpool.lua#L35
Seems we need to manually add "ZO_ObjectPool_DefaultResetControl" now as "resetFunction" parameter to the call of ZO_ObjectPool, or what is the change needed here to solve your bug?

I recently noticed some weird "frozen" (not removed/hiden?) lines in the merTorchbug table lines here and there which I never noticed before.
Maybe it got to do with it.

Thank you!

Last edited by Baertram : 11/17/21 at 02:09 PM.
  Reply With Quote
11/17/21, 02:25 PM   #22
Sharlikran
 
Sharlikran's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2014
Posts: 316
Dan already mentioned we would have to make or override the reset function. I just forget how he worded it. He mentioned it would change prior to even making the change.
__________________
Admin for TES5Edit, occasional LOOT masterlist contributor, and Wrye Bash contributor. I also maintain special Fallout 3 and Fallout NV versions of Wrye Flash.
  Reply With Quote
11/17/21, 06:12 PM   #23
andy.s
AddOn Author - Click to view addons
Join Date: Jul 2014
Posts: 38
Originally Posted by Baertram View Post
Nice to know. Thank you andy.s.

This one? https://github.com/esoui/esoui/blob/...ctpool.lua#L35
Seems we need to manually add "ZO_ObjectPool_DefaultResetControl" now as "resetFunction" parameter to the call of ZO_ObjectPool, or what is the change needed here to solve your bug?

I recently noticed some weird "frozen" (not removed/hiden?) lines in the merTorchbug table lines here and there which I never noticed before.
Maybe it got to do with it.

Thank you!
Yeh, it might cause small visual bugs in several addons because objects are not automatically hidden anymore. Basically, anything that can obviously (like in this example) break backward compatibility would be nice to have mentioned somewhere
  Reply With Quote
11/18/21, 05:07 AM   #24
sirinsidiator
 
sirinsidiator's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2014
Posts: 1,492
Seeing how the ingame code still relies on resetFunction being an optional argument in many places, I feel this is more of a bug than an intended change and should be fixed in the game.

EDIT: I clarified it with Dan. The reason it was removed was because the ingame code truly does not need a reset function in some cases and in the past they would pass in function() end, which is quite awful. The new behavior is that the reset function is completely optional and if you need one you have to pass in either a custom function, ZO_ObjectPool_DefaultResetObject or ZO_ObjectPool_DefaultResetControl.
__________________
https://www.imperialtradingcompany.eu/ - My Addons - The Vault (Early updates and experimental projects) - My patreon - My blog
>siri.exe MyAddon
Does your addon work? [y/n] n
There is a typo in there.

Last edited by sirinsidiator : 11/18/21 at 09:42 AM.
  Reply With Quote
11/18/21, 10:11 AM   #25
Baertram
Super Moderator
 
Baertram's Avatar
WoWInterface Super Mod
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,817
Thanks andy.s, siri and ZOsDanBatson for the info!
  Reply With Quote

ESOUI » Developer Discussions » Tutorials & Other Helpful Info » Update 32 (Version 7.2)

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off