Quantcast Set3DRenderSpaceUsesDepthBuffer Bug? - ESOUI
Thread Tools Display Modes
09/30/18, 09:24 AM   #1
Sordrak
 
Sordrak's Avatar
AddOn Author - Click to view addons
Join Date: May 2017
Posts: 23
[Solved] Set3DRenderSpaceUsesDepthBuffer Bug?

Hey Guys

I hope you can help me with this. I'm currently playing around with 3D objects.
There is the Set3DRenderSpaceUsesDepthBuffer(bool) function.
This function is used by addons like harvest map. If active, the object will not be visible through other objects in the world.

Yet, for whatever reason, this doesn't seem to work on all clients respectively PC configuration. The following screenshots are from two different accounts / PCs. Only HarvestMap is running and in both cases Set3DRenderSpaceUsesDepthBuffer has been set to true. Yet, one client won't render the object properly.



Any suggestions what the issue here is? Related to any graphic settings in game or the graphic card?

Last edited by Sordrak : 09/30/18 at 09:48 AM.
  Reply With Quote
09/30/18, 09:30 AM   #2
Sordrak
 
Sordrak's Avatar
AddOn Author - Click to view addons
Join Date: May 2017
Posts: 23
Okay, i think i found the issue...
SubSampling Quality level High is required. Otherwise this won't work.
  Reply With Quote

ESOUI » Developer Discussions » Lua/XML Help » Set3DRenderSpaceUsesDepthBuffer Bug?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off