Quantcast ZeroBrane Studio - ESOAddonDev Plugin - Page 2 - ESOUI
Thread Tools Display Modes
12/18/14, 01:43 AM   #21
farangkao
 
farangkao's Avatar
AddOn Author - Click to view addons
Join Date: May 2014
Posts: 59
Thanks for the Report,

it proably has to do with a newer Version of ZBS.

I've used v0.60 at the time of writting this Page, there is currently v0.90 available.

I will check into it this Weekend.
__________________
@farangkao on EU Servers. My Addon: Mobile Bank Extended, For Developers: ZeroBrane Studio - ESOAddonDev Plugin
  Reply With Quote
12/20/14, 01:06 PM   #22
radarcg
Join Date: Dec 2014
Posts: 1
Same error here

I'm getting the same "module 'dist' not found:" error. Is there a quick workaround?
  Reply With Quote
12/29/14, 05:29 PM   #23
farangkao
 
farangkao's Avatar
AddOn Author - Click to view addons
Join Date: May 2014
Posts: 59
Okay, i had the same Problem,i talked with Paul K, and it was a known problem with the current 0.90 version of ZBS.

However it's already fixed

Go to https://github.com/pkulchenko/ZeroBraneStudio , click on "Download as ZIP" ,you will get the newest
version of ZBS

It's possible you have to update the luadist.lua file in "Packages" as well ,if it doesn't work with the old version,
try the one here:

https://raw.githubusercontent.com/pk...er/luadist.lua

(Right Click and "Save as" ...)

If he updates his ZBS official Version >0.90 ,it might work again without these changes.

I will then include the modified luadist.lua again directly in my package here and leave a note about the minimum Version of ZBS.
__________________
@farangkao on EU Servers. My Addon: Mobile Bank Extended, For Developers: ZeroBrane Studio - ESOAddonDev Plugin

Last edited by farangkao : 12/30/14 at 03:31 AM.
  Reply With Quote
12/29/14, 10:02 PM   #24
hisdad
AddOn Author - Click to view addons
Join Date: Dec 2014
Posts: 33
Zerbrabe 0.90 fixes

Thanks for your update.
I'm still having a problem,
Similar but different..


luadist.install 'luaxml'
Running 'install' for Lua 5.1 in 'C:\Users\John\luadist\5.1'.
D:\Zerobrane\bin\lua.exe: D:\Zerobrane\lualibs/dist\sys.lua:7: module 'lfs' not found:
no field package.preload['lfs']
no file '.\lfs.lua'
no file 'D:\Zerobrane\bin\lua\lfs.lua'
no file 'D:\Zerobrane\bin\lua\lfs\init.lua'
no file './lfs.lua'
no file './lfs/init.lua'
no file './lua/lfs.lua'
no file './lua/lfs/init.lua'
no file 'D:\Zerobrane\lualibs/lfs/lfs.lua'
no file 'D:\Zerobrane\lualibs/lfs.lua'
no file 'D:\Zerobrane\lualibs/lfs/lfs/init.lua'
no file 'D:\Zerobrane\lualibs/lfs/init.luaC:\Users\John\luadist\5.1\lib\lua/lfs.lua'
no file 'C:\Users\John\luadist\5.1\lib\lua/lfs/init.lua'
no file '.\lfs.dll'
no file 'D:\Zerobrane\bin\lfs.dll'
no file 'D:\Zerobrane\bin\loadall.dll'
no file 'D:\Zerobrane\bin/lfs.dll'
no file 'D:\Zerobrane\bin/clibs/lfs.dllC:\Users\John\luadist\5.1\lib\lua/lfs.dll'
stack traceback:
[C]: in function 'require'
D:\Zerobrane\lualibs/dist\sys.lua:7: in main chunk
[C]: in function 'require'
D:\Zerobrane\lualibs/dist\config.lua:5: in main chunk
[C]: in function 'require'
(command line):1: in main chunk
[C]: at 0x00402a57
  Reply With Quote
12/29/14, 10:07 PM   #25
hisdad
AddOn Author - Click to view addons
Join Date: Dec 2014
Posts: 33
Funny line C:\Users\John\Luadist

Just noticed the reference at the start to that path.
It doesn't exist. Zerobrane is in D:\Zerobrane

--dad
  Reply With Quote
12/30/14, 03:26 AM   #26
farangkao
 
farangkao's Avatar
AddOn Author - Click to view addons
Join Date: May 2014
Posts: 59
Yeah, ZBS is looking for a bunch of folders and seems not to find the lib he needs.

It works with me, did you try the following:


Make a Clean installation from the ZIP you got directly from the Github Repro.


Only add the following files into the "packages" subfolder (sample.lua is inside there already)


luadist.lua (Downloaded also directly from github)
ESOAddon.lua (from my ZIP)


This way it worked on my machine flawless, also make sure you open the right .exe (if you have still an Icon to your old Installation Path, you might have the same problem)


If it still not work, i zipped my installation for you to test:


download here, if nothing else works

In that installation the command to load XML was already done.So if you run luadist.install 'luaxml' ,it should say "No packages to install".
Note: it might not work if you are on a MAC or 32bit system, i'm not sure about that.
__________________
@farangkao on EU Servers. My Addon: Mobile Bank Extended, For Developers: ZeroBrane Studio - ESOAddonDev Plugin

Last edited by farangkao : 12/30/14 at 03:29 AM.
  Reply With Quote
12/30/14, 12:37 PM   #27
hisdad
AddOn Author - Click to view addons
Join Date: Dec 2014
Posts: 33
Fixed! but is this supposed to happen?

Thanks,
I had unzipped over the top and that caused the issues.
A Delete and reinstall works much better!
It's now created C:\Users\john\luadist\5.1, which seems to be by design.
However will the luadist 1.7.5 failure cause issues?

luadist.install 'luaxml'
Running 'install' for Lua 5.1 in 'C:\Users\John\luadist\5.1'.
Downloading repository information...
Finding out available versions of luaxml...
- trying another candidate due to: Error when resolving dependencies: Error when retrieving the info about 'luaxml': Error fetching package 'luaxml-1.7.5' from 'git://github.com/LuaDist/luaxml.git' to 'C:\Users\John\luadist\5.1\tmp': Binary version of module not available and using source modules disabled.
Getting luaxml-1.7.3 (binary)...
Finding out available versions of lua...
Getting lua-5.1.5 (binary)...
Installation successful.
Completed in 10 second(s).
  Reply With Quote
12/30/14, 12:47 PM   #28
farangkao
 
farangkao's Avatar
AddOn Author - Click to view addons
Join Date: May 2014
Posts: 59
The Magic word here is "Installation successful."
__________________
@farangkao on EU Servers. My Addon: Mobile Bank Extended, For Developers: ZeroBrane Studio - ESOAddonDev Plugin
  Reply With Quote
12/18/15, 11:51 AM   #29
Wussypants
Join Date: Dec 2015
Posts: 2
Post Error downloading luaxml

Hello

So when I try to do the luadist.install 'luaxml' it cant fetch the package.

Do you have any clue how I could resolve this?

Code:
luadist.install 'luaxml'
Running 'install' for Lua 5.1 in '/Users/Molin/luadist/5.1'.
Downloading repository information...
Finding out available versions of luaxml...
 - trying another candidate due to: Error when resolving dependencies: Error when retrieving the info about 'luaxml': Error fetching package 'luaxml-1.7.5' from 'git://github.com/LuaDist/luaxml.git' to '/Users/Molin/luadist/5.1/tmp': Binary version of module not available and using source modules disabled.
 - trying another candidate due to: Error when resolving dependencies: Error when retrieving the info about 'luaxml': Error fetching package 'luaxml-1.7.3' from 'git://github.com/LuaDist/luaxml.git' to '/Users/Molin/luadist/5.1/tmp': Binary version of module not available and using source modules disabled.
Cannot resolve dependencies for 'luaxml': Error when resolving dependencies: Error when retrieving the info about 'luaxml': Error fetching package 'luaxml-scm' from 'git://github.com/LuaDist/luaxml.git' to '/Users/Molin/luadist/5.1/tmp': Binary version of module not available and using source modules disabled.
Completed in 3 second(s).
  Reply With Quote
12/19/15, 02:52 AM   #30
farangkao
 
farangkao's Avatar
AddOn Author - Click to view addons
Join Date: May 2014
Posts: 59
Hi there,
You might want to report the Issue to Paul (creator of ZBS):

https://github.com/pkulchenko/ZeroBraneStudio/issues

You don't need luaxml to write with ZBS, but it helps to detect the variables used in XML Code (Names of Elements)

Also check above the Link to my latest installation which includes all you might need.

luaxml can be downloaded seperately from here: http://viremo.eludi.net/LuaXML/ (5.1 version recommended)

Hope this helps

Since i stopped playing ESO a long time ago, i can't support this Extension any further, but feel free to use it or even modify it.

__________________
@farangkao on EU Servers. My Addon: Mobile Bank Extended, For Developers: ZeroBrane Studio - ESOAddonDev Plugin
  Reply With Quote
12/19/15, 06:22 AM   #31
Wussypants
Join Date: Dec 2015
Posts: 2
I tried the link you provided, but it appears to be a windows install, and i am on Mac -.-

Anyway I'll try to write the Paul.
  Reply With Quote
12/19/15, 11:03 AM   #32
farangkao
 
farangkao's Avatar
AddOn Author - Click to view addons
Join Date: May 2014
Posts: 59
you can still "steal" my files from the zip. Since many of the files that are text-based (.lua) files anyway (such as the luaxml.lua)


I'm not even sure if the luadist works properly on a Mac, ask Paul, and don't forget to mention that you use a Mac.
__________________
@farangkao on EU Servers. My Addon: Mobile Bank Extended, For Developers: ZeroBrane Studio - ESOAddonDev Plugin
  Reply With Quote

ESOUI » Developer Discussions » Dev Tools » ZeroBrane Studio - ESOAddonDev Plugin

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off