Quantcast Bad Argument in Add-ons tab - ESOUI
Thread Tools Display Modes
10/27/19, 07:33 PM   #1
Demi-Demon
Join Date: Jan 2016
Posts: 17
Bad Argument in Add-ons tab

I just got my new PC back and finally added all my add-ons back. I went to adjust the mini map and I got this error:

bad argument #1 to 'ipairs' (table/struct expected, got nil)
stack traceback:
[C]: in function 'ipairs'
EsoUI/PregameAndIngame/ZO_Options/Keyboard/ZO_Options_Keyboard.lua:162: in function 'ZO_KeyboardOptions:PanelRequiresDeferredLoading'
EsoUI/PregameAndIngame/ZO_Options/Keyboard/ZO_Options_Keyboard.lua:146: in function 'ZO_KeyboardOptions:ChangePanels'
user:/AddOns/HarvestMap/Libs/LibAddonMenu-2.0/LibAddonMenu-2.0/LibAddonMenu-2.0.lua:964: in function 'panelData.callback'
EsoUI/Common/ZO_GameMenu/ZO_GameMenu.lua:52: in function 'TreeEntryOnSelected'
EsoUI/Libraries/ZO_Tree/ZO_Tree.lua:705: in function 'ZO_TreeNode:OnSelected'
EsoUI/Libraries/ZO_Tree/ZO_Tree.lua:411: in function 'ZO_Tree:SelectNode'
EsoUI/Libraries/ZO_Tree/ZO_Tree.lua:888: in function 'ZO_TreeEntry_OnMouseUp'
ZO_CollectionsBook_TopLevelCategoriesScrollChildZO_CollectionsBook_SubCategory1_MouseUp:3: in function '(main chunk)'


Add-on list is currently this:

CustomCompassPins by Shinni
HarvestMap by Shinni
LibCustomMenu by votan
LibStub by sirinsidiator
LoreBooks by Kyoma
MiniMap by Fyrakin
Quest Map by CaptainBlagbird
SkyShards by AssemblerManiac
  Reply With Quote
10/28/19, 04:09 AM   #2
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,536
3rd thread about this now
https://www.esoui.com/forums/showthread.php?t=8806

And if this does not work I do not see LibAddonMenu (version 2.0) in your list? Please download and update it to the newest version as well.

Last comments shows the fix about Harvens LAM to HAS adapter.

Enjoy your new pc, hope it rocks!
  Reply With Quote
10/28/19, 05:07 AM   #3
Demi-Demon
Join Date: Jan 2016
Posts: 17
Originally Posted by Baertram View Post
3rd thread about this now
https://www.esoui.com/forums/showthread.php?t=8806

And if this does not work I do not see LibAddonMenu (version 2.0) in your list? Please download and update it to the newest version as well.

Last comments shows the fix about Harvens LAM to HAS adapter.

Enjoy your new pc, hope it rocks!
Yeah, he had different mods then I did, so thought maybe something changed with this combination that was causing errors or something I was missing.

Will stick it on and load it up in a few to see what happens. (Will edit this post afterwards)

It does, I had to take it in for repairs already cuz they put the water cooler fans in a bad place and it was causing it to over heat. :/ Glad it is fixed and I can play on it again. 1080ti and I couldn't use it without fear of it restarting on me mid-game. Dx

Edit: putting LibAddonMenu fixed it. I must have totally missed it when I was grabbing mod names from my old PCs list. Thanks a bunch! I can finally change my mini map! XD

Last edited by Demi-Demon : 10/28/19 at 05:16 AM.
  Reply With Quote

ESOUI » AddOns » AddOn Help/Support » Bad Argument in Add-ons tab

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off