Quantcast
Uninstalled and reinstalled Minion; it can't find my ESO AddOns folder now - ESOUI
Thread Tools Display Modes
04/11/20, 11:26 AM   #1
LucidSeraph
Join Date: Apr 2020
Posts: 2
Uninstalled and reinstalled Minion; it can't find my ESO AddOns folder now

Hello all. Windows 10 user here. Please read this whole post to see what I have done so far in terms of troubleshooting.

I recently uninstalled and reinstalled Minion. My original intent was to move some programs off my SSD onto my HDD, including ESO. Before I tried reinstalling Minion, Minion was working just fine after I had moved ESO. It found the Live Addon folder (incidentally also on my HDD) My SSD is where most of my Windows files & work software live; I've been moving most non-work files (video games, etc) to the HDD, just because my SSD is quite small.

Initially, I tried to just uninstall and reinstall Minion to the HDD. When I discovered that it was unable to detect my AddOn folder, I gave up and just installed it to the original SSD path. Still no luck. Here are the steps I have followed as per your troubleshooting thread:

* Username contains non-latin characters? It shouldn't; my PC name is The Aluminum Falcon (with spaces). Also, remember that Minion was working fine before my attempt to move it to the HDD.
* Uninstalled Minion, deleted the XML. Done several times now.
* Downloaded 32 bit instead of 64 bit. This is what I am currently working with.
* Install to the default path. As noted, that's the first thing I tried when installing it to my HDD didn't work.
* I've been running it as administrator
* I have whitelisted the relevant folders on Windows Defender
* I do not use MS OneDrive

It launches just fine, but it doesn't find my ESO Add-Ons folder. I get a blank white screen and no options other than to try to tell it to find the folder again. I've tried varying levels of depth when telling it to find said folder: my documents, the Elder Scrolls Online folder, the Live folder, the actual AddOn folder, no such luck. I've even altered the scan depth in settings to no avail. The last thing I tried: I run [email protected] to study Coronavirus, and it can take quite a lot of processing power, so I shut that off. Still no change.

I have attached the most recent Log and XML files to this post. Curiously, you can see in the .log file that it actually finds the Elder Scrolls Online folder in My Documents, but then just doesn't find what it's looking for or doesn't do anything with it? I am at the end of my skills with troubleshooting, alas.

*edit* Nevermind! It honestly does seem that [email protected] may have been the problem. I ran it as administrator one last time, and while it's being a bit weird about it, it DOES seem to have finally found things. So, I guess, for anyone else with this problem, after doing ALL of the above steps, check to see if you have any heavy duty CPU processes going on in the background!
Attached Thumbnails
Click image for larger version

Name:	Screenshot1.png
Views:	86
Size:	41.5 KB
ID:	1231  
Attached Files
File Type: log minion.log (11.2 KB, 59 views)
File Type: xml minion.xml (972 Bytes, 52 views)
File Type: txt minionLogUpdated.txt (705.2 KB, 59 views)

Last edited by LucidSeraph : 04/11/20 at 11:33 AM.
  Reply With Quote
04/11/20, 11:33 AM   #2
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,204
Hi there,

From your log file I can see it has scanned on D:\Quick Access Folders\Documents\Adobe\Adobe.txt some txt files which do not belong in any matter to ESO. Not sure why it dies this but maybe you had chosen D:\ as your addons folder once?
The addons folde rneeds to be in the user directory of your windows account.

Try this:
Please logout of ESO.
Close Minion and be sure via the taskmanager that there is no active Minion.exe anymore running.
Check the systemtray as well for the minion icon and right click->close it.

Go to the Minion folder located at "C:\Users\The Aluminum Falcon\AppData\Local\Minion\" and backup your minion.xml file (rename it to minion.xml_old or similar).

Start Minion 32bit version as administrator and setup Minion normally.
At the top right edge of Minion click on the gear icon and change the addon scan depth to maximum.
Add a new ESO game, manually chose your addons folder for ESO. It MUST be the users folder of your windows account!
Like c:\uers\The Aluminum Falcon\documents\Elder Scrolls Online\live\AddOns

After chosing the folder let minion finish the scan and then close it normally! Do not install or update anything.
Re open Minion and see if it has scanned the folder now properly and shows your addons again.
If not close and reopen a few times until it shows up properly.

Edit:
As you said it takes some time and closing Minion once should also help. Some users reported they needed to open and close it several times. Never had that happen but using it on a SSD so it maybe because of a HDD used (speed advantage with SSD).
But you should remove the not-used ESO games in your Minion now so you do not have it scan and pollute the XML file. You could also close Minion and abckup the XML file, then try my above mentioned steps to get a clean one. If this does not work go back to the backuped XML file (close Minion before again).

Last edited by Baertram : 04/11/20 at 11:36 AM.
  Reply With Quote
04/11/20, 11:37 AM   #3
LucidSeraph
Join Date: Apr 2020
Posts: 2
Hey an update @Baertram

As noted in the edit of my post, it seems that one of the problems may have been that I was running [email protected] in the background, which is a VERY heavy duty CPU and GPU process (basically I'm helping scientists find potential antiretrovirals that might work against the coronavirus and work toward a vaccine by donating my processor cycles ) I think the massive load on my CPU and GPU meant that Minion actually couldn't allocate the resources to finish scans. It's still a little shaky, and I wish Minion didn't act so weird on reinstall, but it's working now. Alas, it'll have to stay on my C drive (the SSD), I think, but at the very least I'm still able to move my other games to the D drive (the HDD).

*edit* I have removed the duplicate ESOs. Everything working fine so far now. Have to finish some other install processes but will do another update once I have a chance to run ESO itself again.

*edit2* I guess since I'm on the subject, just because I really do think it's cool: if anyone reading this thread wants to also contribute to [email protected], go here: https://foldingathome.org/start-folding/

Last edited by LucidSeraph : 04/11/20 at 11:45 AM.
  Reply With Quote
04/12/20, 02:38 PM   #4
Phoenix_Reimagined
Join Date: Apr 2020
Posts: 1
Same problem, and noting spelling mistake

Exact same thing is happening to me - Minion is just stuck on the screen where it asks for my 'AddOn' folder - I keep adding the correct path and it just goes back to the same screen, not adding anything.

Just wondering, but the proper folder name is 'AddOns'. Is this just a minor spelling mistake in the help text or is this a more major error in code?
  Reply With Quote
04/12/20, 05:26 PM   #5
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,204
Just a spelling problem as Minion works fine and you need to choose the folder manually, so it does not matter as long as you choose the "live/AddOns" folder.

Did you increase the folder depth scan settings like described above?
If no addons are found try to close Minion and search + read the minion.log file. It should provide you infos how much Minion did and where it got stuck now (last row at the bottom before "minion closing/exit" or similar).
  Reply With Quote

ESOUI » Site Forums » Minion » Uninstalled and reinstalled Minion; it can't find my ESO AddOns folder now

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off