Quantcast [open] hidden controls cause "too many anchors processed". but only if hidden. - ESOUI
Thread Tools Display Modes
04/23/18, 03:27 PM   #1
Shinni
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 122
[open] hidden controls cause "too many anchors processed". but only if hidden.

When anchoring more than 5000 controls everything works fine, but only as long as they are NOT hidden.
In the following example I anchor 5000 controls. Moving the parent results in a bit of lag since all the children have to be processed, but no error occurs.
Then, when I hide the anchored controls and move the parent control, I suddenly get a "too many anchors processed" error, which is weird because technically no anchor has to be processed for hidden controls, also everything was fine while the controls were still visible.

Example (without any addons active)
Open the map and use the following command
/script numPins = 5000 list = {} for i = 1, numPins do pin, pinKey = ZO_WorldMap_GetPinManager():AcquireObject() list[pinKey] = pin pin:SetLocation(0.5,0.5) end
This creates 5000 (empty) pin controls and via the SetLocation method, they become anchored to ZO_WorldMapContainer.
If you now move the map (dragging it with the mouse), it is a bit laggy, but you get no errors.

Next use the following chat command
/script for pinKey, pin in pairs(list) do pin:GetControl():SetHidden(true) end
Now all controls are hidden and if you move the map, you get a "too many anchors processed" error.
Weirdly enough, if you un-hide the controls, everything works again:
/script for pinKey, pin in pairs(list) do pin:GetControl():SetHidden(false) end
Moving the map now return no errors anymore.

Btw re-pooling the controls doesn't change anything. This weird behaviour depends only on the hidden state.
/script for pinKey in pairs(list) do ZO_WorldMap_GetPinManager():ReleaseObject(pinKey) end
Via this chat command, all the controls are hidden and moved back to the pool.
If you move the map, then you will now get a "too many anchors processed" error again.

I also want to point out that this only happens after ~5000 controls. If fewer controls are anchored and hidden, then no error occurs.

So for some reason you can have only fewer than 5000 hidden controls anchored. However, if they are visible everything is fine??

Last edited by Shinni : 04/23/18 at 03:34 PM.
  Reply With Quote
07/15/18, 01:13 PM   #2
Taonnor
AddOn Author - Click to view addons
Join Date: Nov 2014
Posts: 7
Oh yes i strugled on the same problem at my Addon development. This is a weird problem and should addressed by ZOS. It is a problem for long time, because there is an older thread from 2014 with the same issue!

Actually i work on resolving this by "ClearAnchors" on Control hidden and it is more a workaround than a fix and steal much time.
  Reply With Quote

ESOUI » Developer Discussions » Bug Reports » [open] hidden controls cause "too many anchors processed". but only if hidden.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off