Quantcast 502 Bad Gateway - ESOUI
Thread Tools Display Modes
08/24/19, 06:52 AM   #1
cloudor
 
cloudor's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2014
Posts: 22
502 Bad Gateway

I got the following response from api.esoui.com when I was uploading addon.
Code:
<html>
<head><title>502 Bad Gateway</title></head>
<body bgcolor="white">
<center><h1>502 Bad Gateway</h1></center>
<hr><center>cloudflare</center>
</body>
</html>
It seems api.esoui.com is not very stable.
  Reply With Quote
08/24/19, 04:09 PM   #2
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,191
api.esoui.com is the same server that serves this forum/site so are you getting any 502's browsing the site?

Sounds like our CDN cloudlfare may be having issues with your geolocation? If that is the full error page then its likely an issue with the cloudflare node that is closest to you. Usually there is a transaction id on errors and since there is a lack of that it looks like an issue with their internal network.

Can you visit https://api.esoui.com/cdn-cgi/trace and let me know what 'colo' you are connecting to?

Last edited by Dolby : 08/24/19 at 04:16 PM.
  Reply With Quote
08/26/19, 12:25 AM   #3
cloudor
 
cloudor's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2014
Posts: 22
Originally Posted by Dolby View Post
api.esoui.com is the same server that serves this forum/site so are you getting any 502's browsing the site?

Sounds like our CDN cloudlfare may be having issues with your geolocation? If that is the full error page then its likely an issue with the cloudflare node that is closest to you. Usually there is a transaction id on errors and since there is a lack of that it looks like an issue with their internal network.

Can you visit https://api.esoui.com/cdn-cgi/trace and let me know what 'colo' you are connecting to?
Thank you for your reply. It has turned well later and seems to be good for now.

The reason why I could browse is that I was using a proxy.

I got the following from the trace page (without proxy):
Code:
fl=4f245
h=api.esoui.com
ip=124.64.18.207
ts=1566800711.549
visit_scheme=https
uag=Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.100 Safari/537.36
colo=SJC
http=http/2
loc=CN
tls=TLSv1.3
sni=plaintext
warp=off
  Reply With Quote

ESOUI » Developer Discussions » General Authoring Discussion » 502 Bad Gateway

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off