Quantcast Minion not launching after latest Java update? - ESOUI
Thread Tools Display Modes
04/19/19, 09:19 AM   #1
Davjwx
Join Date: Oct 2017
Posts: 2
Minion not launching after latest Java update?

Hey guys, 2 days ago I got a prompt to update java to the latest version. The next morning when I went to run Minion as I always do before playing ESO nothing happened. Tried it a few more times and still nothing. Then I looked in Task Manager and there were 4 Instances of Minion running, but no windows, no system tray icon, nothing. I figured the java update messed it up so I uninstalled it and installed the previous version that did work. Still nothing.

Today I've tried:

1. Uninstalling and reinstalling Minion.

2. Installing the 32bit version.

3. Tried all compatibility modes and running as admin.

4. Disabling my anti virus and Windows Defender.

It still just shows up in Task Manager and nothing else. Here's my log file, hopefully it helps pinpoint the issue.

Code:
INFO  2019-04-19 11:03:50,985 [JavaFX Application Thread] gg.minion.Minion:start(43): Attempting to start Minion...
INFO  2019-04-19 11:03:51,500 [JavaFX Application Thread] gg.minion.util.ConfigurationManager:loadConfig(1192): Configuration file does not exist.  Creating ...
INFO  2019-04-19 11:03:51,562 [JavaFX Application Thread] gg.minion.Minion:logSystemInformation(127): os.name=Windows 10
INFO  2019-04-19 11:03:51,563 [JavaFX Application Thread] gg.minion.Minion:logSystemInformation(128): os.version=10.0
INFO  2019-04-19 11:03:51,563 [JavaFX Application Thread] gg.minion.Minion:logSystemInformation(129): os.arch=amd64
INFO  2019-04-19 11:03:51,563 [JavaFX Application Thread] gg.minion.Minion:logSystemInformation(130): java.runtime.version=1.8.0_92-b14
INFO  2019-04-19 11:03:51,563 [JavaFX Application Thread] gg.minion.Minion:logSystemInformation(131): java.class.path=C:\Program Files\Minion\app\Minion-jfx.jar;lib/httpclient-4.5.2.jar;lib/httpcore-4.4.4.jar;lib/commons-logging-1.2.jar;lib/commons-codec-1.9.jar;lib/commons-configuration-1.10.jar;lib/commons-lang-2.6.jar;lib/commons-jxpath-1.3.jar;lib/commons-collections-3.2.2.jar;lib/jackson-mapper-asl-1.9.13.jar;lib/jackson-core-asl-1.9.13.jar;lib/junrar-0.7.jar;lib/commons-logging-api-1.1.jar;lib/commons-vfs2-2.0.jar;lib/maven-scm-api-1.4.jar;lib/plexus-utils-1.5.6.jar;lib/maven-scm-provider-svnexe-1.4.jar;lib/maven-scm-provider-svn-commons-1.4.jar;lib/regexp-1.3.jar;lib/kefirbb-1.1.jar;lib/commons-io-2.4.jar;lib/jsr305-3.0.1.jar;lib/junique-1.0.4.jar;lib/jregex-1.2_01.jar;lib/controlsfx-8.40.11.jar;lib/log4j-api-2.6.2.jar;lib/log4j-core-2.6.2.jar
INFO  2019-04-19 11:03:51,564 [JavaFX Application Thread] gg.minion.Minion:logSystemInformation(132): java.library.path=C:\Program Files\Minion\app;C:\Program Files\Minion
INFO  2019-04-19 11:03:51,564 [JavaFX Application Thread] gg.minion.Minion:logSystemInformation(133): user.language=en
INFO  2019-04-19 11:03:51,564 [JavaFX Application Thread] gg.minion.Minion:logSystemInformation(134): user.home=C:\Users\David
DEBUG 2019-04-19 11:03:51,981 [JavaFX Application Thread] gg.minion.controller.MinionController:initWindowControls(504): Controls initialized.
DEBUG 2019-04-19 11:03:51,982 [JavaFX Application Thread] gg.minion.util.FeedClient:checkNetworkConnections(106): Starting network check ...
DEBUG 2019-04-19 11:03:51,983 [JavaFX Application Thread] gg.minion.util.FeedClient:getRoutePlanner(61): System Default Http Proxy.
DEBUG 2019-04-19 11:03:52,113 [Thread-8] gg.minion.util.FeedClient:run(159): Ping Status for http://api.mmoui.com/: 403
DEBUG 2019-04-19 11:03:52,118 [Thread-9] gg.minion.util.FeedClient:run(159): Ping Status for http://cdn.mmoui.com/: 403
  Reply With Quote
04/19/19, 09:57 AM   #2
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,282
It seems the server cannot be pinged. This normally is a problem with your proxy settings or a firewall blocking Minion to communicate.
Maybe related to the java update but I'm not sure how exactly. Add Minion to your firewalls and antivirus whitelist and double check it was added.
Check your system proxy and disable it if it's activated, or check VPN tunnels and don't use them to try if this solves it.
  Reply With Quote
04/19/19, 10:12 PM   #3
Davjwx
Join Date: Oct 2017
Posts: 2
Ok, after more troubleshooting I believe I found the problem.

Nothing in my network settings had changed at all. Further, if I turned on a VPN I could get Minion to launch.

I went to make an update to this thread earlier and suddenly I was getting Captcha requirements and crap from Cloudflare security which apparently ESOUI and MInion.gg use on their webhosting. So the issue seemed IP related so I tried restarting my router and modem. While explaining to my mom the issue Cloudflare was giving me she said she was having problems on her tablet. So now I know the issue is related to my IP and some weird blacklist I got put on. Talking with my ISP tech support now to fix the issue.
  Reply With Quote
04/24/19, 12:22 PM   #4
snowlily64
Join Date: Apr 2019
Posts: 2
Same problem i am having

I have followed all the troubleshooting steps including calling spectrum about my ip address
I have uninstalled and reinstalled minion several times
Made sure i was running the newest java by updating
Turned off my firewall and antivirus
and still all i get is this
any help would be awesome
Attached Files
File Type: log minion.log (12.8 KB, 66 views)
File Type: xml minion.xml (466 Bytes, 25 views)
  Reply With Quote
04/24/19, 03:49 PM   #5
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,282
Ping Status for http://api.mmoui.com/: 403
-> As written above this is related to your IP address and/or firewall/proxy blocking the ping to the minion servers. Or the cloudflare antispam protection of the esoui websites which are blocking you (like written in the post above).
Try to restart your modem and get a new IP if you are able to, or try to use a VPN like the other user said, to check if the connection could be established then.
  Reply With Quote
04/24/19, 06:31 PM   #6
snowlily64
Join Date: Apr 2019
Posts: 2
Welll... i don't think it's my ip address bc it does the same thing on both my laptop and my desktop and they have separate ip addresses...
  Reply With Quote
04/24/19, 09:29 PM   #7
Wheels
AddOn Author - Click to view addons
Join Date: Feb 2017
Posts: 41
Originally Posted by snowlily64 View Post
and they have separate ip addresses...
if they are on the same subnet, then they are sharing an external IP, so the issue would likely still occur.
  Reply With Quote
04/25/19, 04:23 AM   #8
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,282
Originally Posted by snowlily64 View Post
Welll... i don't think it's my ip address bc it does the same thing on both my laptop and my desktop and they have separate ip addresses...
Haha you did not understand the difference between a local network LAN (where your ip addresses are different) and a WAN (internet, where your ISP provides an IP for you).
Both, or all LAN devices got an ip in a range like 10.x.x.x or 192.168.x.x e.g. but they share the external same IP which will be determined from your ISP by your touter device. The internet only communicates with the external IP and the router will share the data to the internal LAN ips then.
  Reply With Quote

ESOUI » Site Forums » Minion » Minion not launching after latest Java update?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off