Quantcast Addon request: Advanced Language Selector - ESOUI
Thread Tools Display Modes
02/12/17, 07:14 AM   #1
lnfinity
AddOn Author - Click to view addons
Join Date: Feb 2017
Posts: 22
Addon request: Advanced Language Selector

As the title already hints, I am looking for a way to play the game in two languages. While I think that english is simply the language a mmo is supposed to be played in, I would like to have a tool that allows me to have my text in english but voices in german so that I don't miss some of the lore.
There are probably a lot of others who would like this feature, too.
  Reply With Quote
02/12/17, 09:54 PM   #2
Dolgubon
 
Dolgubon's Avatar
AddOn Author - Click to view addons
Join Date: Jan 2016
Posts: 340
This is actually a feature of the base game. (though hidden) First you need to download the german client (No idea where to do that tbh tho)

Then when the game is open type /script SetCVar("language.2","en") to change the UI into English. This is used by quite a few addon authors to test localizations for their addons.
  Reply With Quote
02/12/17, 11:02 PM   #3
Ayantir
 
Ayantir's Avatar
AddOn Author - Click to view addons
Join Date: Jul 2014
Posts: 1,022
Search in addons "language" there's at least 3 working addons..
__________________
Obsessive Compulsive Coder

My little french Guild: Cercle de l'Eveil
  Reply With Quote
02/13/17, 02:05 AM   #4
votan
 
votan's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2014
Posts: 494
Originally Posted by Ayantir View Post
Search in addons "language" there's at least 3 working addons..
I think the point is something different: Even if you switch language in-game alot non-UI strings like the chatter dialogs and quest conditions are still german.
This can not be done by an Lua-addon. The question is: Can the game be fooled by replacing the english voice folder with the german files???
__________________
@votan73 (EU - megaserver)
  Reply With Quote
02/13/17, 10:49 AM   #5
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,359
Nope it can't cuz the client will redownload them because of changed hash/md5 sums.
At least I couldn't get it to work.
  Reply With Quote
02/13/17, 10:57 AM   #6
sirinsidiator
 
sirinsidiator's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2014
Posts: 1,270
Wouldn't it work if you installed the german client and just changed the language ingame after you started it?
__________________
Like what I do? Support me on Patreon!
>siri.exe MyAddon
Does your addon work? [y/n] n
There is a typo in there.
  Reply With Quote
02/14/17, 03:05 AM   #7
votan
 
votan's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2014
Posts: 494
Originally Posted by sirinsidiator View Post
Wouldn't it work if you installed the german client and just changed the language ingame after you started it?
If you start the client in German with no other language downloaded, when switch language with one of the addons available and relog, the voices are in German and text is in English.
But if you forget to change language before you quit the game, next time there is no audio.
You have to switch to German, restart and repeat the procedure.

(ok, not done for a long time. Should be verified.)
__________________
@votan73 (EU - megaserver)
  Reply With Quote
02/14/17, 03:16 AM   #8
Ayantir
 
Ayantir's Avatar
AddOn Author - Click to view addons
Join Date: Jul 2014
Posts: 1,022
No, language used for audio and so on is sent by the launcher at startup.

If the patcher is not here, eso.exe use Language.2 lua var stored in file.
__________________
Obsessive Compulsive Coder

My little french Guild: Cercle de l'Eveil
  Reply With Quote
02/14/17, 06:08 AM   #9
sirinsidiator
 
sirinsidiator's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2014
Posts: 1,270
Originally Posted by votan View Post
If you start the client in German with no other language downloaded, when switch language with one of the addons available and relog, the voices are in German and text is in English.
But if you forget to change language before you quit the game, next time there is no audio.
You have to switch to German, restart and repeat the procedure.

(ok, not done for a long time. Should be verified.)
You could set the usersettings.txt to be writeprotected and use an addon that autoswitches the language on first load if it is not the desired one.
__________________
Like what I do? Support me on Patreon!
>siri.exe MyAddon
Does your addon work? [y/n] n
There is a typo in there.
  Reply With Quote
02/14/17, 01:19 PM   #10
lnfinity
AddOn Author - Click to view addons
Join Date: Feb 2017
Posts: 22
Originally Posted by Dolgubon View Post
This is actually a feature of the base game. (though hidden) First you need to download the german client (No idea where to do that tbh tho)

Then when the game is open type /script SetCVar("language.2","en") to change the UI into English. This is used by quite a few addon authors to test localizations for their addons.
Does this actually work? Is there a possibility to get this running permanently without having to type the command in everytime I start? Thanks for the replies so far

PS: I'm pretty sure one can choose the language in the launcher somewhere.
  Reply With Quote
02/14/17, 04:42 PM   #11
Dolgubon
 
Dolgubon's Avatar
AddOn Author - Click to view addons
Join Date: Jan 2016
Posts: 340
This should actually save and work every single time you login as long as you don't change it. You can change it when the game is closed by opening up and modifying the usersettings.txt file.
  Reply With Quote
02/15/17, 03:51 AM   #12
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,359
If you have downloaded the EU and NA server data via the launcher (Press the round wheel at the top right corner -> settings will be shown -> Choose the language from the dropdown) you#re able to play with english or german game data + videos and voices.

Choose the server ingame at the login screen.

Originally Posted by lnfinity View Post
Does this actually work? Is there a possibility to get this running permanently without having to type the command in everytime I start? Thanks for the replies so far

PS: I'm pretty sure one can choose the language in the launcher somewhere.
  Reply With Quote
02/19/17, 07:20 AM   #13
lnfinity
AddOn Author - Click to view addons
Join Date: Feb 2017
Posts: 22
Originally Posted by Dolgubon View Post
This should actually save and work every single time you login as long as you don't change it. You can change it when the game is closed by opening up and modifying the usersettings.txt file.
I just found the time to try this out, it works, thanks a lot!
However, it is weird that some names/texts still appear in german... but I guess I can live with that.
  Reply With Quote
02/20/17, 03:52 PM   #14
lnfinity
AddOn Author - Click to view addons
Join Date: Feb 2017
Posts: 22
Originally Posted by Dolgubon View Post
This should actually save and work every single time you login as long as you don't change it. You can change it when the game is closed by opening up and modifying the usersettings.txt file.
How exactly do I put that command in the usersettings.txt? which part of it? It is not saving after being used ingame :/
Edit: Changing this did not work, texts stay german.

Last edited by lnfinity : 02/20/17 at 04:23 PM.
  Reply With Quote
02/20/17, 09:38 PM   #15
Scootworks
 
Scootworks's Avatar
AddOn Author - Click to view addons
Join Date: Nov 2014
Posts: 244
Originally Posted by lnfinity View Post
How exactly do I put that command in the usersettings.txt? which part of it? It is not saving after being used ingame :/
Edit: Changing this did not work, texts stay german.
__________________
EU Server - SŁĄuGhTerHĜuSe
  Reply With Quote
02/21/17, 04:43 AM   #16
lnfinity
AddOn Author - Click to view addons
Join Date: Feb 2017
Posts: 22
Originally Posted by Scootworks View Post
What is this screenshot supposed to tell me? Yes, I am using that option.
As far as I understood, it is supposed to be used to have german soundfiles, which I want.
My problem is that the text stays german except if I use the command given above every single time after I login.
  Reply With Quote
02/21/17, 07:53 AM   #17
Scootworks
 
Scootworks's Avatar
AddOn Author - Click to view addons
Join Date: Nov 2014
Posts: 244
ok the trick is:
- change language to german in launcher
- close launcher
- edit UserSettings.txt to "en"
- open the game directly without launcher "C:\Program Files (x86)\Zenimax Online\The Elder Scrolls Online\game\client\eso64.exe"

edit: here is a quick video https://www.youtube.com/watch?v=ATHg...ature=youtu.be
__________________
EU Server - SŁĄuGhTerHĜuSe

Last edited by Scootworks : 02/21/17 at 07:57 AM.
  Reply With Quote
02/21/17, 08:32 AM   #18
lnfinity
AddOn Author - Click to view addons
Join Date: Feb 2017
Posts: 22
Originally Posted by Scootworks View Post
ok the trick is:
- change language to german in launcher
- close launcher
- edit UserSettings.txt to "en"
- open the game directly without launcher "C:\Program Files (x86)\Zenimax Online\The Elder Scrolls Online\game\client\eso64.exe"

edit: here is a quick video https://www.youtube.com/watch?v=ATHg...ature=youtu.be
Okay yeah, that did the trick, thanks!
The only thing that I haven't done before was starting the game without launcher.
  Reply With Quote
05/23/17, 04:47 AM   #19
lnfinity
AddOn Author - Click to view addons
Join Date: Feb 2017
Posts: 22
Originally Posted by Scootworks View Post
ok the trick is:
- change language to german in launcher
- close launcher
- edit UserSettings.txt to "en"
- open the game directly without launcher "C:\Program Files (x86)\Zenimax Online\The Elder Scrolls Online\game\client\eso64.exe"

edit: here is a quick video https://www.youtube.com/watch?v=ATHg...ature=youtu.be
This does no longer seem to work, do you know any way to do this in morrowind?
I want to enjoy that sweet lore

Edit: Interestingly using "/script SetCVar("language.2","en")" after starting with launcher set to german does still work.... how can I make this permanent tho? Obviously I did not change anything from the above way you gave me, but it simply doesn't work anymore..

Last edited by lnfinity : 05/23/17 at 05:04 AM.
  Reply With Quote
05/27/17, 12:36 PM   #20
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,359
Maybe use one of the language addons which for the same as the script. Or build yourself an addon (check the esoui wiki in order to learn how to: "Hello World") and simply let it execute this command as the addon loads or event_player_activated is run in your addon.
  Reply With Quote

ESOUI » AddOns » AddOn Search/Requests » Addon request: Advanced Language Selector

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off