Quantcast
Mount summon sound. Can be made quieter? - ESOUI
Thread Tools Display Modes
05/28/20, 01:29 AM   #1
algemes
Join Date: May 2014
Posts: 7
Mount summon sound. Can be made quieter?

When you summon exotic mounts it often accompanied by loud blast!
Try to use any Flame Atronach mount often! If you summon it once – it epic. But when you summon them several time in minute – it become exhausting for ears.

Is there addon for this issue? It concerns not only Flame Atronach mount though.
It shouldn’t be to complicated addon, we already have various mute addons…
  Reply With Quote
05/28/20, 01:34 AM   #2
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,122
Check FCOChangeStuff.

I've added a setting to mute sounds you can choose from a list -> All sounds that are available for addons are listed.
Left available -> rigth muted.

Not sure what the sound name is but you can click them to play them.
And the names are shown, maybe a sound starts with "mount" or got "mount" in there.
  Reply With Quote
05/28/20, 02:05 AM   #3
algemes
Join Date: May 2014
Posts: 7
FCOChangeStuff awesome addon but there is no required sounds on this list.
  Reply With Quote
05/28/20, 02:28 AM   #4
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,122
What do you mean by "there is no required sound on the list"?
There is not the sound which is played as you mount?

Then you cannot change it as these are ALL sounds that the game provides and that can be change via addons, sorry.
  Reply With Quote
05/28/20, 02:44 AM   #5
algemes
Join Date: May 2014
Posts: 7
Yes. There is not the sound which is played as you mount. And each mount have their own sound.

Well, but addons can mute certain dialog voice over. And they are not in the list either.
So maybe not all lost?
  Reply With Quote
05/28/20, 02:58 AM   #6
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,122
There is an event which is raised by the game as you mount. One could mute the total sound for like 2 seconds there I guess. Let me find it...

EVENT_MOUNTED_STATE_CHANGED

I guess it will be too late though! As it fires as the state WAS changed and not before, and the sound is played BEFORE that already as you press the mount key :-(
And one cannot intercept this key press to run code then, sorry.

Edit:
I'll write a few code lines and add it to FCOChangeStuff for a test. Will post you the link here later this day.

Edit2:
Good news, you only seem to hear the whistle as the mount is called and then the event fires so the sound of the mount itsself can be muted as it seems.
Still testing.

Okay it works, standard time muted is 500ms after mounting. If any mount's sound is "longer" you can adopt this up to 10 seconds after mount if you like to.

https://www.esoui.com/downloads/info...angeStuff.html

Last edited by Baertram : 05/28/20 at 04:22 AM.
  Reply With Quote
05/28/20, 06:22 AM   #7
algemes
Join Date: May 2014
Posts: 7
Awesome news! Looking forward to test it!
  Reply With Quote
05/28/20, 06:29 AM   #8
algemes
Join Date: May 2014
Posts: 7
Test it:
1) It work.
2) You need to mute just Effects Volume (this is where those loudnes), not all Volume! ) Music must go on)
3) I guess would be nice option to lower Effects Volume to 10-15, not disabling it. To prevent some weirdness.

Last edited by algemes : 05/28/20 at 06:33 AM.
  Reply With Quote
05/28/20, 08:12 AM   #9
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,122
Yep, good ideas. Changed game to SFX volume and added the slider for the SFX volume "mute" (0 = mute, standard value).
  Reply With Quote
05/28/20, 08:48 AM   #10
algemes
Join Date: May 2014
Posts: 7
Awesome! Work perfectly! Thanks for the quick and high-quality response!

Some weird behaviour tho:
If use volume 0 and mute time 500 - it cancel all mount summon sound.
If use volume >1 you need set mute time 1500+ to cover all sound period.
If use volume 0 and mute time 1 - it enough to mute first blast sound but leave following natural horse neigh (tiger growl etc.).

The last one is best for immersion! ) I like it!
I'd leave it as it is. Because all option is nice)

I test it with 3 different mount with noisy blast sound.
  Reply With Quote
05/28/20, 11:03 AM   #11
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,122
I only have tested it with 2 mounts and it workd with 450ms mute time and sound at 0.
Also tested with sound = 25%, worked as well.

Nopt sure which mounts you got and test it with, I do not own all. Only have like 2 that "are louad" as you mount and these were handled fine with 450ms time. But I also set it to SFX sound = 0 then to mute it in total as I do not need to hear the loud noises at all there
  Reply With Quote
05/28/20, 11:35 AM   #12
Gandamir
Join Date: Feb 2017
Posts: 12
Just saw this

Is this what you are looking for?

https://www.esoui.com/downloads/info...ietMounts.html
  Reply With Quote
05/28/20, 12:49 PM   #13
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,122
Oh did not see this before.

Well, it was released after I had updated FCOChangeStuff to add the mount quiet stuff, so it did not exist before on esoui. I already thought I get old
  Reply With Quote
05/29/20, 02:39 AM   #14
algemes
Join Date: May 2014
Posts: 7
Originally Posted by Gandamir View Post
Not really. Your addon don’t affect the real issue – sound in moment of summoning. Though yours can be useful for people who want to lower footstep sound.
Baertram did exactly what was needed.

Actually there was similar addon from 2017.
https://www.esoui.com/downloads/info...unts.html#info
It lower Effects Volume for all period of time, from moment of mountiong to dismount.
  Reply With Quote

ESOUI » AddOns » AddOn Search/Requests » Mount summon sound. Can be made quieter?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off