Quantcast PlayerProgressBar error - ESOUI
Thread Tools Display Modes
12/18/18, 02:22 PM   #1
wambo
Join Date: Mar 2017
Posts: 10
PlayerProgressBar error

I started getting these regularly, sometimes on login (or reloadui to change addons) sometimes after arriving somewhere (not only by port also by horse/foot)

Do I understand this right, that it is not caused by an addon?

Code:
EsoUI/Ingame/PlayerProgressBar/PlayerProgressBar.lua:477: attempt to index a nil value
stack traceback:
EsoUI/Ingame/PlayerProgressBar/PlayerProgressBar.lua:477: in function 'PlayerProgressBar:GetCurrentInfo'
(tail call): ?
EsoUI/Ingame/PlayerProgressBar/PlayerProgressBar.lua:940: in function 'PlayerProgressBar:Bar_OnMouseEnter'
EsoUI/Ingame/PlayerProgressBar/PlayerProgressBar.lua:972: in function 'ZO_PlayerProgressBar_OnMouseEnter'
ZO_PlayerProgressBar_MouseEnter:3: in function '(main chunk)'
  Reply With Quote
12/18/18, 02:50 PM   #2
sirinsidiator
 
sirinsidiator's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2014
Posts: 1,282
I moved it to a different thread since the bug in the other one is already fixed and this seems unrelated.
Have you tried to turn off all addons? Does it still happen then?
__________________
Like what I do? Support me on Patreon!
>siri.exe MyAddon
Does your addon work? [y/n] n
There is a typo in there.
  Reply With Quote
12/18/18, 03:01 PM   #3
votan
 
votan's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2014
Posts: 496
Originally Posted by wambo View Post
I started getting these regularly, sometimes on login (or reloadui to change addons) sometimes after arriving somewhere (not only by port also by horse/foot)

Do I understand this right, that it is not caused by an addon?

Code:
EsoUI/Ingame/PlayerProgressBar/PlayerProgressBar.lua:477: attempt to index a nil value
stack traceback:
EsoUI/Ingame/PlayerProgressBar/PlayerProgressBar.lua:477: in function 'PlayerProgressBar:GetCurrentInfo'
(tail call): ?
EsoUI/Ingame/PlayerProgressBar/PlayerProgressBar.lua:940: in function 'PlayerProgressBar:Bar_OnMouseEnter'
EsoUI/Ingame/PlayerProgressBar/PlayerProgressBar.lua:972: in function 'ZO_PlayerProgressBar_OnMouseEnter'
ZO_PlayerProgressBar_MouseEnter:3: in function '(main chunk)'
Where is your progressbar and where did you left your mouse pointer when it happend?
__________________
@votan73 (EU - megaserver)
  Reply With Quote
12/18/18, 05:19 PM   #4
wambo
Join Date: Mar 2017
Posts: 10
I cant remember ever moving my progress bar.
So still upper left corner.

Cant really say whether I moved my mouse pointer. This time it popped up after I ported to Kynesgrove for the new life dailies, and I think it popped up when I was close to the pavillon.

-> I just got the error again, by only going into cursor mode and moving it to where the progress bar usually is (wasnt visible at this time)


With no addons enabled, I couldnt recreate it.But I also couldnt recreate it with different sets of addons enabled....
So I probably have to gain some XP to recreate it? Or maybe a relog... noot sure.
  Reply With Quote
12/19/18, 07:05 AM   #5
votan
 
votan's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2014
Posts: 496
Originally Posted by wambo View Post
I cant remember ever moving my progress bar.
So still upper left corner.

Cant really say whether I moved my mouse pointer. This time it popped up after I ported to Kynesgrove for the new life dailies, and I think it popped up when I was close to the pavillon.

-> I just got the error again, by only going into cursor mode and moving it to where the progress bar usually is (wasnt visible at this time)


With no addons enabled, I couldnt recreate it.But I also couldnt recreate it with different sets of addons enabled....
So I probably have to gain some XP to recreate it? Or maybe a relog... not sure.
Last time it had to do with closing the scene (e.g. crafting station) while XP gain animation is running.

This should be fixed, but maybe there is a left-over.
__________________
@votan73 (EU - megaserver)
  Reply With Quote

ESOUI » General Discussion » Tech Chat » PlayerProgressBar error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off