Quantcast Why do we have to allow outdated addon when all addons are updated ? - ESOUI
Thread Tools Display Modes
08/12/19, 10:54 AM   #1
Anceane
 
Anceane's Avatar
Join Date: Feb 2014
Posts: 207
Why do we have to allow outdated addon when all addons are updated ?

I was very surprised this morning, logging into the game, to find out that the last updated version of https://www.esoui.com/downloads/info...fter.html#info updated on 08/12/19 12:00 AM, was considered by the game as non existant.

The addon was red and the message was : you need the addon ..... (to say the least the message is pretty unclear about what to do)

After some verification of the addon, i decided to check the allow outdated addon .... and that was it ??

So actually even the very last updated addons are flagged as outdated ?

I am basically lost on how this works now, could you explain me please ?
__________________
  Reply With Quote
08/12/19, 11:01 AM   #2
sirinsidiator
 
sirinsidiator's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2014
Posts: 1,263
The game has no way to actually know if an addon is properly running in the latest update. It simply compares a number contained in the addon to a number contained in the game client. If they are not equal it will show the message and refuse to load the addon unless you check the allow outdated addons checkbox.

The number in the addon has to be changed manually by the author each time. Some forget to change it when they upload a new version, some simply won't do an update when the addon is still working and only the number would need to be changed.

The checkbox simply skips this check and loads the addon regardless, which offers the same result as changing the number in the txt file manually for each addon.
__________________
Like what I do? Support me on Patreon!
>siri.exe MyAddon
Does your addon work? [y/n] n
There is a typo in there.
  Reply With Quote
08/12/19, 11:05 AM   #3
Anceane
 
Anceane's Avatar
Join Date: Feb 2014
Posts: 207
Originally Posted by sirinsidiator View Post
The game has no way to actually know if an addon is properly running in the latest update. It simply compares a number contained in the addon to a number contained in the game client. If they are not equal it will show the message and refuse to load the addon unless you check the allow outdated addons checkbox.

The number in the addon has to be changed manually by the author each time. Some forget to change it when they upload a new version, some simply won't do an update when the addon is still working and only the number would need to be changed.

The checkbox simply skips this check and loads the addon regardless, which offers the same result as changing the number in the txt file manually for each addon.

Thank you! totally understood. But may be ZOS could change the message because You need the addon is pretty disturbing when you have the addon showing and present.
__________________
  Reply With Quote
08/12/19, 11:07 AM   #4
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,274
Not ALL addons are updated and even then the number in the txt file ## APIVersion: could be still the old one as one forget to increase or change it.

The checkbox ingame will always be unchecked after a major patch and thus all addons which are now "considered outdated by the game client" are ddisabled due to this.
Some addons already got an entry ## APIVersion: <currentApiVersion> <nextAPIversion>
so they appear to be updated (but their code could still be from 3 patches before and not running at all ).

The game is just checking numbers like Sirinsidator wrote already.
So just enable the checkbox and play. 1 click, no problems.
Or if you want to support the checbox and this nonsense check just change ALL addons you'd like to use in their txt file and put the correct ## APIVersion: 100028
for Scalebreaker in

Edit:
the message because You need the addon is pretty disturbing
Sounds weird. Never saw it so far. Will uncheck the checkbox and see myself

For me it only shows:
Outdated, Dependencies
And if there are dependencies you can expand the addon and see below:
White line (activated)
Red line (deactivated)

Where did you see this message?

Last edited by Baertram : 08/12/19 at 11:11 AM.
  Reply With Quote
08/12/19, 01:28 PM   #5
Anceane
 
Anceane's Avatar
Join Date: Feb 2014
Posts: 207
When i logged in, after hearing the sound error, i checked the addon list and the only one with problem was Dolgubon lazy crafter ... all red. When i moused over it, there was a tooltip saying : you need the addon

I was uh oh i have the addon ... and i checked, the addon is up to date.

## Title: Dolgubon's Lazy Writ Creator
## APIVersion: 100028
## Author: Dolgubon
## Version: 2.7.6

So could that error come from a library used by the addon and not up to date ?


And to be honnest, i did exactly what you said this morning before the patch. I replaced

## APIVersion: 100026 100027
or
## APIVersion: 100027
or
## APIVersion: 100027 100028 100029


par ## APIVersion: 100028

But i did not updated the addons that went updated last night by their authors like Dolgubon

Originally Posted by Baertram View Post
Not ALL addons are updated and even then the number in the txt file ## APIVersion: could be still the old one as one forget to increase or change it.

The checkbox ingame will always be unchecked after a major patch and thus all addons which are now "considered outdated by the game client" are ddisabled due to this.
Some addons already got an entry ## APIVersion: <currentApiVersion> <nextAPIversion>
so they appear to be updated (but their code could still be from 3 patches before and not running at all ).

The game is just checking numbers like Sirinsidator wrote already.
So just enable the checkbox and play. 1 click, no problems.
Or if you want to support the checbox and this nonsense check just change ALL addons you'd like to use in their txt file and put the correct ## APIVersion: 100028
for Scalebreaker in

Edit:

Sounds weird. Never saw it so far. Will uncheck the checkbox and see myself

For me it only shows:
Outdated, Dependencies
And if there are dependencies you can expand the addon and see below:
White line (activated)
Red line (deactivated)

Where did you see this message?
__________________

Last edited by Anceane : 08/12/19 at 01:31 PM.
  Reply With Quote
08/12/19, 01:53 PM   #6
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,274
Was the tooltip at the right colum of the addon manager list, with a yellow or red icon where you hovered the mouse over?
This is Votans Addon List then. Maybe the text is coming from this addon then.
  Reply With Quote
08/12/19, 01:57 PM   #7
Anceane
 
Anceane's Avatar
Join Date: Feb 2014
Posts: 207
Originally Posted by Baertram View Post
Was the tooltip at the right colum of the addon manager list, with a yellow or red icon where you hovered the mouse over?
This is Votans Addon List then. Maybe the text is coming from this addon then.
Ah ok then the addon may need a little update :P as they were other information

Thank you
__________________
  Reply With Quote

ESOUI » AddOns » AddOn Help/Support » Why do we have to allow outdated addon when all addons are updated ?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off