Quantcast
Minion on Linux - ESOUI
Thread Tools Display Modes
04/30/19, 07:06 PM   #1
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,214
This is how I was able to install the oracle jdk8 on Pop!_os (since the oracle java ppa is no longer available due to license changes) but should work on most up to date distro's out there.
  • Register for a free Oracle account and download the latest JDK8 tar.gz(jdk-8u211-linux-x64.tar.gz).
  • Download these bash scripts and follow the simple directions to install jdk8 from the tar.gz file you downloaded.
  • Check if java -version shows the correct version:
    Code:
    [email protected]:~/Downloads/Minion$ java -version
    java version "1.8.0_211"
    Java(TM) SE Runtime Environment (build 1.8.0_211-b12)
    Java HotSpot(TM) 64-Bit Server VM (build 25.211-b12, mixed mode)
  • Download the Minion jar from minion.gg and extract the zip into location and folder of your choice.
  • Now run java -jar Minion-jfx.jar in the folder you extracted the zip to
    Code:
    [email protected]:~/Downloads/Minion$ java -jar Minion-jfx.jar
  • Choose to update Minion and restart. (It won't restart)
  • Before you start minion we need to apply the patch manually. Navigate to the folder you are running minion from and you should see a new folder named "null" grab the Minion-jfx.jar from there and copy over the old Minion-jfx.jar in the parent directory.
  • now start minion again java -jar Minion-jfx.jar and it should work like mine...
Attached Thumbnails
Click image for larger version

Name:	Screenshot from 2019-04-30 19-53-55.png
Views:	1378
Size:	909.7 KB
ID:	1117  

Last edited by Dolby : 04/30/19 at 07:38 PM.
  Reply With Quote
05/05/19, 04:41 PM   #2
maxheadroom2000
Join Date: Sep 2018
Posts: 4
Minion Lives!

Finally, a usable set of instructions that work! You are a saint.

I am using these instructions with the Steam version of ESO on Linux Mint, and it is working perfectly.

For those that are doing the same, and have no idea where to find the AddOns folder, it is buried in a somewhat weird place. Try turning on "Show hidden files" and look for someplace like this:
~/.steam/steam/steamapps/compatdata/306130/pfx/drive_c/users/steamuser/My Documents/Elder Scrolls Online/live/AddOns

See you in Tamriel!
  Reply With Quote
05/17/19, 07:31 AM   #3
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,214
This is a guide by VERNSTOKED to install Minion with Lutris

https://www.esoui.com/forums/showpos...92&postcount=6
  Reply With Quote
05/20/19, 07:19 PM   #4
calvin.scones
Join Date: May 2019
Posts: 1
Java Error

I followed the instructions here, but I am getting an error at running java -jar Minion-jfx.jar

X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 151 (GLX)
Minor opcode of failed request: 24 (X_GLXCreateNewContext)
Value in failed request: 0x0
Serial number of failed request: 29
Current serial number in output stream: 30

I verified that java is the right version, and tried 8u212 as well

--------------------------------------------------------------------------------------------------
EDIT

Simple reboot fixed this

For anyone finding this post later the issue was that Manjaro/arch uses openJDK, and using:
"archlinux-java set <JRE version>"
fixes the issue, but will error out until after a reboot


Feel free to remove this post if you want since this is a sticky.

Last edited by calvin.scones : 05/20/19 at 07:31 PM.
  Reply With Quote
08/16/19, 01:20 PM   #5
ettavolt
Join Date: Sep 2014
Posts: 10
You don't need JRE/JDK from Oracle speicifically, OpenJDK has no difference (but freer license).
Though not all distros provide OpenJFX 8. For Ubuntu-based a possible solution is outlined here: https://bugs.launchpad.net/ubuntu/+s...x/+bug/1799946

To run on JDK+JFX 11 Minion will need be converted to modules, it seems. At least that the error I got from trying to launch it in this setup.

Instead of changing the default JDK as calvin.scones suggests, one may simply run
Code:
/usr/lib/jvm/java-8-openjdk/bin/java -jar Minion-jfx.jar
  Reply With Quote
09/09/19, 11:55 AM   #6
Techwolf
 
Techwolf's Avatar
Join Date: Aug 2018
Posts: 5
Just found this thread. I will add my two cents. :-D

I run minion from the command line. What I ended up doing a year and half ago was installed Oracle version 9.0.4 of java as the open source version did not work graphics wise. It did ran, but the UI was all messed up.

My OS is gentoo and CPU is currently Threadripper.

I installed Oracle java using the guild from the wiki: https://wiki.gentoo.org/wiki/Java

I su to the steam user. I use a different user from the main to keep things seperate as games have a bad habit of doing things the users does not want. So running a seperate user is recommended on Linux systems.

Manually download the .jar and place in ".wine_Tamriel/drive_c/users/steam/Local Settings/Application Data/Minion/app/" Note on my sytem, I installed it using the .exe and hence why the full path to the normal install. It was later I found the GUI bugs.

I did not set the system wide java as I wanted the default java to be not oracle, so my command line is:

Code:
[email protected] ~ $ /opt/oracle-jre-bin-9.0.4/bin/java -jar ".wine_ESO/drive_c/users/steam/Local Settings/Application Data/Minion/app/Minion-jfx.jar"
Getting minion to find the right place for the addons was tricky and I forgot how I did it. See previous posts for tips on getting minion to find the right place where the addons should be.

I have been running minion like that for over year with only one issue, you must update from the first window, using the update button from sub-windows will not work. Example is clicking on the addon and reading the change log and updateing from there does not work.

Update: Gentoo removed oracle bin version 9.0.4 for security issues. So one may have to manually install version 9.04. Will be testing other versions.

Update 2:
Tested oracle version 1.8.0.202: works
Tested icedtea version 3.13.0: failed with "Error: Could not find or load main class gg.minion.Minion"
Tested openjdk version 11.0.4: failed with "Error: Could not find or load main class gg.minion.Minion
Caused by: java.lang.NoClassDefFoundError: javafx/application/Application"

Update 3: I revisited this issue and found out the root cause of the error was missing openjfx from openjdk. Search for and install the openjfx package for the distro. For gentoo system, enable and openjfx USE flag and re-emerge openjdk. Got past the error but gets stuck at init. Can get to settings and so on, but the black popup will not go away. Can close the program normally.

Last edited by Techwolf : 06/21/21 at 11:24 PM. Reason: Added one fix for the error
  Reply With Quote
09/09/19, 03:17 PM   #7
FIGBird
Join Date: Sep 2019
Posts: 2
The issue I run into with the JAR version is as follows:

java.lang.NoClassDefFoundError: it/sauronsoftware/junique/AlreadyLockedException


I have attempted a few different java versions. I am not entirely sure where the error is, but that looks like a unit testing framework which suggests it is an issue with the JAR file itself. I can post the whole stack if needed.

For reference here is the output from java -version after the bash scripts were used on the originally suggested oracle file.

java version "1.8.0_221"
Java(TM) SE Runtime Environment (build 1.8.0_221-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.221-b11, mixed mode)
  Reply With Quote
09/09/19, 10:31 PM   #8
Baertram
Super Moderator
 
Baertram's Avatar
WoWInterface Super Mod
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,717
Seems the class it.sauronsoftware.junique.AlreadyLockedException is missing in the jar file, or a jar dependency is missing in the classpath entry of the jar's manifest.
Weird it is working for some and not for others.
Maybe they have the same class somewhere else in there environment variables and you could download it somewhere and add it as well to yours, so it's "globally" known for all jar files?
  Reply With Quote
09/10/19, 05:02 AM   #9
sirinsidiator
 
sirinsidiator's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2014
Posts: 1,487
Sounds more like you are either missing the lib folder accompanying the Minion-jfx.jar or it is not found on the classpath for some reason. You could try to specify it manually like so:
Code:
java -cp .;lib -jar Minion-jfx.jar
__________________
https://www.imperialtradingcompany.eu/ - My Addons - The Vault (Early updates and experimental projects) - My patreon - My blog
>siri.exe MyAddon
Does your addon work? [y/n] n
There is a typo in there.
  Reply With Quote
09/10/19, 03:29 PM   #10
FIGBird
Join Date: Sep 2019
Posts: 2
My face is a little red at the moment. I somehow managed to extract only the JAR file and missed the lib folder. Works like a charm as soon as I have the dependencies...
  Reply With Quote
01/08/20, 07:00 AM   #11
Tar000un
 
Tar000un's Avatar
AddOn Author - Click to view addons
Join Date: May 2014
Posts: 47
I m running Minion from Lutris as I got the java error and didn't want to dig too long.

But I tilted on :
Originally Posted by ettavolt View Post
To run on JDK+JFX 11 Minion will need be converted to modules, it seems. At least that the error I got from trying to launch it in this setup.
So I tried more longer and I got this "working" :
Code:
wget https://download2.gluonhq.com/openjfx/11.0.2/openjfx-11.0.2_linux-x64_bin-sdk.zip -O /tmp/openjfx-11.0.2_linux-x64_bin-sdk.zip
unzip /tmp/openjfx-11.0.2_linux-x64_bin-sdk.zip -d /tmp/
java --module-path="/tmp/javafx-sdk-11.0.2/lib/" --add-modules=javafx.swing,javafx.graphics,javafx.fxml,javafx.media,javafx.web \
  --add-reads javafx.graphics=ALL-UNNAMED \
  --add-opens javafx.controls/com.sun.javafx.charts=ALL-UNNAMED \
  --add-opens javafx.graphics/com.sun.javafx.iio=ALL-UNNAMED \
  --add-opens javafx.graphics/com.sun.javafx.iio.common=ALL-UNNAMED \
  --add-opens javafx.graphics/com.sun.javafx.css=ALL-UNNAMED \
  --add-opens javafx.base/com.sun.javafx.runtime=ALL-UNNAMED \
-jar Minion-jfx.jar

But addons are not listed after I pointed to the addOns dir.

Getting a lot of :
Code:
DEBUG 2020-01-08 13:56:19,947 [Thread-9] gg.minion.service.AddOnDetectionService:interrogateDirs(354): PotionMaker - TOC Version: 5.7.9
DEBUG 2020-01-08 13:56:19,947 [Thread-9] gg.minion.service.AddOnDetectionService:detectAddOn(268): No addons match PotionMaker
How do you "convert as module" ?
__________________
EU member
  Reply With Quote
01/08/20, 08:19 AM   #12
Baertram
Super Moderator
 
Baertram's Avatar
WoWInterface Super Mod
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,717
Minion got some settings at the top right UI corner where you can change the addon directory scan depth. Sometimes increasing this helps.

I can not speak for Unix, only for the Windows versions:
-Use 32bit version even on 64bit OS
-Start as admin to give it access to the user directory
-Allow the minion directory and elder scrolls online directory access (whitelist/exclusion list) in Antivirus/Firewalls

Maybe this helps you for Unix as wlel somehow

You could also try to stop minion, rename/delete the Minion.xml file!
Then go to your AddOns directory. Remove all addons (move them elsewhere).

Start minion, point to the addon dir.
Download a few addons new.
Close Minion.
Move/Copy the other addons into the AddOns directory again but do not overwrite any files.

Start minion again and check if it scans and updates properly now.
  Reply With Quote
01/10/20, 02:28 AM   #13
Tar000un
 
Tar000un's Avatar
AddOn Author - Click to view addons
Join Date: May 2014
Posts: 47
I recently changed the depth, lowering it. But I tried raising with theses values:
- Concurrent downloads: 4
- Game Scan Depth: 3

Still getting the issue. I can't find "more addon" to download and install a new addon.

I would like to highlight an issue in your list.
Originally Posted by Baertram View Post
-Start as admin to give it access to the user directory
Running a bin as admin (ie root) is very unsafe.


Instead running as admin, you have to set the proper ACL.
Even largely permissive ACL still better than giving root access to an app.
__________________
EU member

Last edited by Tar000un : 01/10/20 at 02:37 AM.
  Reply With Quote
01/10/20, 08:54 AM   #14
Baertram
Super Moderator
 
Baertram's Avatar
WoWInterface Super Mod
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,717
Okay, thanks. As I said the admin info was for a Windows system
  Reply With Quote
06/16/20, 10:56 PM   #15
ettavolt
Join Date: Sep 2014
Posts: 10
Managed to run Minion on OpenJDK 14 with
Code:
java --module-path=/usr/lib/jvm/default/lib/javafx.web.jar:/usr/lib/jvm/default/lib/javafx.graphics.jar:/usr/lib/jvm/default/lib/javafx.base.jar:/usr/lib/jvm/default/lib/javafx.swing.jar:/usr/lib/jvm/default/lib/javafx.fxml.jar:/usr/lib/jvm/default/lib/javafx.controls.jar:/usr/lib/jvm/default/lib/javafx-swt.jar:/usr/lib/jvm/default/lib/javafx.media.jar --add-modules=javafx.swing,javafx.graphics,javafx.fxml,javafx.media,javafx.web \
  --add-reads javafx.graphics=ALL-UNNAMED \
  --add-opens javafx.controls/com.sun.javafx.charts=ALL-UNNAMED \
  --add-opens javafx.graphics/com.sun.javafx.iio=ALL-UNNAMED \
  --add-opens javafx.graphics/com.sun.javafx.iio.common=ALL-UNNAMED \
  --add-opens javafx.graphics/com.sun.javafx.css=ALL-UNNAMED \
  --add-opens javafx.graphics/javafx.scene.image=ALL-UNNAMED\
  --add-opens javafx.base/com.sun.javafx.runtime=ALL-UNNAMED \
-jar Minion-jfx.jar
If you happen to have no /usr/lib/jvm/default/lib/jrt-fs.jar, you might be able to run with just --module-path=/usr/lib/jvm/default/lib/
  Reply With Quote
01/15/21, 07:24 PM   #16
Lizzi's Bow
Join Date: Nov 2019
Posts: 6
Why doesn't this work?

/usr/java/jre1.8.0_271/bin/java -jar "/home/lizzias/Downloads/Minion3.0.5-java/Minion-jfx.jar"

download java 8 from here:

https://www.java.com/en/download/

easy install follow these instructions:

Change to the directory in which you want to install. Type:
cd directory_path_name
For example, to install the software in the /usr/java/ directory, Type:
cd /usr/java/

Move the .tar.gz archive binary to the current directory.
Unpack the tarball and install Java
tar zxvf jre-8u73-linux-x64.tar.gz

The Java files are installed in a directory called jre1.8.0_73 in the current directory. In this example, it is installed in the /usr/java/jre1.8.0_73 directory. When the installation has completed, you will see the word Done.
Delete the .tar.gz file if you want to save disk space.

Last edited by Lizzi's Bow : 01/15/21 at 07:51 PM.
  Reply With Quote
04/27/21, 05:53 PM   #17
thelonghop
Join Date: May 2014
Posts: 1
Originally Posted by Dolby View Post
This is how I was able to install the oracle jdk8 on Pop!_os (since the oracle java ppa is no longer available due to license changes) but should work on most up to date distro's out there.
  • Register for a free Oracle account and download the latest JDK8 tar.gz(jdk-8u211-linux-x64.tar.gz).
  • Download these bash scripts and follow the simple directions to install jdk8 from the tar.gz file you downloaded.
  • Check if java -version shows the correct version:
    Code:
    [email protected]:~/Downloads/Minion$ java -version
    java version "1.8.0_211"
    Java(TM) SE Runtime Environment (build 1.8.0_211-b12)
    Java HotSpot(TM) 64-Bit Server VM (build 25.211-b12, mixed mode)
  • Download the Minion jar from minion.gg and extract the zip into location and folder of your choice.
  • Now run java -jar Minion-jfx.jar in the folder you extracted the zip to
    Code:
    [email protected]:~/Downloads/Minion$ java -jar Minion-jfx.jar
  • Choose to update Minion and restart. (It won't restart)
  • Before you start minion we need to apply the patch manually. Navigate to the folder you are running minion from and you should see a new folder named "null" grab the Minion-jfx.jar from there and copy over the old Minion-jfx.jar in the parent directory.
  • now start minion again java -jar Minion-jfx.jar and it should work like mine...
Could we possibly get a Read Me or current instructions to install the Java version of Minion, specifically for Linux? Or using current Java versions?
  Reply With Quote
04/28/21, 02:30 AM   #18
Baertram
Super Moderator
 
Baertram's Avatar
WoWInterface Super Mod
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,717
Readme = first post by Dolby (which you have quoted already). What is missing?
Additional info = other posts, like other Linux versions, Steam, etc.
  Reply With Quote
06/10/21, 10:59 PM   #19
Faulon
Join Date: Aug 2016
Posts: 3
What am I missing here?

Okay so ive been following instructions on installing java and what not, currently running the most up to date version of java

openjdk version "1.8.0_292"
OpenJDK Runtime Environment (build 1.8.0_292-8u292-b10-0ubuntu1~20.10-b10)
OpenJDK 64-Bit Server VM (build 25.292-b10, mixed mode)

now when I try and run java -jar Minion-jfx.jar it gives me the following error

Error: Could not find or load main class gg.minion.Minion

I read another post, but the individual was running a version of java not supported. So that would make sense, but I am running the version i thought was compatible with Minion 3.0.5.

I am currently updating ESO so I can't do a system restart just yet to see if that may fix the issue. But I will try a reboot after its completed.

Last edited by Faulon : 06/10/21 at 11:48 PM.
  Reply With Quote
06/11/21, 01:52 AM   #20
Baertram
Super Moderator
 
Baertram's Avatar
WoWInterface Super Mod
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,717
Others having a similar issue had either a corrupt download of the jar containing file, or at least missing subfolders of that downloaded file (like the libs folder).
Try to validate it's the full file and you have extracted all properly.
  Reply With Quote

ESOUI » Site Forums » Minion » Minion on Linux

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off