Quantcast
[notabug] GetOufitName(index) is not working - ESOUI
Thread Tools Display Modes
06/03/21, 01:16 PM   #1
Jodynn
 
Jodynn's Avatar
AddOn Author - Click to view addons
Join Date: Aug 2018
Posts: 2
[notabug] GetOufitName(index) is not working

Always returns an empty string
 
06/03/21, 01:19 PM   #2
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 3,597
This is not a bug but the outfit parameters of nearly all functions changed:

Most outfit functions need an actor parameter now as outfits can be used on the player and the companion!

Always make sure you check the "most up2date" API functions file linked at the Wiki for the current game version:
https://wiki.esoui.com/APIVersion#live_API_version
-> The link at "API TXT Documentation"

Open the txt file and search for the function, and check the parameters and values needed

Lua Code:
  1. * GetOutfitName(*[GameplayActorCategory|#GameplayActorCategory]* _actorCategory_, *luaindex* _outfitIndex_)
  2. ** _Returns:_ *string* _name_

Make sure to check all outfit API functions and usages of ZO_OUTFIT_MANAGER (like function EquipOutfit) etc. for the first parameter GameplayActorCategory now. Possible values are:
Code:
h5. GameplayActorCategory
* GAMEPLAY_ACTOR_CATEGORY_COMPANION
* GAMEPLAY_ACTOR_CATEGORY_PLAYER

Last edited by Baertram : 06/03/21 at 01:23 PM.
 
06/08/21, 10:33 AM   #3
Jodynn
 
Jodynn's Avatar
AddOn Author - Click to view addons
Join Date: Aug 2018
Posts: 2
Thank you very much, I thought I did click that one but I guess I didn't!
 

ESOUI » Developer Discussions » Bug Reports » [notabug] GetOufitName(index) is not working

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off