Quantcast Ainsi - Utf-8 - ESOUI
Thread Tools Display Modes
10/21/19, 10:31 AM   #1
Anceane
 
Anceane's Avatar
Join Date: Feb 2014
Posts: 251
Ainsi - Utf-8

Since this morning, for a lot of addons updated, if i open the .txt file to check the necessary libraries, there is message File encoding error.

It appears that the files are encoded AINSI, and some special characters dont work for me in that format

The Elder Scrolls *utf-8 works fine for me* but if this is in AINSI suddenly its shows an error

What do i need to change on my Notepad++ or even computer to correct this ?

(i guess the game accept both method of AINSI and UTF reason why some authors do this differently)

Thank you

(in case, my keyboard is Canadian Multilingual french keyboard - QWERTY (my computer in English USA, and my game is english too)
__________________
  Reply With Quote
10/21/19, 10:37 AM   #2
Rhyono
AddOn Author - Click to view addons
Join Date: Sep 2016
Posts: 561
ANSI is default for Windows in English. Any file that has special characters should not have been saved as ANSI in the first place. Give an example of an addon file that isn't working correctly.
  Reply With Quote
10/21/19, 10:42 AM   #3
Anceane
 
Anceane's Avatar
Join Date: Feb 2014
Posts: 251
Originally Posted by Rhyono View Post
ANSI is default for Windows in English. Any file that has special characters should not have been saved as ANSI in the first place. Give an example of an addon file that isn't working correctly.

All Votan's addons recently updated beside 2 of them (Votan Minimap is UTF-8 and MapPinsColor is UTF-8) all others from the last update are in AINSI.
__________________
  Reply With Quote
10/21/19, 10:46 AM   #4
Rhyono
AddOn Author - Click to view addons
Join Date: Sep 2016
Posts: 561
The only files that need to be UTF8 are the ones with special characters.

Using Votan's Search Box as an example:
His French lang file is UTF8
His addon.txt file is ANSI

This is acceptable. I did not see any issues with it.
  Reply With Quote
10/21/19, 10:49 AM   #5
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,533
If the txt file contains Umlauts etc. it needs to be utf-89 but WITHOUT the byteorder mark (BOM) or the game will not show the umlauts. If the file is utf-8 WITH BOM it won't load properly so remove the BOM with notepad++ please if you see it.
SAme counts for the lua files. If contents are written in text like "Hello Brtram" the won't be shown ingame properly if the file is ANSI only, so it needs to be UTF-8 e.g.

MAybe some descriptions have changed in Votan's files or he changes his editor and this one uses UTF-8 as standard now. It's just the encoding of the file, nothing special. Ignore it in your editor, shouldn't make any difference.
The only problem can be the byterorder mark (BOM) as I said. If this is set to the files they cannot load properly ingaem into the addon manager (they sometimes do, sometimes don't) and you should tell Votan to remove them from his files with UTF-8.
  Reply With Quote
10/21/19, 10:50 AM   #6
Anceane
 
Anceane's Avatar
Join Date: Feb 2014
Posts: 251
Originally Posted by Rhyono View Post
The only files that need to be UTF8 are the ones with special characters.

Using Votan's Search Box as an example:
His French lang file is UTF8
His addon.txt file is ANSI

This is acceptable. I did not see any issues with it.
oh I dont say he did something wrong at all far from it.
I just asked why i have this error on my computer when i open the addon.txt file in Notepad++. I never had this issue before, so i wonder if something is wrong.

And i dont use the french lang at all only english
__________________
  Reply With Quote
10/21/19, 10:58 AM   #7
Anceane
 
Anceane's Avatar
Join Date: Feb 2014
Posts: 251
Originally Posted by Baertram View Post
If the txt file contains Umlauts etc. it needs to be utf-89 but WITHOUT the byteorder mark (BOM) or the game will not show the umlauts. If the file is utf-8 WITH BOM it won't load properly so remove the BOM with notepad++ please if you see it.
SAme counts for the lua files. If contents are written in text like "Hello Brtram" the won't be shown ingame properly if the file is ANSI only, so it needs to be UTF-8 e.g.

MAybe some descriptions have changed in Votan's files or he changes his editor and this one uses UTF-8 as standard now. It's just the encoding of the file, nothing special. Ignore it in your editor, shouldn't make any difference.
The only problem can be the byterorder mark (BOM) as I said. If this is set to the files they cannot load properly ingaem into the addon manager (they sometimes do, sometimes don't) and you should tell Votan to remove them from his files with UTF-8.

Actually there was only a probleme with the trademark and ' signs, as far as i could say.
I did not opened the.LUA files at all but only the addon.txt to check if i had all the good libraries for each addon.

For this i used my notepad++ which is opening the files it seems directly in UTF-8 and thus showing an error for the file that was created in AINSI. That is what i think i just understood.

I do not say that Votan did something wrong. I thought the error was on MY SIDE computer.

I guess i can just ignore the error from now.

Thank you all
__________________
  Reply With Quote
10/21/19, 10:59 AM   #8
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,533
It's all about the files and your Notepad++ settings I guess.
If you create a file with Notepad++ and the standard encoding will be UTF-8 without bom, you won't notice any messages if this would be your Notepad++ standard setting for file encoding.
If the file encoding settings in Notepad++ is set to ANSI instead and you open files with another encoding, it wil lshow you such an information and maybe also provides options to change it (which I wouldn't do then if you got no error messages ingame).
  Reply With Quote
10/21/19, 11:05 AM   #9
Anceane
 
Anceane's Avatar
Join Date: Feb 2014
Posts: 251
Originally Posted by Baertram View Post
It's all about the files and your Notepad++ settings I guess.
If you create a file with Notepad++ and the standard encoding will be UTF-8 without bom, you won't notice any messages if this would be your Notepad++ standard setting for file encoding.
If the file encoding settings in Notepad++ is set to ANSI instead and you open files with another encoding, it wil lshow you such an information and maybe also provides options to change it (which I wouldn't do then if you got no error messages ingame).
K this time i understand what is happening.

- my notepad++ is set to open with UTF-8 (without BOM) anytime
- the .txt files from Votan are all in AINSI, so my notepad shows an error for the lines where a special character can not be read correctly BY my computer.

So as far as i understood, this is not a problem at all, and i just have to ignore the error from my notepad.

Thank you both of you
__________________
  Reply With Quote

ESOUI » AddOns » AddOn Help/Support » Ainsi - Utf-8

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off