Quantcast Unable to Install/Update Addons - ESOUI
Thread Tools Display Modes
04/04/14, 04:41 AM   #1
Xyltin
Join Date: Apr 2014
Posts: 3
[Bug] Unable to Install/Update Addons

The Update and Install buttons next to the addon's name doesn't work. I can click them, but then it will load forever.

The Install button at the top right side of the addon description does work to install them.

The Autoupdate function has the same problem as the Update button. It will load forever.

For every update I have to uninstall the addon and re-install it with that button in the extra window.

Restarting Minion doesn't change anything.

Using Win7. Can't upload .log files, so i added .txt
Attached Thumbnails
Click image for larger version

Name:	Minion.jpg
Views:	196
Size:	181.2 KB
ID:	63  
Attached Files
File Type: xml minion.xml (1.0 KB, 205 views)
File Type: txt minion0.log.txt (8.9 KB, 158 views)
File Type: txt minion1.log.txt (160.9 KB, 159 views)

Last edited by Xyltin : 04/04/14 at 05:08 AM.
  Reply With Quote
04/04/14, 02:02 PM   #2
Zeo
Join Date: Apr 2014
Posts: 3
Same porblem here, (used to worke at some point in the past belived it was before I switched to EU version?)
Well anyway can't update and install addons...
OS is Win 8.1 (64-bit)
Attached Files
File Type: xml minion.xml (996 Bytes, 161 views)
File Type: txt minion0.log.txt (48.9 KB, 215 views)
  Reply With Quote
04/04/14, 02:04 PM   #3
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,189
Originally Posted by Zeo View Post
Same porblem here, (used to worke at some point in the past belived it was before I switched to EU version?)
Well anyway can't update and install addons...
OS is Win 8.1 (64-bit)
Your issue is a bit different that the OP's. If you remove this line from your minion.xml it should work:
Code:
<game addon-path="D:\Program Files (x86)\Zenimax Online\The Elder Scrolls Online EU" auto-update="false" game-id="ESO" ignore="true" unique-game-id="ESO-2"/>
If you dont want to edit your minion.xml let me know and I can edit it and attach it here and you can replace the file with my version. Or you can delete the minion.xml and reconfigure Minion (it will startup like it was just installed).

What the issue is your config has 2 games in the xml that have the same unique-game-id. We are working on a fix for this. It happens when you add/remove games from the game list. So when Minion goes to write to the config for unique-game-id ESO-2 it doesn't know which one to write to because there are two of them.

Last edited by Dolby : 04/04/14 at 02:11 PM.
  Reply With Quote
04/04/14, 02:06 PM   #4
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,189
Originally Posted by Xyltin View Post
The Update and Install buttons next to the addon's name doesn't work. I can click them, but then it will load forever.

The Install button at the top right side of the addon description does work to install them.

The Autoupdate function has the same problem as the Update button. It will load forever.

For every update I have to uninstall the addon and re-install it with that button in the extra window.

Restarting Minion doesn't change anything.

Using Win7. Can't upload .log files, so i added .txt
I don't see anything wrong with your minion.xml but could you please try deleting it and restart Minion?
  Reply With Quote
04/04/14, 02:14 PM   #5
Zeo
Join Date: Apr 2014
Posts: 3
Originally Posted by Dolby View Post
Your issue is a bit different that the OP's. If you remove this line from your minion.xml it should work:
Code:
<game addon-path="D:\Program Files (x86)\Zenimax Online\The Elder Scrolls Online EU" auto-update="false" game-id="ESO" ignore="true" unique-game-id="ESO-2"/>
If you dont want to edit your minion.xml let me know and I can edit it and attach it here and you can replace the file with my version. Or you can delete the minion.xml and reconfigure Minion (it will startup like it was just installed).

What the issue is your config has 2 games in the xml that have the same unique-game-id. We are working on a fix for this. It happens when you add/remove games from the game list. So when Minion goes to write to the config for unique-game-id ESO-2 it doesn't know which one to write to because there are two of them.
Thanks, did that and had still the same issue...
Removing the minion.xml file as you said in the other post did the trick, thanks
  Reply With Quote
04/04/14, 02:21 PM   #6
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,189
Originally Posted by Zeo View Post
Thanks, did that and had still the same issue...
Removing the minion.xml file as you said in the other post did the trick, thanks
Would you mind attaching your new Minion.xml (now that Minion is working for you) so I can compare? It would help me find the root cause.

Thank you
  Reply With Quote
04/04/14, 02:32 PM   #7
Zeo
Join Date: Apr 2014
Posts: 3
Originally Posted by Dolby View Post
Would you mind attaching your new Minion.xml (now that Minion is working for you) so I can compare? It would help me find the root cause.

Thank you
Sure can do, here it is:
Attached Files
File Type: xml minion.xml (817 Bytes, 167 views)
  Reply With Quote
04/04/14, 02:50 PM   #8
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,189
Thanks Zeo that helped. I didnt notice one other item that I should have asked you to remove.

This should all get better with our next release as we are overhauling the game detection system so it will detect EU automatically and the bug with the multiple same unique-game-id's will be fixed too.
  Reply With Quote
04/05/14, 12:13 PM   #9
Xyltin
Join Date: Apr 2014
Posts: 3
Originally Posted by Dolby View Post
I don't see anything wrong with your minion.xml but could you please try deleting it and restart Minion?
Seemed to work for the install button. Couldn't test the updat button till now.
Thanks a lot.

But after the first start (after deleting the .xml) it didn't find LootDrop and Foundry Tactical Combat, so I deleted them manually and reinstalled them. Only side not.
  Reply With Quote

ESOUI » Site Forums » Minion » Unable to Install/Update Addons

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off